Ubuntu 20.04 Testing week

Ubuntu Testing Week Starts Today!

Ubuntu and its flavors are participating in an Ubuntu Testing Week from April 2nd to April 8th. On April 2nd, we’ll be releasing the Ubuntu 20.04 LTS beta after halting all new changes and between then and the final release 3 weeks later, all efforts are focused on ISO testing, bug reporting, and fixing bugs.

Grab an ISO

Please join the community by downloading the daily ISO image from 1st April onwards and trying it out. There are a variety of testcases on the ISO tracker, which take less than 30 minutes to complete, so give them a try.

Get involved

If you are having difficulties, watch me do it in the videos below and join the tester community live in our IRC channel ( #ubuntu-quality on freenode ) or telegram group ( Ubuntu Testers ).

If you’d like to read up more on being a tester, visit the links below.

https://wiki.ubuntu.com/QATeam/Overview/NewTesters
https://wiki.ubuntu.com/Testing/ISO/Walkthrough
https://wiki.ubuntu.com/QATeam/DevelopmentSetup
https://launchpad.net/~ubuntu-testing
http://iso.qa.ubuntu.com/qatracker/reports/defects - list of known defects

10 Likes

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Just installed from Ubuntu 20.04 LTS “Focal Fossa” - Alpha amd64 (20200329)

After successful install on msg ‘continue test/restart now’ I select ‘restart now’ and I don’t see the message ‘remove install media’ but a black screen with vendor logo and ubuntu logo.

After system restart on the window ‘ready to go’ I click on ‘open software now’ nothing happen and the window ‘ready to go’ can not be moved, I can just click ‘done’ to close it.

I open snap-store and search for GIMP, i’m proposed just the snap version despite in the software repositories Focal(universe) is enabled.

I enter ‘ubuntu-bug -w’ click on snap store window and obtain a window with a long list of errors and the bug is not sent.

I was very happy with Ubuntu Focal until few days ago…

Looks like this bug: https://bugs.launchpad.net/ubuntu/+source/casper/+bug/1865161

Did you have an internet connection? I have seen that dialog be empty if there’s no network connection.

This is fixed in a later release, which hasn’t landed yet. You will get a drop down box in the top right which allows you to choose the source for applications.

Sadly ubuntu-bug doesn’t work on snaps yet.

I know the bug You suggest but seems a little different.
I have an internet connection working, I just installed downloading updates.
In the drop box from ‘hamburger’ icon top right I see Focal(universe) repository is enabled

Tried on USB live session using ISO from this link around 3 hours ago

http://cdimage.ubuntu.com/daily-live/current/focal-desktop-amd64.iso

I think memory consumption has gone less compared to 18.04 in 20.04. CPU usage has also felt lighter.

But I think I got a bug. When I finished the live session, used Shutdown option to come out. But even after 5 minutes + there was a black screen but nothing else. I got no alert about the old remove USB and press enter. Finally, I simply hit the space key and everything got off all by itself without any further notice.

In short, during my session, the getting out of the live session process was buggy. Thanks.

old bug reappeared at each ubuntu version https://bugs.launchpad.net/ubuntu/+source/casper/+bug/966480

1 Like

@popey the daily ISO image is now beta version ? If no, kindly share the link to download the beta version. Thanks.

Yup. Go via http://iso.qa.ubuntu.com/qatracker/milestones/411/builds to get the right ones for sure.

1 Like

I’ve just installed Ubuntu Beta and i spotted something that i consider a design flaw in Snap Store.
After i first opened it no results came up from any option given by the store. Clicking in any category gave me a blank page, and searching for anything also returns no result. To fix it i had to go to “Updates” tab and click in the “Update” button, to update Snap cache (i think).

I didn’t click in the “Go to the store” button in the welcome app, and before i opened it i had already installed some pkgs using “apt install”.

That’s not the best way to welcome new users. Maybe a forced update at some point after Ubuntu install may fix it.

I think perhaps you’re presuming a design flaw where there may just be a bug or glitch. The desktop store app has an architecture where a backend process does the store calls and the front end is a separate process which paints the UI on the screen. It’s possible the backend had a problem, or didn’t start, crashed, or otherwise didn’t update correctly. I wouldn’t necessarily say it was designed in such a way that you have to press the update button - you don’t. If it’s reproducible, then it likely is just a bug, and should be filed as such.

I’m sorry if i expressed myself wrong. I don’t know how the store works under hood. What i meant is that it gave me the feeling that i had to click something or to wait for a long time for the results to appear, which is really annoying. That’s why i said “i consider a design flaw”, but it may be a bug or simply a maladjustment of some script. I’m just reporting my thoughts.

Also, talking about the store, is there a way to accept “Classic mode” snap installations? For example, i want to install “node” snap version 12/stable, but i can’t do it via store because of the “Classic mode” error. It would be nice to have an option or a dialog to accept it.

Besides that, Ubuntu 20.04 is in really great shape! Congratulations to the whole team! I’ve been using it daily for some days and today i’ve reinstalled it with the Beta Iso, and so far i didn’t see major bugs. I confess i don’t use Ubuntu since it switched to Gnome, because it was too messy for me, but this one is making me scratch my head to switch again.

Oh, and if you grant me another wish, i would really like to see “Sound Input & Output Device Chooser” extension, or something like it, preinstalled with Ubuntu.

1 Like

This login loop is still there in the newest 20.04 beta. Removing “splash” from grub fixes the issue.
https://bugs.launchpad.net/ubuntu/eoan/+source/gdm3/+bug/1845801

With automatic login:
The first boot works fine. Rebooting after that takes me to the login screen and trying to log in does nothing.
Using the Nvidia proprietary driver that is on the newest ISO

When looking for applications in the Activities Overview, Snaps don’t seem to appear. I have been trying to search for some (like Slack, 0 AD, a.o.) randomly in the past couple of weeks, but to no avail.

I have submitted a bug about this for the GNOME Shell, but am now thinking that maybe the Snap-store maintainers should know about this in the first place.

Oh yes, also, none of the links to official websites work.

Installed Kubuntu 20.04 Beta minimal on
Asus C300 Bay Trail QUAWKS - sound card chtmax98090 (originally a Chromebook) -4GB ram, 32GB emmc

Installation process worked as expected.

The sound card is not detected.

The system is slow, krunner and plasma-shell are using 3-5% of the cpu almost constantly, with nothing but top running in a terminal.

On the same rig I’m running Debian Bullseye with Plasma, kernel 5.4, alsa ucm2 sound system as Focal: sound card working, system snappy, cpu in the same conditions 0.3-0.7%.

I used to run GalliumOS (bionic derivative) with Plasma desktop minimal same workload as Debian.

I hope this is helpful.

I’ve just installed the beta release on two machines and it works like a charm. :slight_smile: I’ve tried to add my test results to http://iso.qa.ubuntu.com/qatracker/milestones/411/builds/210065/testcases/1300/results

But there’s no “add result” button after I logged in. Any idea?

I’ve translated some missing Hungarian strings on Launchpad, when do you release a new translation package?

We have issue.

When we choose
Yangon/Myanmar Location
Mon (mnw_MM) is default.
Its must be Barmar / Myanmar (my_MM).

We have 135 Ethnics

  • 68% [Bamar]
  • 9% [Shan]
  • 7% [Karen]
  • 4% [Rakhine]
  • 2% [Mon]
  • 1% [Hindus]
  • 9% others

we have l10n in 2 group
my / bur (Myanmar) and shn (Shan)

we have glib locale in 3 group

  1. my_MM / bur_MM (Myanmar)
  2. shn_MM (Shan)
  3. mnw_MM (Mon)

now mnw_MM is default in locale

if we want to change Myanmar
we need to install my_MM / Burmese.
its difficult for endusers and wrong thing.

ref to wikipedia

Burmese

Recognised regional languages

  • [Kachin]
  • [Kayah]
  • [Karen]
  • [Chin]
  • [Mon]
  • [Rakhine]
  • [Shan]

[1] https://lh.2xlibre.net/locale/my_MM/

with regards.