New Unity7 based distro

Hi all. I’m new here, please bear with me!

I’ve created my own Unity based Ubuntu 18.10 distro, called synOS Canora.
Attached is a photo of the current alpha 3 build.
synOS Trident-2019-03-09-00-18-54

Using a customized version of Caja that works better with Unity and integrates well with the Dash. Caja works far better than Nautilus imo.
What do y’all think? And would anybody be willing to test this out?

EDIT Here’s a Google Drive link for alpha 3! https://drive.google.com/open?id=1qokgMfHJ1AEamWbTWWBfoxu9dnZ1qWbg

6 Likes

I’d be happy too in my free time.

hey dude, thanks for the quick reply! I’ll be building an ISO right now and will post a Google Drive link here when ready. Please do report any bugs!

Looks great!
Do you plan to release your changes as packages in the specially created dedicated PPA on LaunchPad?
Do you plan to share the instruction how to transform ordinary Ubuntu to your distro?

Too much Ubuntu derivatives exist right now - both Unity-based and MATE-based.
How does you distro is different from them?
Where do you plan to host its packages?
How can we check your distro for malware? Or how can we check package validity?

Oh, it’s no pleasure. I just checked once I came home because im awaiting a reply from a message I sent to a canonical employee.

But, if you add lots of changes to synOs, then you MIGHT be able to score it on Wikipedia’s Linux-based distrobution timeline.

Good luck!

No, as I don’t know how to :frowning:

If anyone asks then yes!! I surely will, that’s the beauty of open source :smiley: although some of the changes include heavy modification to packages from upstream, but yes I can!

Well, first off I DID check distrowatch for Unity based distros. They were too specialized for the end user, is what I’ve observed. My distro is more of a stock Ubuntu install - plus tweaks. This distro runs Unity, is running the latest kernel out-of-box, has patches to fix all issues with Unity7 and GNOME packages conflicting and/or causing UI glitches, and additionally replaces some featureless or conflicting GNOME packages, namely Nautilus and EyeOfGnome with a custom version of Caja and Mirage as they blend better with the Unity GUI and offer additional features on top of being user-friendly. Lastly the distro has been themed on a skeuomorphic - not flat theme as it in my opinion looks better. The end goal of my distro is to provide a beautiful, easy to use distro for users.

The custom packages? Maybe launchpad? If I can figure out how to :frowning: the distro on Google Drive.

I… really do not know how! Maybe you can make me prove to you this isn’t any infected distro! I will provide ISO Links, and you may test it in a virtual machine environment!

And thank you so much for your support!!

2 Likes

@itzswirlz @Norbert Edited this post to add the link!

For reference, this is how the default live CD boot should look like:
synOS Trident-2019-03-09-03-31-29
Once again, please do report bugs!

Alright thanks, downloading it now!

(I will probably look at it when I come back from dance class at 8:30 PM EST

Alright dude, thank you so much!
As for me, I’ll be sleeping, its 3:42 AM IST, I’ve worked on this way too much XD
See you soon!

@lumosphenom64
Will be checking yours tomorrow. Had been watching Cricket the whole day today, just looked in.

Btw, I have a 19.04 on Unity7 (and an Ubuntu default one also, and few others) with Nemo as the default file manager. Completely without Nautilus. One day, I’d upload them.

Btw, 19.04 differs a lot from 18.10. Anyway, it is good that you created this distro. Maybe, (hope) some others would start doing the same. It is time for some remasters/remixes to come about, bring in some life.

@lumosphenom64 OS won’t boot, something is probably wrong with the way the ISO was compiled.

But once its ready, I think it will be awesome.

@lumosphenom64

Writing from your Unity7 remix Live. Took a bit of a time to boot. (Didn’t matter, as I am watching Cricket today too.) Booted to a good old Ubuntu!

  1. Make your own apps to appear in the Unity launcher. There’s Nautilus icon still there, which would open it, claiming it is opening the Trash. Put Caja there. Btw, it is called DocSurf. Also, uninstall (or hide) Nautilus.

  2. All other apps opens quite fast, as they should be. I notice that there are no snaps, which is good, as Calculator and System Monitor opens faster than in 19.04 where they happen to be installed as snaps.

  3. Pinguy Builder doesn’t appear to keep your settings, when building the iso. Try rsync. Or, manually do the steps from Pinguy builder/Remastersys.

You are using ubuntu-unity-desktop to get unity 7 working in your remix. So, contact @khurshid-alam, who actually creates and maintains it. Have a look at this thread, and this and this from the beginning. And, join this team.

18.10 is going to live only for next 3 months, so maybe best put your efforts on 19.04 and then on 19.10.

1 Like

Where are you testing this on? Is it VMware or VirtualBox? What settings are you using and have you set the BIOS to boot from CD?

Hey dude thank you so much for your help! I really appreciate it!

Huh, can I have a screenshot of the default live desktop/or installed desktop? Also, I’ve tried to when I got similar issues in another virtual testing session but I do not know how to completely switch to Caja over Nautilus. The name change to DocSurf was purely due to issues with the xdg-mime query default inode/directory returning org.Gnome.nautilus.desktop instead of mate.caja.desktop However this caused even more issues such as the trash starting nautilus and not caja (hence nautilus calling itself trash). I do not know how to completely remove nautilus and replace it with caja, although I’ve been trying since last night. If you could, please do help me on how to make caja the default, replacing even the trash

Ah, this is because I used the ubuntu-server codebase rather than the ubuntu-desktop codebase, so I can start without the GNOME environment, and have a minimum install base. However I found that this causes the sudo command to take unnecessary amounts of time to compute and the boot time to be doubled along with firefox hanging sometimes. Presumably because of security, but now in the next build of synOS Canora I’m going to be using the ubuntu-desktop codebase, for added speed.

Thank you so much! That’s exactly what I will do now.

@lumosphenom64 http://prntscr.com/mvgqzg

Your Optical drive is on IDE but your hard drive is on SATA. Try switching your optical drive to SATA, and see if it runs!

It didn’t work on SATA, but when I switched the hard to IDE it worked. You might want to fix that on final release.

Live desktop and DocSurf

docsurf

I am not going to use Caja, but Nemo over Nautilus, so can’t help much with using Caja.

I did that in both Ubuntu Unity and default Ubuntu, but simply can’t remember how today. Best you should invest your energies to create the live iso with 19.04 than 18.10. Ubuntu had linked some folders in root to /usr, just like it was done in Arch long time ago. And, also 18.10 is practically dead.

Hope you’d read the thread testing-unity-session-in-19-04 from the beginning, you would see what we have been experimenting on. You can also build with the mini iso on UEFI.

I downloaded the ISO:

$ md5sum synOS-Canora_build09032019_1.0-idx02_lab06n.iso 
cfcd7270dd1a6488d964e16fe9572fed  synOS-Canora_build09032019_1.0-idx02_lab06n.iso

$ sha256sum synOS-Canora_build09032019_1.0-idx02_lab06n.iso 
5ff5e6cfae70c09b672ccb7d060b9668bf509fefeb9cc356c857e7165be1d4c0  synOS-Canora_build09032019_1.0-idx02_lab06n.iso

1. Boot

1.1. VirtualBox

TL;DR - does not boot, stalls at Begin: Regenerating SSL certificate.

I tried IDE, SATA, SCSI and SAS for optical drive on my VirtualBox 5.1.38 host - SynOS does not start: shows text Plymouth screen with dots:

Ubuntu 18.10
. . . .

While booting verbose mode (verbose noplymouth INIT_VERBOSE=y instead of quiet splash) - the longest process is:

Begin: Regenerating SSL certificate... ...

this steps stalls for 15 minutes. I’m using SSD, so speed is not a problem. Other VMs work normally.

1.2. KVM

TL;DR - boots only with UEFI.

Also it does not start from KVM with:

sudo kvm -m 1536 -cdrom synOS-Canora_build09032019_1.0-idx02_lab06n.iso

It boots only with UEFI after installation of OVFM (sudo apt install ovmf) from Virtual Machine Manager.

2. Analysis of the system

2.1. Live mode

The Live version has 8 nautilus-related packages:

$ dpkg -l | grep nautilus | wc -l
8

The http://syndromatic.tk does not contain any relevant information to synOS.

I can’t get the idea behind renaming Caja to DocSurf.

2.2. Installation

Casper and Ubiquity worked as expected.

2.3. First boot

But after reboot I have strange window named Install with Try Ubuntu and Install Ubuntu.

Click on Try Ubuntu ends with showing of LightDM greeter (expected behavior).

Clicking on Install Ubuntu starts installation wizard. It is completely unexpected for installed system. Next reboot ends with the same Install window.

You should not have ubiquity package in installed system!

So I purged all ubiquity-related packages with sudo apt purge ubiquity*.

2.4. Next boot and analysis of packages

The Unity is installed as if one will install ubuntu-unity-desktop.

The hostname is ignored, sets itself to default synos-trident.

System comes with preinstalled openssh-server, this is not good idea. Also you have broken host keys here. So I purged SSH Server with sudo apt purge openssh-server.

The system is booted with Linux 5.0, which is not yet released in Ubuntu:

$ uname -a
Linux synos-trident 5.0.0-050000-generic #201903032031 SMP Mon Mar 4 01:33:18 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

$ ls /boot/
config-4.18.0-15-generic     initrd.img-4.18.0-15-generic     memtest86+_multiboot.bin         vmlinuz-4.18.0-16-generic
config-4.18.0-16-generic     initrd.img-4.18.0-16-generic     System.map-4.18.0-15-generic     vmlinuz-5.0.0-050000-generic
config-5.0.0-050000-generic  initrd.img-5.0.0-050000-generic  System.map-4.18.0-16-generic
efi                          memtest86+.bin                   System.map-5.0.0-050000-generic
grub                         memtest86+.elf                   vmlinuz-4.18.0-15-generic

$ dpkg -S /boot/vmlinuz-5.0.0-050000-generic
linux-image-unsigned-5.0.0-050000-generic: /boot/vmlinuz-5.0.0-050000-generic

$ apt-cache policy linux-image-unsigned-5.0.0-050000-generic
linux-image-unsigned-5.0.0-050000-generic:
  Installed: 5.0.0-050000.201903032031
  Candidate: 5.0.0-050000.201903032031
  Version table:
 *** 5.0.0-050000.201903032031 100
        100 /var/lib/dpkg/status

The linux-modules-4.18.0-10-generic with /lib/modules/4.18.0-10-generic is unneded as there is no kernel in /boot.

Packages

The system is shipped with locally installed packages:

$ sudo aptitude search ~o
i   libgnome-desktop-3-12                                              - Utility library for loading .desktop files - runtime files                  
i   linux-headers-5.0.0-050000                                         - Header files related to Linux kernel version 5.0.0                          
i   linux-headers-5.0.0-050000-generic                                 - Linux kernel headers for version 5.0.0 on 64 bit x86 SMP                    
i   linux-image-unsigned-5.0.0-050000-generic                          - Linux kernel image for version 5.0.0 on 64 bit x86 SMP                      
i   linux-modules-5.0.0-050000-generic                                 - Linux kernel extra modules for version 5.0.0 on 64 bit x86 SMP              
i   orta-settings-manager                                              - Settings manager for the Orta gtk theme                                     
i   orta-theme                                                         - the Orta gtk theme and Metacity decorators                                  
i   pinguybuilder                                                      - This script creates a livecd of the installed system and works with *buntu s
i   spectrum-plymouth                                                  - Install Spectrum plymouth in Ubuntu                                         
i   vertex-theme                                                       - Vertex is a theme for GTK 3, GTK 2, Gnome-Shell and Cinnamon       

and several PPAs:

$ grep -r -v ^# /etc/apt/ --include="*.list"
/etc/apt/sources.list.d/noobslab-ubuntu-themes-cosmic.list:deb http://ppa.launchpad.net/noobslab/themes/ubuntu cosmic main
/etc/apt/sources.list.d/teejee2008-ubuntu-ppa-cosmic.list:deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu cosmic main
/etc/apt/sources.list.d/noobslab-ubuntu-icons-cosmic.list:deb http://ppa.launchpad.net/noobslab/icons/ubuntu cosmic main
/etc/apt/sources.list.d/unity7maintainers-ubuntu-unity7-desktop-cosmic.list:deb http://ppa.launchpad.net/unity7maintainers/unity7-desktop/ubuntu cosmic main
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic main restricted
/etc/apt/sources.list:
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic-updates main restricted
/etc/apt/sources.list:
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic-updates universe
/etc/apt/sources.list:
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic-updates multiverse
/etc/apt/sources.list:
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic-backports main restricted universe multiverse
/etc/apt/sources.list:
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu cosmic partner
/etc/apt/sources.list:
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic-security main restricted
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic-security universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu cosmic-security multiverse

$ aptitude search '~O LP-PPA' | grep ^i
i  arrongin-telinkrin-themes - Arrongin and Telinkrin theme uploaded on NoobsLab.com PPA
i  faenza-icon-theme - Faenza Icon Theme
i  libunity-control-center1 - utilities to configure the GNOME desktop
i  libunity-settings-daemon1 - Helper library for accessing settings
i  obsidian-1-icons - Obsidian-1 Icons uploaded on NoobsLab.com PPA
i  ubuntu-unity-desktop - The Ubuntu Unity desktop system
i  ukuu - Kernel Update Utility for Ubuntu-based distributions
i  unity-control-center - utilities to configure the GNOME desktop
i  unity-settings-daemon - daemon handling the Unity session settings

including UKUU

$ apt-cache policy ukuu
ukuu:
  Installed: 18.5.1-0~201805120527~ubuntu18.10.1
  Candidate: 18.5.1-0~201805120527~ubuntu18.10.1
  Version table:
 *** 18.5.1-0~201805120527~ubuntu18.10.1 500
        500 http://ppa.launchpad.net/teejee2008/ppa/ubuntu cosmic/main amd64 Packages
        100 /var/lib/dpkg/status

which is dangerous for end-user as it provides not-tested kernels.

The installed system contains many development packages with headers:

$ dpkg -S /usr/include/ | sed "s/,/\n/g" | grep "\-dev" | wc -l
66

$ du -sh /usr/include/
43M	/usr/include/

and development tools such as build-essential, g++, g++-8 but they should not be installed by default on the system.

Debsums

Debsums says that you have modified some config files:

$ sudo debsums --config --changed
[sudo] password for synos:      
/etc/lsb-release
/etc/casper.conf
/etc/PinguyBuilder.conf
/etc/sysctl.d/10-ipv6-privacy.conf
/etc/sudoers

The /etc/lsb-release came from base-files, its contents are:

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.10
DISTRIB_CODENAME=cosmic
DISTRIB_DESCRIPTION="synOS Canora"

I’m not sure, but looks like copyright violation.

The /etc/casper.conf came from casper package, it is not expected to be in installed system.

The /etc/PinguyBuilder.conf came from pinguybuilder, which is locally installed.

The full scan gives the following result:

$ sudo debsums --all --changed
/usr/lib/os-release
/etc/lsb-release
/usr/share/applications/caja-browser.desktop
/usr/share/applications/caja-folder-handler.desktop
debsums: missing file /usr/share/applications/caja.desktop (from caja package)
/usr/share/initramfs-tools/scripts/casper-bottom/25adduser
/etc/casper.conf
/usr/share/applications/eog.desktop
debsums: Error: symlink loop detected in path 'usr/share/icons/hicolor/256x256/apps/ubuntu-logo-icon.png'. Please file a bug against gnome-control-center-data.

Here - in /usr/lib/os-release we have copyright violation.

The /usr/share/applications/caja-browser.desktop and /usr/share/applications/caja-folder-handler.desktop are changed to have DocSurf name.

The error messaga about ubuntu-logo-icon.png was fixed by reinstallation of gnome-control-center-data package, so we will continue:

$ sudo debsums --all --changed
...
/usr/share/unity/icons/launcher_bfb.png
/usr/share/applications/mirage.desktop
/usr/share/applications/org.gnome.Nautilus.desktop
/usr/share/icons/Obsidian/.icon-theme.cache
/sbin/mount.vmhgfs
debsums: Error: symlink loop detected in path 'usr/bin/vmhgfs-fuse'. Please file a bug against open-vm-tools.

Here the /usr/share/unity/icons/launcher_bfb.png came from libunity-core-6.0-9, but you have overwritten this file with your logo.

The symlink loop is fixable after reinstallation of open-vm-tools package. Let’s continue:

$ sudo debsums --all --changed
...
/usr/share/plymouth/themes/ubuntu-logo/ubuntu-logo.png
/etc/sysctl.d/10-ipv6-privacy.conf
/etc/sudoers
/usr/share/unity-control-center/ui/UbuntuLogo.png
/usr/share/unity-greeter/logo.png

Here you have changed /usr/share/plymouth/themes/ubuntu-logo/ubuntu-logo.png, /usr/share/unity-control-center/ui/UbuntuLogo.png, /usr/share/unity-greeter/logo.png.

Scanning the system for non-deb stuff with

sudo find /bin /etc /lib /lib64 /opt /sbin /srv /usr /var -type f -exec dpkg -S {} \; 2> ~/Desktop/results.out

gives the following results:

  • /etc/vmware-tools, /usr/bin/vmware-uninstall-tools.pl, /usr/bin/vmware-config-tools.pl, /usr/lib/vmware-tools - the parts of VMWare guest tools, should not be installed with the system;
  • /etc/PinguyBuilder - part of locally installed PinguyBuilder
  • /etc/skel/.config and /etc/skel/.local - parts of your user profile, should not be customized this way, should not be in the installed system
  • /etc/python3/debian_config - leftover
  • /etc/systemd/system/snap* - leftovers
  • /etc/network/if-pre-up.d/mtuipv6 - leftover
  • /etc/network/if-up.d/mtuipv6 - leftover
  • /etc/network/if-up.d/update - strange file with apt update command, should not be included in installed system
  • /usr/local/share/fonts/.uuid - leftover
  • /usr/share/lightdm.sh - leftover
  • /usr/share/icons/pixelfun3 and /usr/share/themes/pixelfun3 - leftovers
  • /usr/share/themes/poppy, /usr/share/themes/Mc0S-Color-Concept - leftovers
  • /root - leftovers
  • /usr/share/sounds/ubuntu/stereo/synos-desktop-login.ogg - login sound theme

All parts marked as leftover(s) should not be included in installed filesystem.

Conclusion

IMHO this looks more like copyright changing, than creating new functionality or bringing new life to Unity 7.
I do not find any reason to use this repack of Ubuntu.The OP should change the vision and/or the production method.
Everyone can get such a system from mini.iso by installing ubuntu-unity-desktop, removing nautilus and installing caja in it.

2 Likes