Testing Unity Session in 18.10

Hi,

Unity is running fine on 18.10. You can try by installing ubuntu-unity-desktop. Please file a bug against respective package if you find any. There are some problems with media keys which will be fixed later.

It is still using Ambiance as default theme.
We are again switching back to totem as gnome-mpv has some problems. Other than that there are no other significant changes.

Update:

The PPA has now been updated. It contains

  1. Fix for broken sharing panel
  2. unity-settings
  3. An update with ubuntu-unity-desktop (totem returns)

FTBFS
indicator-sound is still not compiling due to same glib regression.

Thanks.

3 Likes

I’m testing ubuntu-unity-desktop under 18.10 in a virtual machine (virtual box). Contrary to what I said in a previous message, now I’m seeing some broken icons both in the launcher and the Dash. For instance all the icons for LibreOffice are not showing up. Initially in the launcher the LibreOffice icons show OK, but once one of the application is opened, for instance CALC, the icon in the launcher is not shown any more, but a generic grey icon appears. Restarting the session restores the correct icons for LibreOffice in the launcher.

As usual, I move my Ubuntu to the next development release (In this case 18.10) within few weeks. I don’t really have any real (valid) reason to stay with the “stable” release. The development release should work, or…well. There had been an interesting crowd to discuss “problems” and some ideas in another forum for a long time, but now they are gone, since 17.10 slowly changed the default DE.

Anyway, Unity is working quite well with 18.10. Only, I didn’t install Unity over the default Ubuntu, but started from scratch. I even experimented on installing Unity over Xubuntu. That too works quite well, actually much better than installing over the default Ubuntu 18.10.

Ah, about app icons not showing or grey, etc. I just add whatever icons I need, either to usr/share/icons or usr/share/pixmaps and change the .desktop files, where needed. I don’t use LibreOffice, btw.

Mine is an experimental install nowadays. I don’t use Ubuntu any more as the distro for daily work.

I actually tried the same thing. Which software did you use?
I tried to change the kernel but it didn’t work for me.

The live usb contains /casper/vmlinuz and /casper/initrd.lz. I picked vmlinuz, initrd-x.x.x-generic from my own system (from /boot) and then repacked as initrd.lz and then copied them to /casper on usb. I also changed the kernel in filesystem.squashfs (unpack and repack). But even then it did not work. Do you know any method to change the kernel from live persistent usb ? Just the kernel, not anything else.

I simply installed Xubuntu and installed unity over that.
If you want to manipulate the live iso, only take the filesystem.squashfs, unpack it, install unity on that in chroot, even uninstall xubuntu-desktop if you want, then pack it back. Put it back in casper and create the iso. Don’t change anything other than the filesystem.squashfs.

If you look in the /boot in the unpacked root system, (squashfs-root), there are no vmlinuz, initrd-x.x.x-generic. The live iso would boot with the /casper/vmlinuz and casper/initrd.lz, which we don’t need to change at all.

IF you mount squashfs with disk image mounter you will see initrd link in root dir. It points to /boot/initrd…but I think that’s an error. Those links are invalid. That’s why when unpacking it skips those links.

I need patched kernel for my rizen 5 machine. So when I test iso in vm it doesn’t really work. I was thinking a better way just to change the kernel without going through that lengthy process again again. But I guess askubuntu is better for this type of question.

@khurshid-alam

Just downloaded Xubuntu 18.10 daily to have a look. There is no initrd.lz in casper any more, but just initrd, without the .lz extension. Its OK as in Linux, you really don’t need an extension as in Windows. Here with the Xubuntu live iso, we are sort of not given the chance to find out what compression is used to pack that “initrd.” Actually, what compression was used is not a big deal, if you want to create a live iso, 1) you can use the vmlinuz and initrd as they are, or 2) add updated/upgraded ones without any extensions. (Or, you can add any extension you want, even .exe… he, he, just for fun…)

Most probably, your Ryzen 5 is on UEFI, so if you boot Xubuntu 18.10 live, it’d use /boot/grub/grub.cfg to look for what to boot with. This is what it tells,

if loadfont /boot/grub/font.pf2 ; then
set gfxmode=auto
insmod efi_gop
insmod efi_uga
insmod gfxterm
terminal_output gfxterm
fi

set menu_color_normal=white/black
set menu_color_highlight=black/light-gray

set timeout=5
menuentry “Try Xubuntu without installing” {
set gfxpayload=keep
linux /casper/vmlinuz file=/cdrom/preseed/xubuntu.seed boot=casper quiet splash —
initrd /casper/initrd
}

I’ll give you a detailed how-to tomorrow (or on Monday) on manipulating the live iso and creating your own, when I’d be back using the other laptop.

@khurshid-alam
I’d like to know, if you want that how-to, for it takes some writeup.

Now I have tested upgrading a system with Ubuntu 18.04 and ubuntu-unity-desktop to 18.10, and it has worked well. Unity is still working well, except for the problem of the application icons showing gray in the launcher after the first run or showing gray all the time in the dash.

The icon problem is due to glib gicon regression. Will be fixed in glib soon.

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1792758

Great, thanks, that’s the only glitch I can see so far. Is it worth it to open a launchpad ticket to update “18.04” to “18.10” in the lightdm initial screen (unity greeter I think)?

Right. It is indeed. I opened a merge for that. Thanks.

I created the bug report:
https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1793663

The icon problem has been fixed, now icons are rendered correctly both in the Dash and the Launcher.

1 Like

@walter-garcia

Does compiz-config-settings-manager (install it if you haven’t) show any icon for you ?

Yes, it does, it shows the correct icon.

1 Like

No, I mean open the app. Does it show all the icons inside?

I confirm, the icons inside CCCM once you open it are not showing in 18.10. They are showing correctly in 18.04.

1 Like

Update:

The PPA has now been updated. It contains

  1. Fix for broken sharing panel
  2. unity-settings
  3. An update with ubuntu-unity-desktop (totem returns)

indicator-sound is still not compiling due to same glib regression.

Will those fixes come to 18.04 or are they 18.10 specific?