Testing Unity Session in 19.04

Not really. Gives option to disable nemo handling the desktop via ‘startup applications’ if desired.

For me the biggest issue with nemo in a unity session is the busy cursor when using one of the quicklist items
(the default nemo.desktop has a pitiful desktop actions list but still… certainly more apparent if creating a better nemo.desktop
Can be ‘fixed’ in compiz but don’t see that happening officially

Never used Dropbox. I use OneDrive sometimes, in both Linux and Windows, never for important files. I connect through a web browser in Linux.

What is the fix, and how to do that unofficially in compiz?

Merry Christmas everyone!!!


You’d need to patch the compiz source & then build. However a local package build (preferred method) will fail on the xorg-gtest tests (about 32 out of 1519 tests, apparent permissions issue)
So you’d have to either fix that? or disable the xorg-gtest tests (-DBUILD_XORG_GTEST=OFF) or build as root. One of the former 2 is better than last option.
patch I made is here, https://paste.ubuntu.com/p/wfrQdQn7vm/

(- the advisability of patch is unknown to me, haven’t seen any issues in 18.04 or 19.04
Basically adding back xext over xi. This goes back many years ago where to fix an obscure bug someone added xi & removed xext. This created a new obscure issue, never addressed & over several Ubuntu releases that issue seemed to go away. The busy cursor run-on came back in 18.04 for nemo on static quicklists in a unity session, restoring xext fixed for me

After reading some older blog posts, I found that you can use the mini.iso on an uefi system. All you have to do is extract the mini iso to a folder and chown it, then open the /boot/grub folder and mount the efi.img with archive mounter and then copy the resulting efi folder to that extracted folder. Then copy the contents of that folder with the extracted mini.iso and the efi folder to a fat32 usb stick. Then you can boot it normally in an uefi laptop.

extracted mini iso plus efi folder

When you extract the mini.iso, you won’t see the efi folder. You mount the efi.img to get at it. Then paste it. Then boot the mini iso in an uefi laptop/desktop, then install it and do as @manbutu had shown to get a pure ubuntu-unity-desktop.

Where are the custom PPAs or anything. If I want to submit changes to unity I dont suppose that itll be merged on the launchpad

I suppose, you can download dropbox integration packages from here.

It’s just a matter of installing the nemo-dropbox-extension & having dropbox installed.
The Cinnamon Stable PPA has various versions of the extension. One likely doesn’t need to add the ppa nor particularly match nemo & extension versions, just dl the package & install via apt.

If you want to submit a patch you can send them on the mailing list (you need to subscribe first), or you can open pull request on launchpad (unity now moved to git) . For bzr based repos you can open merge request at launchpad.

Is it possible to not to place Nautilus, Gedit, Firefox as dependencies in ubuntu-unity-desktop and/or in unity or unity-session?

No. ubuntu-unity-desktop doesn’t actually depends on it, it pulls them. unity-session depends on unity, unity recommends nautilus. So use --no-install-recommends

Nautilus is there in --no-install-recommends

$ sudo apt install ubuntu-unity-desktop --no-install-recommends

[sudo] password for ....: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
...metacity-common nautilus nautilus-data notify-osd....

This is the depends part, right?

$ sudo apt install unity-session --no-install-recommends

only nautilus-data is installed as dependency. Same with installing unity with --no-install-recommends.
No idea why nautilus-data is needed anyway for unity to work.

I am trying this on the install I have now with ubuntu-session without Nautilus.

Unity-settings-daemon pulls nautilus-data which install gschema. Without it u-s-d will crash and you won’t be able to login. Beside nautilus is burried deep in unity ( launcher progress bar, launcher-trash, quicklists, unity-lens-files, zeitgeist integration, hud, bamf, indicator-appmenu, etc…it’s everywhere). You can’t have productive desktop without it. Unity may crash or spams syslog heavily. However you can have a different filemanager with parts of nautilus installed.

Maybe, just nautilus-data is buried deep in unity, not nautilus itself. In the other (ubuntu default) install, both nautilus and nautilus data are uninstalled, and it is working. Here in unity, I can get nautilus out, but not nautilus data. Doesn’t matter, really.

Btw, once back in Unity, don’t feel like going back to that install at all. :slight_smile:
Except to the Openbox one.

There’s also something Unity settings has that Gnome settings doesn’t, locking the laptop, when the lid is closed. But, both doesn’t have adjustment of low battery level for notification. @khurshid-alam is there a possibility to add that adjustment to the Unity settings? I do it manually by changing the /etc/Upower/Upower.conf > PercentageLow=10 to 18. If this parameter change can be linked to the settings, it would be nice.

Btw, is there notifications in Unity Settings?

Hmm, u-s-d still has the code but latest upower ignore all the settings. I thought this is only my laptop since it has poor battery but it seems a bug…so answer this questions…

  1. Does it show a notify-osd when battery level reached critical ?

Try changing percentage-action, percentage-critical from dconf-editor (org.gnome.settings-daemon.plugins.power)

  1. Try both org.gnome.settings-daemon.plugins.power use-time-for-policy false/True

  2. If that doesn’t work then try changing upower conf.

  3. Set critical battery action suspend (org.gnome.settings-daemon.plugins.power critical-battery-action). Does it work ?

Upower.conf change didn’t work with Unity, but worked with Gnome-shell and Budgie.

I changed the current value in percentage-low in (org.gnome.settings-daemon.plugins.power) from 10 to 18, but have to wait until next battery drop.

In percentage-critical, the values is 3, what does that mean?

(What a mess Gnome is doing, really? Don’t they know that people use laptops, even in offices, not desktops these days? Committing suicide, most probably.) I put that in brackets, for it is just ranting. :slight_smile:

In Openbox, I am using xfce4-power-manager and I don’t have any problems with locking on closed lid or notifications of low battery and changing the critical battery level. Do you think, can we just drop gnome power manager and use xfce4 one instead in Unity?

Didn’t work with changing the default value to false, either. Didn’t work with the default value too.

Setting it to suspend didn’t work too.

It just went pass 18% without any notification and the laptop went off around 16%.

EDIT: Setting it to ‘interactive’ worked. Got back the fine old unity notification with sound!

No. xfce probably using upower < 0.99 with #ifdef, that’s why it is probably working, Or if they adapted to upower > 0.99 the we could use that code in u-s-d power plugin.

You don’t have to wait. You can set very high value depending on current battery charge, just for testing.

What ? !! Screenshot ?

Here is the screenshot,