Foundations Team Updates - Thursday 8 Jun 2023

The previous status is here: Foundations Team Updates - Thursday 1 Jun 2023

1 Like

gnome-42-2204-sdk snap

  • Enable building the gnome-42-2204-sdk snap for riscv64. PR 145
1 Like


  • Started upstreaming Ubuntu delta to Debian:
  • Set-up salsa-ci
  • Uploaded grub2 2.06-2ubuntu18 that
    • fixes riscv64 builds hopefully
    • drops i386 builds for unsigned
    • turns the dependencies on grub2-unsigned unversioned such that we can update src:grub2 without also needing to issue new grub2-unsigned
  • Submitted ESM signing request for 2.04-1ubuntu47.5 (pro/2)
  • Submitted Core signing request for 2.06-2ubuntu14.2 (core/2)

uefi misc:


  • verified fwupd-efi fwupd-signed SRUs across all releases

fwupd OEM:

  • unrelated to my uploads, for the OEM team uploads to src:fwupd, I removed obsolete block-proposed-* tags from LP#1994143, it was for a previous upload that only fixed the test suite and now blocking LP#1983451


  • ubuntu-sponsors
1 Like


  • Currently drafting a spec for making versioned Rust toolchains for matching other toolchains
  • Working on reviving several Cargo related MIRs (LP#1993819 LP#1990655)


  • Currently investigating and fixing armhf time_t ABI checking issues
1 Like


armhf time_t

1 Like


  • New 1.19.10 & 1.20.5 release
    • Uploaded to Debian and synced to Ubuntu mantic
    • Updated golang-fips PPA
    • Updated Go snap for both standard and fips tracks

armhf time_t

  • Working on armhf_time-t compilation failures - batch 26
1 Like



  • Conducted an interview
1 Like


  • processing removal requests
  • rerunning process-removals for Debian removals
  • removing NBS kernels from trusty (still running)
  • component-mismatches cleanup


  • Full SRU rotation Friday


  • First shift in the new Patch Pilot setup!
  • armhf time_t reviews and fixes
  • submitted patches to Debian for 64-bit time_t support in dpkg-buildflags
  • published gu-build helper to expedite git-ubuntu merges
  • drove SRUs of debootstrap and ubuntu-dev-tools
1 Like
1 Like

subiquity / curtin

  • fixed list of available third-party drivers incorrectly returned as empty while the list is still being fetched LP: #2023265
  • opened initial PR to list OEM meta-packages. More to come in the coming days.
  • discussed the ability for users to reuse a /boot partition without formatting. This caused the initramfs from other OSes to be regenerated by curtin => going forward, the installer will prevent such configuration
  • spec work for OEM / ubuntu-drivers


  • working on merge for dbus
1 Like
  • subiquity
    • PR: 1689 - add enough infrastructure to allow ZFS rootfs autoinstall.
    • PR: 1687 - fix a footgun where configuring cloud-config for the install session with no default user would crash subiquity. (Not a cloud-init bug)
    • File LP: #2022102 - autoinstall with Mantic by way of cloud-init is broken right now. Cloud-init to provide a more intentional location for apps like Subiquity to retrieve the merged cloud-config.
  • proposed-migration: dgit vs git (LP: #2022096) - Upload a patched dgit to disable some tests.
  • Cleanup of LP: #2020402
  • travel booking
  • greenhouse
1 Like


  • LP: #2023016 Merge 13.2-1 into mantic
    • In Progress
  • LP: #1992947 gdb fails in Ubuntu-22.04
    • New -> Incomplete (reporter did not respond)
  • LP: #1332484 GDB Demangler crashes in 14.10 and 14.04
    • Confirmed -> Incomplete (could not be replicated in recent versions)
  • LP: #1131841 gdb run as root: untrusted .gdbinit causes malloc arena corruption crash
    • Confirmed -> Incomplete (could not be replicated in recent versions)
  • LP: #1902225 SRU: update gdb 8.1.1 for 18.04 LTS
    • New -> Invalid (already marked as “Fix Released” for bionic)
  • LP: #1390905 gdb list not from the first line
    • Confirmed -> Invalid (intended behaviour)


  • LP: #138307 unzip manpage does not document -O and -I options
    • In Progress
1 Like
  • glibc
    • Trying to get the Jammy and Focal SRUs through the door. This saga keeps having new twists and turns to it! The Jammy SRU is now in -proposed, and some good souls are already verifying their issues :slight_smile:
    • Preparing a snapshot for the upcoming test rebuild
  • Netplan
  • Misc
    • Reviewed quite a few take-home tests that were languishing in my queue.
1 Like
  • Revised lvm2 merge (LP: #2020464)
  • Take home test
  • Checked ubuntu-image 3.0 based images for rpi (server mildly broken, desktop very broken)
  • Take home test
  • Some research related to an old debhelper fix (LP: #2019089 after LP: #1959054)
  • Another take home tests
  • Updated rpi-imager to 1.7.5 in mantic (LP: #2009581)
  • Yet another take home test
  • Pi meetings
  • Did I mention the take home tests?
  • Patch pilot shift
  • … if I see another take home test … eye twitches
1 Like

armhf time_t analysis

  • add parallelization of abi-compliance-checker calls (up to 2.5x speedup on CPU-intensive jobs)
  • add the ability to split packages; this is needed when there are incompatible or when a package is to big; if a sub-package exhibits ABI breaks other sub packages are skipped (this makes it possible to “finish” huge packages like libclang-1[45]-dev which cannot be analyzed in full)
  • fixed analysis of several packages


  • worked on the application of Foundations to bug control
  • more clean up of tickets on LP for openssl
1 Like


  • Reviewed an MP from @andersson123 which adds a --dry-run mode to seed-new-release as that is something that times out for us regularly when opening adding a new release to the autopkgtest environment.
  • Updated novarcs.tar (openstack / nova environment variable files) on wendigo for staging to include lcy02 and drop lcy01.
  • Setup lcy02 (PS5) amd64 test runners in the staging prod-proposed-migration environment, so that staging and production are the same.
  • Submitted an MP about autopkgtest-cloud and OpenStack rc files.
  • Submitted an MP regarding updating the “Supply secrets” portion of the documentation for mojo and juju.
  • Reported a bug regarding expanding the number of people who can retry autopkgtests.
  • Submitted a canonical-is-firewall MP updating the IP address range for the PS5 staging network.
  • Wrestled with the PS45 and PS5 openstack networks having different names and was able to sort it out with some help fr
    om @cjwatson. Submitted an MP updating the service-bundle to use the new network name.
  • Reported a bug regarding the autopkgtest-cloud-worker charm and when it doesn’t update some config files.
  • Worked with @andersson123 to troubleshoot an issue with the autopkgtest-web server in staging.


  • While performing an SRU review of glibc I discovered an inconsistency in our process and worked on sorting it out.
  • Submitted an MP for copy-package which makes it a bit more informative about where the package will be copied.


  • Short week due to being out for one day.
  • Reviewing candidate applications.
1 Like


  • +1 maintenance week (report so far)

  • delve: FTBFS due to the installed bpftool not matching the running kernel version.
    I tried to workaround this by calling bpftool directly from /usr/lib/linux-tools-.
    It kinda worked but the build still fails for a different reason. See LP: #2021481

  • bpftrace: FTBFS on armhf. Fixed, see: LP: #2023173
    Also submitted to Debian #1037185

  • cbmc: FTBFS on all architectures.
    The compiler is catching some error I believe are false positives.
    The are some optional variables that it says are MAYBE uninitialized.
    I added -Wno-error=maybe-uninitialized to the CXX FLAGS.
    LP: #2023276

  • pistache: FTBFS on all architectures except riscv
    One of the unit tests tries to resolve an address and fails
    because the build doesn’t have access to the internet.
    It’s not failing on the Debian’s CI.
    A patch was submitted to the upstream project
    LP: #2023274

  • ctffind: FTBFS on non-x86 architectures
    It’s using x86 assembly inline. I implemented an alternative code calling
    sinf() and cosf() from the libc instead.
    LP: #2023288
    Debian bug: #1037227

  • elinks: FTBFS on s390x
    A tool used during tests, sgml-parser, is crashing. There is a number
    of memory issues in the code that are not making it crash on other architectures.
    One can see them by using valgrind or compiling elinks with address sanitizer.
    See: LP: 2023305
    I also reported the problem upsteam:


  • Started investigating how to add support for veths
  • Investigated and fixed an issue related to keyfiles parsing and wireguard configuration (PR#366)
1 Like


    0s autopkgtest [08:54:13]: starting date and time: 2023-06-08 08:54:13+0100
    0s autopkgtest [08:54:13]: git checkout: 1676db7 amend regex tests
    0s autopkgtest [08:54:13]: host duckstation; command line: ./runner/autopkgtest -o /home/tim/tests mawk -- qemu --ram-size=1536 --cpus 2 ../../images/autopkgtest-lunar-amd64.img
   14s autopkgtest [08:54:27]: testbed dpkg architecture: amd64
   18s autopkgtest [08:54:31]: testbed running kernel: Linux 6.2.0-19-generic #19-Ubuntu SMP PREEMPT_DYNAMIC Sat Mar 25 10:22:33 UTC 2023
   19s autopkgtest [08:54:32]: @@@@@@@@@@@@@@@@@@@@ apt-source mawk
   20s Get:1 lunar/main mawk (dsc) [1,776 B]
   20s Get:2 lunar/main mawk (tar) [469 kB]
   20s Get:3 lunar/main mawk (diff) [14.1 kB]
   20s gpgv: Signature made Fri 17 Jun 2022 04:38:22 PM BST


  • Merged MP for script for updating all machines in juju environment when starting development for new release
  • Merged MP for packing charms on commit to check for breaking changes
  • Wrote scripts for testing various mirrors for each set of env variables in the cloudrc files in the autopkgtest-cloud environment - enabling us to use the fastest mirror for each env.
  • Worked on MP for seed-new-release script which runs with a --fake-release flag, for further testing addendum to the --dry-run flag. The aim is to troubleshoot issues with the script (right now, it requires being put into a while loop to run until it succeeds, due to flaky swift connection)


  • Wrote an MP for a daily charmcraft pack of the autopkgtest-cloud charms(@paride fixed some breaking issues in venonat to enable it to work)


  • Fixed janky lxd installation on venonat
  • Started work on an MP for LPCI which adds a command line flag to enable verbose output of git information in an lpci run
1 Like

Short week due to public holiday.

Java 17 on chiselled Ubuntu:

  • ran tests and finished report draft


1 Like