Foundations Team Updates - Thursday 15 Jun 2023

The previous status is here: Foundations Team Updates - Thursday 8 Jun 2023

1 Like

Short week, out Wed/Thu this week.

+1 maintenance

Took a first stab at a commandline tool to make it easier to open and/or claim update-excuse bugs. There are update-excuse bugs open now for all packages in testing > 124 days. I’ve raised an MP against ubuntu-dev-tools for it, to get early feedback.

  • revisited kgb-bot and libpoe-component-server-simplehttp-perl. Errors as inscrutable as before. Opened an update-excuses bug.
  • revisited ruby-rackup, which I had looked at before lunar release and determined should not be fixed because it depended on new ruby-rack from Debian experimental. ruby-rack 3.0.0-1 has since been synced, but itself FTBFS. Turns out this was because of a change in ruby3.1 to pull in a new upstream version of the CGI module. ruby-rack was patched for this in unstable but not experimental. Forward-ported the patch and uploaded ruby-rack, which should also unstick ruby-rackup once its build-dependency is available. LP: #2023576
  • wtforms-alchemy: another one that was carried over because it was too late in the lunar cycle to resolve. Merged python-sqlalchemy-utils 0.38.2-2 from unstable. This also takes care of wtforms-json. LP:
  • libprotocol-http2-perl: revisited. Confirmed the issue in a local environment. Opened an update-excuses
    but didn’t dig further.
  • wine-development: build regressed on arm64. Also regressed in Debian. Package in the lunar release pocket FTBFS on all architectures. And in Debian the package is marked as not suitable for a stable release. So I’ve removed and blacklisted the package.
  • maven-verifier: Had previously reported this issue to Debian. Found that updating the version number in the test xml is insufficient to get this to build. Leaving this for someone more conversant with Java build systems.
  • libclamunrar: requires a newer clamav, which the Server Team is targeting for next month. Opened a task on LP:
    and tagged update-excuse.
  • jruby: autopkgtest regression, but hadn’t been retried since January. Triggered a retry. Newly passes on amd64, still fails on armhf/ppc64el/s390x. No further analysis.
  • pywebdav: LP: #2018702 already
    identified two necessary fixes for the failing autopkgtests but there are other failures, reported to upstream. Not digging further.
  • ojalgo: package using network resources at build time. Debian had a patch already to disable network-dependent tests, but it appears it was incomplete with respect to the current source. Uploaded a fix and forwarded to Debian. LP: #2023591
  • nvidia-graphics-drivers-418-server: this package has been blocked in -proposed since October 2022. However, the January upload of the package appears to have fixed the reason for the block (failure to build with newer kernels). I’ve removed the block-proposed tags to let it migrate.
  • r-cran-rstan: build runs out of memory on 32-bit systems, upstream bug reports that it works when building with boost 1.81 headers instead of boost 1.74. The boost 1.81 transition is coming this Debian cycle, not sure if it’s a good idea to move r-cran-bh to boost 1.81 ahead of this. Opened a Debian bug. Debian maintainer fixed. Retried r-cran-rstan build against new r-cran-bh but it still runs out of memory. Tracking in Debian.
  • shaarli: this was added to the sync blocklist on 2023-02-10 (which is something I recognized because I was the one who blocked it, someone else would’ve probably had to dig quite a bit to find this out) but unfortunately a version had synced to lunar-proposed on 2023-01-29 that went unnoticed and didn’t get removed. Removed it now.
  • pushpin: Shengjing filed a removal bug for the out-of-date architectures the other week as part of his +1 maintenance shift, but there was a question about riscv64 removal due to this not being a Debian architecture. More information clarified that a new (transitive) build-dependency is broken on riscv64, so this is appropriate to remove. LP:
  • libmail-dmarc-perl: various tests fail because they require network access. Uploaded hackish fix and forwarded to Debian.
  • rust-ahash: autopkgtests for the new version fail in both Debian and Ubuntu. Bug has already been reported in Debian with no response from the maintainer. Removed from -proposed.
  • zulucrypt: autopkgtests have regressed in Ubuntu; they aren’t being run in Debian because they require machine-level isolation. Bug filed in Debian.
  • ruby-jekyll-remote-theme: failing network-dependent tests at build time. Talked with Lucas about how best to fix such things for ruby packages, he says he will take care of it via Debian.
  • intelrdfpmath: Ubuntu’s compiler is stricter than Debian’s at the moment, and this fails to build because of using sprintf() without bounds checking. Fixed to use snprintf(), you should never use sprintf(). However, -Werror=format-truncation fires even with snprintf(), so disable this error as well. Uploaded and forwarded to Debian.
  • ruby-jekyll-github-metadata: more network-based tests. Disabled in debian/ruby-tests.rake, uploaded, forwarded to Debian.


  • Full SRU rotation Friday


  • continued work on armhf time_t analysis.
1 Like


  • Moved previous .NET 8 preview3/4 work to preview5 (released yesterday)
    • Currently working on ARM64 bootstrap package for .NET 8 preview5
    • Built AMD64 bootstrap package for .NET 8 preview5


  • Worked on merging adduser 3.134 from Debian (pending review) (LP: #2021498)
    • Submitted a patch upstream to clean up ubuntu delta (waiting on maintainer’s readiness to review patch)
1 Like


  • Merged @andersson123’s autopkgtest MP which will add timestamping to log files.
  • Updated the autopkgtest database on staging as some recent result were missing. It was out of date due to a stuck publish-db process.
  • Updated the autopkgtest branch deployed in production so that @andersson123’s time stamp change is now available.
  • Investigation into the lack of armhf test runners in production.


  • Worked with @andersson123 to debug failures with automatic distribution upgrade testing.
  • Modified sru-review's default release to be lunar not kineic.
  • “Special” sru-review of glibc for Focal. It’s only special because it comes from a -security enabled PPA.
  • Searched through some ubuntu-release-upgrader bug reports for @enr0n.


  • Short week due to being out for one day.
  • Reviewing candidate applications.
  • Conducted interviews with candidates.
  • Patch pilot shift.
  • Attended Developer Membership Board meeting.
1 Like

LicheeRV Dock

  • Currently we have packaged an out of tree driver as DKMS package to support WiFi on the LicheeRV Dock. The driver has to be built on the board which takes ca 1h. This is not a good user experience.
  • With Linux v6.4 similar SDIO based WiFi chips have been enabled. It was explicitly mentioned that the RTL8723DS chip should work using the same code base.
  • I have send a driver module for the RTL8723DS upstream for review:


  • With LP #1983359 hardware RNG drivers are added to the initrd if MODULES=most.
  • I have prepared the SRU to Jammy. @schopin sponsored it.


  • I have been reviewing several written interviews and a take home test as well as conducting an interview.
1 Like



I enhanced the network tests and opened Bring up networking if ip is specified on cmdline to upstream them. Then I tried to add IPv6 test case to Ubuntu’s initramfs-tools. The basic “ip6=dhcp” fails. I opened IPv6 fails with busybox: ip: either “dev” is duplicate, or “permanent” is garbage for it.

I failed to construct a DHCPv6 test case using qemu user network. Qemu uses libslirp for the user network. libslirp/src/dhcpv6.c says:

We only support stateless DHCPv6, e.g. for network booting. See RFC 3315, RFC 3736, RFC 3646 and RFC 5970 for details.

No DHCP client worked with Qemu user network:

$ dhcpcd -1 -t  60 --inform6 -6 ens3
ens3: failed to request DHCPv6 information
ens3: requesting DHCPv6 information
$ dhclient -v -1 -6 -S ens3
RCV: Reply message on ens3 from fec7::2.
Response without a server identifier received.
Invalid Reply - rejecting.


1 Like


  • armhf time_t work: add the ability to carry out the analysis in several steps (needed for a number of packages): ; add --parallel to speed up the process (up to 60% faster) ; several smaller improvements
  • looked more into git-ubuntu build / gu-build
  • some cleaning of openssl bugs

Short week, was out last Thu/Friday

  • boot-managed-by-snapd: Reworked tests to run on and containers as well as local containers (it now swaps between shim-signed and boot-managed-by-snapd and tests both)
  • nullboot: Bumped Go requirement to 1.18 and merged several dependency updates. Still need to sort out new shim support with Chris, we have old forks/one-off branches of secboot and other related libraries.
  • Interviews
  • Various armhf time_t work
  • Submitted a small grub upstream patch as part of 2.12 freeze
1 Like


  • Start Go 1.20 as default transition in Debian.
  • Update golang-opentelemetry-otel to a new version to unblock the containerd migration.


1 Like


  • Kept working on the SRUs, with various topics that stemmed from it:
    • glibc should be kept in sync with the security pocket and thus should be built in a security-enabled PPA rather than following the normal route.
    • There appeared to be some issues with that used not to be stripped on armhf in Focal, but now is stripped again, leading to debugging problems. It turned out to be an issue of mismatched version between -updates and -security that should be addressed by the SRU that’s currently in -proposed, HOWEVER we also discovered that the unstripping bit of our delta has silently failed to work since Impish. Whoops.
    • I’ve been working on tracking down a regression on s390x in the libflame autopkgtests vs the Jammy glibc SRU. While I still haven’t quite figured out what’s the issue, I’ve managed to semi-reliably reproduce it on Canonistack in a way that takes ~2mn, as opposed to >1h initially. That’s only semi-reliable as the bug disappears as soon as I try to strace it to figure out the actual call that’s problematic. Heisenbugs, you gotta love’m.
  • In parallel, I’m trying out snapshot builds of glibc using my Debian merge from a couple of weeks ago. Said merge revealed to be quite buggy, so that takes more time than planned.


  • I had my first Patch Pilot shift on Wednesday \o/
  • A couple of interviews, a couple of take-home tests.
1 Like
1 Like


  • Worked on triaging some old systemd bugs
  • Working on deb822 support and migration in ubuntu-release-upgrader
  • SRU verification for mokutil
  • Finished a batch of armhf work
  • Investigated systemd autopkgtest failures in Jammy++ (LP 2023229)
    • This was caused by the new LXD version introducing a --reuse flag that changes the previous behavior of lxc publish --alias. I still need to work on pushing fixes.


  • Reviewed a take home test
  • Conducted an interview
1 Like


  • focused on OEM meta-packages
  • listing of the meta-packages is merged
  • installing the meta-packages is work in progress. Been testing it thoroughly. Some bits are missing - including making sure only a single kernel gets installed.
  • SRU of ubuntu-drivers for jammy still to be initiated


1 Like
  • Fixes for google-guest-agent on xenial, related to an old debhelper fix (LP: #2019089 after LP: #1959054)
  • Worked on Ubuntu packaging guide … erm … packaging
  • Debugging daily mantic images for raspi desktop (plymouth unbroken, but first-time setup not currently showing up; gadget seems to be the issue)
  • PPA’d git-ubuntu so I’d have an arm64 build (ppa:waveform/git-ubuntu for any other architectural weirdos; and my apologies to the riscv64 crowd – I’ll try and remember to get that enabled after I’ve sorted out some more of the packaging!)
  • Pi meetings
  • … and no take home tests \o/
1 Like


  • Addressed the comments on the Rust versioned spec


  • Finished investigating the check failure on the libboost1.74-dev in the armhf time_t checking batch
1 Like


  • +1 maintenance last week (report)


  • Veth support for Netplan (PR#368)
  • Code review for a contributor (PR#367)
  • Trying to help investigating an issue related to vlans on IBM Z (LP#2022030)
  • Prepared an update for with a patch fixing the parsing of Wireguard keyfiles (MR#444864)
1 Like


  • Deployed my changes with timestamps in staging, tested. @bdmurray merged it into ubuntu/devel
  • Announced changes in ubuntu-devel


  • worked on an MP which will mark jenkins jobs as unstable if a conf file prompt is present in the upgrade test log


  • Fixed the things I broke on venonat which caused all upgrade tests to fail :slight_smile:
  • investigating an issue with virsh vm’s not being undefined with @paride - made MP to try and fix this in utah


  • Spent most of my week trying to learn as much about openqa as possible. The end goal is to be writing openqa tests for desktop applications (snaps) for the desktop team. I’ve learnt a lot but the progress is slow right now. Currently I’m running it locally in a hacky manner but once I’m familiar with the process of writing tests and what is required for each test, I’ll look to move it to proper infra.- One thing to note with this is the introduction of the new installer means we can’t use legacy openqa tests as the screenshots in those aren’t accurate anymore given the new installer.
  • So basically what I need to do is write a test suite just for the installer, and then after that I can start doing tests of individual applications.
1 Like


dotnet6 & dotnet7




1 Like


  • Batch 28 1,2


1 Like