Foundations Team Updates - Thursday 22 Jun 2023

The previous status is here: Foundations Team Updates - Thursday 15 Jun 2023



  • Debian networking discussions
  • MIR: libhttp-message-perl vs libio-compress-brotli-perl



  • email backlog after extended leave
  • pulse planning
  • tavel prep
  • take-home test reviews
  • TownHall


  • simplify hook scripts for the generation of preinstalled riscv64 images
  • analyze errors in image builds


  • create a new release adding upstream patches U-Boot patches LP #2012644

vendor kernel

  • test vendor kernel


  • review written interviews
1 Like


  • opened PR 1700 to get relevant OEM meta-package(s) installed
  • opened PR 1701 to make sure we don’t discard keyrings or additional sources.list.d files installed by extra packages.
  • currently working on making sure we only get the right kernel installed on certified hardware (seems to be working okay on desktop but the result on ubuntu-server isn’t ideal).
  • initiated SRU for ubuntu-drivers on lunar and jammy (thanks @tseliot for sponsoring!) . LP: #1966413. Verification done.
1 Like
  • armhf time_t investigation
  • Travel planning
  • Candidate interviews
  • My first Patch Pilot shift
  • Retried many armhf autopkgtest failures and informed QA Team of the various different error messages
  • Fixed opm-simulators FTBFS on riscv64
  • Sponsored openjdk-21 sync for @vpa1977
1 Like

Short week, public holiday + PTO

+1 maintenance

  • rust-diesel: uninstallable on armhf because it depends on packages not built on any 32-bit arch. Added a build-dependency on these packages, so that the uninstallable binaries wouldn’t be built; and forwarded to Debian for consideration (either they should add the build-dependency or drop the runtime dependency, either way). LP: #2024059 However, it appears rust-diesel has just started failing to build on all architectures, so I filed Debian bug #1038138 for that and removed the package from mantic-proposed.
  • maxima: FTBFS on ppc64el, but not in Debian; so tried rebuilding gcl with -O3 disabled but it still segfaulted. Dumped some information in bug #2024061 after trying a few more things, and gave up.
  • cgreen: unsatisfied versioned build-dependency on libbinutils; we had done a no-change rebuild once before but this didn’t manage to migrate? So trying again. But also, it regressed in buildability on s390x, so filed Debian bug #1038145 about this.
  • calligra: build failure wasn’t reproducible locally. Retried and it succeeded.
  • rust-sequoia-net: unpick build-dep chain rust-sequoia-openpgp -> rust-nettle -> rust-nettle-sys. Current rust-sequoia-openpgp needs the newer rust-base64 in -proposed, but rust-sequoia-net needs the older one. Removed rust-sequoia-net from -proposed to let this settle out in Debian.
  • python-cogent: stuck in -proposed because Debian dropped 32-bit arch support and we have armhf binaries left behind; removed the binaries.
  • eztrace: LP: #2016471 identified that the test was broken because libomp was built with -Bsymbolic-functions but there was reluctance to disable this option. It’s legitimate to build without -Bsymbolic-functions when a package in the
    archive needs to intercept internal library calls. LP: #230460 is a prior example of this from when the hardening flag was introduced. Uploaded llvm-toolchain-15 with a targeted change to disable -Bsymbolic-functions only for libomp, not for all of llvm. But it somehow didn’t work. And somehow rebuilding llvm-toolchain-15 with no relevant changes also now fails. Giving up.
  • opm-simulators: stuck because the riscv64 build had been cancelled. Retriggered it, and it failed again with no build log. Between this and the changelog, seems like it might be OOMing the builders. Opened a bug.
  • Retriggered autopkgtests for packages involved in the r-base transition. There are packages not yet ready for the new r-base, but this makes clear which ones those are.


  • time_t work
  • fighting to do the time_t analysis of boost, keeps running out of memory in VM in canonistack and can’t allocate a larger VM


Full SRU day on Friday

1 Like


  • isc-dhcp: Uploaded isc-dhcp 4.4.3-P1-2ubuntu3 and isc-dhcp 4.4.3-P1-2ubuntu4 to make dhclient behave more like ipconfig in the initramfs.
  • initramfs-tools: Uploaded 0.142ubuntu5 with enhanced qemu-net autopkgtest (to check more cases and results)


/sbin/dhclient-script: line 132: chown: not found
chmod: unrecognized option '--reference=/etc/resolv.conf'



1 Like


  • Support for WPA3 on Netplan (PR#369)
  • Review and merge of a community patch (PR#367)
  • Support for reading VLAN keyfile (PR#370)
  • Minor changes and merge of the support for dummy interfaces (PR#361)
  • Investigating another issue related to Wireguard keyfiles parsing (LP#2024661)
  • Investigating a better way of loading network manager keyfiles to the netplan state.
  • Help investigating an issue related to vlans on IBM Z (LP#2022030)
1 Like


  • Finished building a snapshot of the devel branch for the upcoming test rebuild
  • Investigated a regression in libflame vs glibc/jammy-proposed on s390x, which sent me down a rabbit hole in the CPython and numpy code to finally sort itself out without me needing to do anything. Go figure. Details here.



  • Did quite a bit of paperwork and running around to get a passport to be able to attend GNU Cauldron in September
  • Added support for update-excuse bug references to @mclemenceau’s neat visual-excuses tool. PR 7
  • Town hall meeting
  • Take-home tests grading and technical interviews
1 Like


  • Currently getting the rustc versioned source package spec reviewed
  • Reviewed Rust-related blog post


1 Like


  • Replaced three lxd-armhf autopkgtest workers that had run out of disk space and one that was long in the teeth.
  • Investigation into communication issues between the autopkgtest-lxd-worker and the lxd-armhf units running the autopkg
  • Investigated an issue reported by an Ubuntu developer who was unable to requeue a test. This ended up being an issue with the rabbitmq service which I resolved.
  • Researched the fwupd autopkgtest failures again. The failures are now only happening on s390x and do not appear to be an issue with the proxy server.


  • Created release schedules for releases in the “distant” future.
  • Investigation into the ISO tracker and the software required for it.
  • Performed the SRU verification of a bug regarding the firefox deb not being installed in Ubuntu 22.04.


  • Short week due to a holiday.
  • Reviewing candidate applications.
  • Conducted an interview with a candidate.
  • Travel arrangements.
1 Like


  • LP: #2023016 Merge 13.2-1 into mantic
    • In Progress -> Fix Released


  • prepared Out of Band Update 6.0.119 & 7.0.108 for security team with Mateus Rodrigues de Morais (~mateus-morais)
  • LP: #2024673 wine can not run self contained dotnet7 HelloWorld exe
    • confirmed
  • attended weekly .NET Source-Build Partner Sync Meeting
  • continue working on dotnet-ubuntu-helper

Ubuntu Packaging Guide


  • attened Town Hall Meeting
  • Travel Request stuff
1 Like

Short week with US holiday.


  • Working on a quirk to fix LP 2020406 (“Release upgrade fails due to unsupported DKMS modules”)
  • More systemd bug triaging


  • Conducted interview
  • Booked travel for next Engineering Sprint
1 Like
  • Worked on Ubuntu packaging guide translation layer
  • Worked on flash-kernel merge (LP: #2024672)
  • Blog post writing (make a desktop image with cloud-init)
  • Debugging daily mantic images for raspi desktop (gadget is the issue; still need to fix it though, and another issue with CM4S in Core & Classic which can be fixed in the gadget)
  • Pi meetings
  • Take home tests & interview


  • Finished adduser 3.134 merge from Debian (LP: #2021498) sponsored by @bdrung
    • Upstreamed autopkgtest fixes and the --encrypt-home feature: !89 and !87
    • In Progress -> Fix Releases (proposed)


  • Working on .NET 8 preview 5 bootstrap packages (in progress)
    • RID-specific 7.0 App Host requirement still happening, so investigating “down-streaming” a patch for the time being to fix it and avoid including the prebuilt itself in the package.
  • Packaged dotnet7 7.0.108 Out of Band release with @dviererbe
  • Attended weekly .NET Source-Build Partner Sync Meeting


  • Sprint travel arrangements

+1 Maintenance

  • started writing/experimenting a tool to analyze log files; at the moment it
    mostly greps them but the goal is to extract and detect patterns for
    transient errors and maybe diff between logs
  • coq world: three packages were failing to migrate; two only required waiting
    for syncs from debian but the first one needed a patch from upstream which I
    made the debian maintainer aware of; after a day of building, I confirmed it
    is working and it’s now merged in Debian; we only need to wait for the sync
  • R world: a new version of R was mistakenly uploaded to unstable instead of
    experimental several months ago; the issue are known but I’m not sure we can
    just wait for everything to be updated considering there are 40 failing
    packages at the moment
  • gnustep-base: failures in tests for NSURL which I attributed to issues with
    the remote host used for tests but the cause is probably different; I’m not
    able to reproduce the issue locally and the testsuite required changes to run
    locally at all; best of all, the testsuite says “failed test: […] OK”
  • rust-gio: triggered Simon who’s looking at it; more seriously, it might be a
    toolchain issue specific to armhf and I probably wouldn’t have been able to
    help in a reasonable time-frame
  • rust-sequoia-openpgp: added all arches to big_packages due to arm64 probably
    running out of memory
  • armhf in general: lots of errors due to an infrastructure issue which wasn’t
    as transient as I thought initially

armhf time_t

  • a bit more time spent on the infra side due to a regression I introduced and
    which could skip analyzing packages completely
  • quick experiments to store abi-compliance-checker dumps

edit: for +1 I also looked at eccodes which has missing builds because it tries to pass a float* when a double* is needed (that will fail on most arches) and the bug tracker is not public

1 Like

OpenJDK FIPS package

  • Specification review
  • Started working on tests

OpenJDK package

  • First merge request committed (openjdk-21)
  • Investigated two other issues (hoping to have a merge request for one of them)


  • new starter tasks

Short week for me due to gallavanting around Belgium

  • discussion and a bit of planning/research on dealing with the issue of leftover dead vm’s on venonat (leaving all their disk space too). Implemented a quick script to manually clean up
  • researched and implemented simulated click tests using openqa. Proof of concept for eventual tests to be implemented in proper infrastructure. Currently have a test of gnome-calendar and the ‘try desktop’ option.

Video example of a click test can be seen here:

You might have to request access. Not sure

The end goal is to use openqa to cover functionality of desktop apps that come pre-installed with ubuntu, snap applications and the installer. For any questions about testing or if you have any tests you’d like implemented please contact me. I also plan to try and use openqa to cover a number of the manual tests listed in the iso tracker.



  • openjdk-21 was synced by @ginggs
  • working on FIPS-mode specification with @pushkarnk


  • submitted MR to resolve openjdk-17 install failure

chiselled Java 17:

  • chisel slices MRS 1 2 were merged, one more in review 3
  • final MR for Java 17 container are up for review 1 2 3

armhf time_t:

  • struggling with llvm-14


  • grooming MIR libheif JIRA epic
1 Like