Foundations Team Updates - Thursday 1 Jun 2023

The previous status is here: Foundations Team Updates - Thursday 25 May 2023

1 Like


  • NBS processing of pep8 which has been replaced by pycodestyle
  • component-mismatches management


  • Misc assistance with bionic move to ESM
  • Fixed issue identified with the pending->current promotion of daily images not working after the server move


  • Full SRU rotation on Friday


  • Ongoing work on the time_t migration
  • Met with Robie to discuss how to best approach contributing new features to git-ubuntu
    • have started working on a prototype for git-ubuntu build to wrap dpkg-buildpackage
    • used it in anger a couple of times
  • Drafted an SRU exception for ubuntu-dev-tools, found out to my chagrin there already was one. But the new one is a bit lighter weight
  • SRUed debootstrap and ubuntu-dev-tools everywhere to address
  • Sponsored SRUs of util-linux and openssh
  • Netplan reviews


  • Candidate interview
  • Reviewing a job description
1 Like
  • curtin
    • LP: #2003745 - finalizing fixes for older series support
  • subiqutiy
    • investigate issues in acquiring autoinstall data from cloud-init
    • PR: 1682 - add endpoint for getting the list of interactive sections
  • LP: #2019856 - sponsor util-linux lscpu improvement for @mfo
  • greenhouse
  • specification, github, and launchpad reviews
1 Like

Short week, was off Mon/Tue


  • APT 2.7.1 with PPA snapshot support


  • grub2-unsigned 2.06-2ubuntu17 and 2.06-2ubuntu14.2 SRUs
  • fwupd-efi 1.4 SRUs
  • boot-managed-by-snapd/mantic is NEW


  • Greenhouse
  • armhf time_t work
1 Like

Partial week due to public holidays.


  • Prepared SRUs for Jammy and Focal, including a bit of bug grooming.
  • In the middle of rebasing 3 years worth of Ubuntu-specific changes on top of Debian’s packaging. Fun times!
1 Like

+1 maintenance

I looked at packages that are FTBFS and stuck in proposed migration due to missing build.

  1. gitlab-ci-multi-runner

    The package has long history of ftbfs both in Ubuntu and Debian.

    Request removal

  2. delve

    bpftool needs to match running kernel version. Not possible to have a
    working bpftool command in Ubuntu build environment. (Disclaim: I made the requirement for bpftool in Debian. it works in Debian because the bpftool is packaged differently. I would revert that change in Debian if no solution found when Debian is not in freeze.)

  3. librnd + camv-rnd + pcb-rnd

    camv-rnd and pcb-rnd are in dep-wait status, it needs librnd > 4.
    It’s a small library transition. So I just ask @ginggs to kick off the transition.

    Also ask for revoking the blacklist for sch-rnd since it has stable release now.

  4. perl related

    Several packages FTBFS with same test failure:

    event webhook_request of session KGB for DIR handler ‘^/webhook/’. As
    reported by Kernel: ‘No such file or directory’, perhaps the session name is
    spelled incorrectly for this handler? at /usr/share/perl5/POE/
    line 483.

    I’m still debugging that.

  5. godot

    FTBFS in Debian too
    Imported the bug to launchpad and add a update-excuse bug for reference.

  6. libs3

    FTBFS on ppc64el only. Caused by -Werror=stringop-overread. Looks like the
    difference is -O3 vs -O2 build flags between Ubuntu and Debian.

    Patch attached at

  7. libtgowt

    FTBFS on riscv64, but previous version not. The new version needs upstream
    explicit support in its build config. However this library is only for
    building telegram-desktop.

    Request removal

  8. kickpass

    FTBFS on amd64 due to LTO. Caused by a pie patch which is added by the Debian
    maintainer (Can be safely dropped).

    Patch attached at and forwarded to

  9. pushpin

    FTBFS on ppc64el, riscv64, s390x. Same on Debian, and Debian has removed the packages on these architectures.
    Request removal



armhf time_t



  • Worked on util-linux focal SRU: LP 2015355 “Please backport patches for false atari partition detection to Ubuntu 20.04”
  • Worked on LP 2020474 “openssh-server-1:9.2p1-2ubuntu1 cannot be installed from active ssh session”
    • The issue seems to be resolved now, but still waiting on migration
    • Also made a follow-on fix to LP 2011458 so that we avoid this bug in Kinetic and Lunar
  • armhf time_t batch

short week (3 days off)


  • spec work and planning for ubuntu-drivers integration (OEM related)
  • patch for ubuntu-drivers --no-oem merged (uploaded in mantic). SRU to be initiated
  • merged mypy script to compare two branches


  • had a first look at dbus merge


  • still working on release automation tooling




  • Reflected on how to beging implementing systemd-wide crypto configuration without breaking everything (lots of time spent evaluating TLS test clients); PoC to begin this month I think
  • Looked at the cdebconf merge but mostly spent time better understanding it better
  • Launchpad stuff wrt openssl tickets

armhf time_t


  • Prepared Foundations team application to Bug Control


  • Worked on a batch of time_t related fixes for armhf


  • Code review for a contributor from the community related to wpa_supplicant configuration. We are using the wrong configuration key when selecting the frequency for adhoc networks PR#363
  • Improvements on coverage for memory leak tests PR#365
  • Merged the error handling improvements PR PR#334
  • Investigating a problem with Wifi adhoc configuration on the Raspberry PI where it will not work out of the box with netplan.
  • Continued the work on the Netplan Diff spec

Network Manager

  • Investigated and fixed a couple of issues related to the netplan integration MR#443876
1 Like


  • Resolved an issue with updating the autopkgtest-cloud-worker charm in staging by updating the charm to pin the version of pyaml and submitted an MP with that change. This also involved wrestling with juju a wee bit.
  • With @paride resolved another issue updating the autopkgtest-cloud-worker charm in staging this time by pinning PyYAML. See the MP for some more details.
  • Updated the autopkgtest-cloud-worker charm in staging and production to revision 156 which includes fixes for a bug regarding images potentially having packages from -proposed in them and a bug regarding a trailing dot in FQDN of hosts in PS5.
  • Submitted, merged an MP which documents the process for updating the autopkgtest and autodep8 code in the autopkgtest environment.
  • Submitted an MP updating the mojo/service-bundle by removing the autopkgtest-cloud-worker-lrg units and moving test runners to the autopkgtest-cloud-worker units.
  • Removed autopkgtest-cloud-worker-lrg units from production as they had been replaced by autopkgtest-cloud-worker units and were no longer being used.
  • Pinged IS regarding restarting neutron on s0lp4 in scalingstack-bo02 as the s390x queues were slowly processing again. See RT 155441 for details.
  • Submitted a request to have a staging proposed-migration setup in PS5 on the ubuntu-qa bastion. Also reported a bug about the form.


  • Retried autopkgtests which had failed for stable releases using retry-autopkgtest-regressions.


  • Scheduling / coordinating team holidays.
  • Reviewing candidate applications.
  • Reviewed and closed some outstanding RTs that were no longer valid.
1 Like


  • bootstrap package for amd64 ready in PPA
  • working on arm64 bootstrap to add as dependency to final package


  • working on adduser merge



  • currently investigating the network-based tests for the fwupd proposed migration
1 Like



  • investigating jtreg failures of test build
  • jtreg 7 was sponsored by @vorlon and now we can make a release of openjdk-21 rampdown phase 1 (when it gets tagged next week)


  • prepared a build to test LP: #2021566. Unfortunately without proper reproduction steps it is more of a guess.

chiselled-jre 17:

  • doing performance and size benchmarks of a new chiselled Java 17 container (from this branch)
1 Like