Ubuntu Unity iso Troubleshooting

Noob @ ubuntu here :smiley:

OK… So I got the ubuntu-unity-nemo-amd64.iso

I created a fresh startup disk… But it crashes saying

kernel panic - not syncing: no working init found

Image taken with VirtualBox:

VirtualBox_Bionic_20_12_2017_10_01_29

I tried booting with the iso in VirtualBox, which works fine. The issue is with live usb. Is it an issue with startup disk creator? I also tried dd and Unetbootin. How did you guys manage to get it working?

@blaocklight

Your have to use ‘restore’ option from gnome-disks. SDC is no longer the usable method for burning .isos. to usbs.

Regards…

1 Like

Still no luck… I can only get it in VM (Pic: https://i.imgur.com/BD6Iv5h.png)

otherwise it’s the same error.

After gnome-disks restore:

Don’t know why this happens. I just installed 18.04 daily build today using the same pendrive, no issue there. If the download was broken, I wouldn’t have been able to try the mounted ISO in VM. May not be errors with boot mode too cuz it should have run in VM if that was the case and my PC does not even have the SecureBoot option. When I tried to install unity along with the daily build, same issue which chanath has

:cry:

@blaocklight

Can you give me specs to your hardware ?

inxi -Fxz

It works just fine here on all my non-UEFI boxes.

yes … and there is the checksum file you maybe should try.

1 Like

Here are my ‘live’ specs on UEFI box.

ubuntu@ubuntu:~$ nemo
^C
ubuntu@ubuntu:~$ inxi -Fxz
System:    Host: ubuntu Kernel: 4.13.0-17-generic x86_64 bits: 64 gcc: 7.2.0
           Desktop: Gnome  (Gtk 3.22.26-2ubuntu1)
           Distro: Ubuntu Bionic Beaver (development branch)
Machine:   Device: desktop Mobo: MSI model: B85-G41 PC Mate(MS-7850) v: 1.0 serial: N/A
           UEFI: American Megatrends v: V2.8 date: 07/17/2014
CPU:       Dual core Intel Pentium G3240 (-MCP-) 
           arch: Haswell rev.3 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12398
           clock speeds: max: 3100 MHz 1: 3099 MHz 2: 3099 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.5 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1440x900@59.89hz
           OpenGL: renderer: Mesa DRI Intel Haswell Desktop
           version: 4.5 Mesa 17.2.4 Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-17-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/sda model: WDC_WD800JD size: 80.0GB temp: 23C
           ID-2: USB /dev/sdb model: N/A size: 4.0GB temp: 0C
Partition: ID-1: / size: 1.9G used: 25M (2%) fs: overlay dev: N/A
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 178 Uptime: 1 min Memory: 537.0/3808.8MB
           Init: systemd runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.121) inxi: 2.3.45 
ubuntu@ubuntu:~$ 

…and notice nemo-desktop in processes.

1 Like

I’m on 18.04, but not your edition (don’t get confused :smiley: )

I see you are using modesetting for graphics, most likely because you have had problems with nouveau drivers . Then why not use nomodeset when booting live USB?

Just keep tapping Ctrl+Shift and the option will come up … choose nomodeset and then boot live and see what happens . it should boot with nouveau because that is a fairly new board unless there is something not right in BIOS settings.
Regards…

edit:

ahh I see my ‘live’ also chose modesetting by default.

I tapped Ctrl+Shift and chose language, then F6 → marked ‘nomodeset’
yy

and tried both:
Try Ubuntu and Install. No change :frowning:

Edit:
BTW i did not set modesetting by myself, I just installed the ISO. Also I most likely wont get any error cuz I have Intel GPU, not nVidia

Marking nomodeset may not be enough. Try directly editing grub cmd-line.

1 Like

In boot options, I removed quiet splash and insead wrote nomodeset. Along with that, I marked nomodeset like before. This time some extra text came before what was seen before, but finally ended up in the same screen:

What happens when you add init=/bin/sh to the boot parameter?

1 Like

Kernel Panic: requested init /bin/sh failed (Error -2)

I managed to install it by mounting the ISO on a partition (Live USB didn’t work for me as stated before). Now after logging in, if I move my mouse near to the launcher, I get logged out. Not sure whether this is a general problem or just for myself alone.

Could be a general problem.

Finally… found a fix. I just had to update graphics drivers.

How To: Install Intel® 945GM x86/MMX/SSE2 graphics Ubuntu 12.04

There, you need to make a change… i.e
instead of

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

do

sudo add-apt-repository ppa:ubuntu-x-swat/intel-graphics-updates

because the repo has been modified after the post.

I suggest anyone having the problem and has Intel GPU try this.

Phew… I’m so happy :smiley:

Edit:

Software Update should automatically update drivers. In that case you need not manually install the drivers from the repo. Still it wont create the /etc/X11/xorg.conf file. So you need to manually create it by

sudo gedit /etc/X11/xorg.conf

and insert the text below

Now save and restart.

@dale-f-beaudoin please embed the drivers in the distro so others won’t be affected by same problem.

1 Like

Since this is now solved, closing.