Testing Unity Session in 19.04

I suppose, you can download dropbox integration packages from here.

It’s just a matter of installing the nemo-dropbox-extension & having dropbox installed.
The Cinnamon Stable PPA has various versions of the extension. One likely doesn’t need to add the ppa nor particularly match nemo & extension versions, just dl the package & install via apt.

If you want to submit a patch you can send them on the mailing list (you need to subscribe first), or you can open pull request on launchpad (unity now moved to git) . For bzr based repos you can open merge request at launchpad.

Is it possible to not to place Nautilus, Gedit, Firefox as dependencies in ubuntu-unity-desktop and/or in unity or unity-session?

No. ubuntu-unity-desktop doesn’t actually depends on it, it pulls them. unity-session depends on unity, unity recommends nautilus. So use --no-install-recommends

Nautilus is there in --no-install-recommends

$ sudo apt install ubuntu-unity-desktop --no-install-recommends

[sudo] password for ....: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
...metacity-common nautilus nautilus-data notify-osd....

This is the depends part, right?

$ sudo apt install unity-session --no-install-recommends

only nautilus-data is installed as dependency. Same with installing unity with --no-install-recommends.
No idea why nautilus-data is needed anyway for unity to work.

I am trying this on the install I have now with ubuntu-session without Nautilus.

Unity-settings-daemon pulls nautilus-data which install gschema. Without it u-s-d will crash and you won’t be able to login. Beside nautilus is burried deep in unity ( launcher progress bar, launcher-trash, quicklists, unity-lens-files, zeitgeist integration, hud, bamf, indicator-appmenu, etc…it’s everywhere). You can’t have productive desktop without it. Unity may crash or spams syslog heavily. However you can have a different filemanager with parts of nautilus installed.

Maybe, just nautilus-data is buried deep in unity, not nautilus itself. In the other (ubuntu default) install, both nautilus and nautilus data are uninstalled, and it is working. Here in unity, I can get nautilus out, but not nautilus data. Doesn’t matter, really.

Btw, once back in Unity, don’t feel like going back to that install at all. :slight_smile:
Except to the Openbox one.

There’s also something Unity settings has that Gnome settings doesn’t, locking the laptop, when the lid is closed. But, both doesn’t have adjustment of low battery level for notification. @khurshid-alam is there a possibility to add that adjustment to the Unity settings? I do it manually by changing the /etc/Upower/Upower.conf > PercentageLow=10 to 18. If this parameter change can be linked to the settings, it would be nice.

Btw, is there notifications in Unity Settings?

Hmm, u-s-d still has the code but latest upower ignore all the settings. I thought this is only my laptop since it has poor battery but it seems a bug…so answer this questions…

  1. Does it show a notify-osd when battery level reached critical ?

Try changing percentage-action, percentage-critical from dconf-editor (org.gnome.settings-daemon.plugins.power)

  1. Try both org.gnome.settings-daemon.plugins.power use-time-for-policy false/True

  2. If that doesn’t work then try changing upower conf.

  3. Set critical battery action suspend (org.gnome.settings-daemon.plugins.power critical-battery-action). Does it work ?

Upower.conf change didn’t work with Unity, but worked with Gnome-shell and Budgie.

I changed the current value in percentage-low in (org.gnome.settings-daemon.plugins.power) from 10 to 18, but have to wait until next battery drop.

In percentage-critical, the values is 3, what does that mean?

(What a mess Gnome is doing, really? Don’t they know that people use laptops, even in offices, not desktops these days? Committing suicide, most probably.) I put that in brackets, for it is just ranting. :slight_smile:

In Openbox, I am using xfce4-power-manager and I don’t have any problems with locking on closed lid or notifications of low battery and changing the critical battery level. Do you think, can we just drop gnome power manager and use xfce4 one instead in Unity?

Didn’t work with changing the default value to false, either. Didn’t work with the default value too.

Setting it to suspend didn’t work too.

It just went pass 18% without any notification and the laptop went off around 16%.

EDIT: Setting it to ‘interactive’ worked. Got back the fine old unity notification with sound!

No. xfce probably using upower < 0.99 with #ifdef, that’s why it is probably working, Or if they adapted to upower > 0.99 the we could use that code in u-s-d power plugin.

You don’t have to wait. You can set very high value depending on current battery charge, just for testing.

What ? !! Screenshot ?

Here is the screenshot,

No, I mean screenshot of notify-osd bubble when you set interactive. I don’t think u-s-d or indicator-power generating that…perhaps upower which is another bug.

The bubble looks like this. It also comes with a notification sound.

This is not the notification that comes with low battery. It is recreated. You can find the small app at webupd8 repos at Lanuchpad.

EDIT: Here’s the battery low notification bubble.

Screenshot from 2019-01-11 12-40-10

Yes this is what I wanted…it looks like u-s-d generating it indeed, but does it also give critical battery notification? Also in interactive mode what happens when battery reaches critical level ? (Just use high value critical level, just for testing)

No, only that warning and a signal together. Maybe that signal is the critical battery warning.

Any chance we can get this fixed? Login screen showing Authentication Failure Switch to greeter…

Somebody posted a possible fix on a ppa at the end of that bug report a couple of days back

Yeap, I saw that and I was the one testing and reporting it works. How we can get that a new release with that patch applied? I’ve asked on IRC, in the bug itself, trying to send email to some people involved with Unity in the past, but no answer.