Foundations Team Updates - Thursday 19 May 2022

Last week’s update available here: Foundations Team Updates - Thursday 12 May 2022

1 Like


  • Had some meetings to work out minor details of yaml definition (naming, nesting)
  • created a pull request implementing the yaml parsing and schema validation, and deleting livecd-rootfs sections
    • The above PR also has the start of the plumbing for dynamically creating states in the state machine
    • 100% test coverage included in the PR
  • Started investigating how to break down rootfs builds from a seed into smaller states to be dynamically added to the state machine
  • Created another pull request to fix an issue with a test periodically failing due to map order not being preserved in Go.


  • Fixed LP #1972735
  • Reviewed Go 1.18.2 changes along with a member of the server team


  • Uploaded a fixed golang-github-mendersoftware-openssl to unblock openssl
  • proposed migration: runc vs dh-golang
  • retrying a few other tests to unblock dpkg
  • candidate interviews


  • various rounds of no-change rebuilds for revdeps still on
  • worked out that netpbm no-change rebuilds are useless because netpbm has a versioned -dev package name with no compatibility. Glared at this offense but put no further effort into this mess.


  • cycled through all my outstanding TIL merges, which are now either staged in -proposed, or belong to the Server Team and I’m ignoring


  • merged libxc to unblock openmolcas build, but new libxc ftbfs on riscv64 despite a patch to make it use less resources at build time, so tweaked to try 3 instead of 4 as the max parallelization and waiting to see the results (10+ hours later…)
  • postgis FTBFS on ppc64el with test failures; these are fixed by disabling LTO. Uploaded.
  • macromoleculebuilder: upstream build system forces -std=c++14 to ensure availability of “newer” language features, but this is now old and busted and incompatible with one of the build-deps which requires C++17. Patch and forward to Debian, though it needs other build-dependencies also fixed for this updated build-dep before it will build.
  • Filed bug report about golang-github-valyala-gozstd/s390x autopkgtests blocking libzstd. Seems other folks were also looking at this already, hopefully will unblock now once the requested retest has happened. (Spoiler: it passed.)
  • golang-gopkg-libgit2-git2go.v31: was blocking libgit2 (and many friends) because it has a libgit2 version check in its test suite. Kill that noise with prejudice.
  • apertium-recursive: build-time tests fail on all archs where they’re run except amd64. Coincidentally, all archs where we run tests at build-time, except for x86, have ‘char’ defined as an unsigned type. Fixed the wrong use of a ‘char’ to hold the retval of fgetc() in the code an error that was identified by the compiler (more -Werror, please), and forwarded to Debian
  • petsc: was blocked by scotch, which had a failing autopkgtest on ppc64el. The failure was due to compiler output on stderr, which in turn was a complete nonsense warning. Filed about the noise, and patched scotch to ignore stderr in its autopkgtests.
  • flint-arb (an NBS blocker) blocked by an autopkgtest timeout on armhf (successful test run time is close to the timeout). Retried the test and it passed this time. Could add an override to allow this test to have a longer timeout but can’t be bothered right now.
  • Some accidentally aggressive following of Debian removals on my part made spyder uninstallable in kinetic. A fixed version was in -proposed, which migrated because it didn’t regress installability, but it also didn’t fix it because it has new deps that are only in -proposed. python-lsp-server is blocked by python-pluggy, which is blocked because ocrmypdf autopkgtests fail on ppc64el and s390x (killed). Possibly natural growth in memory usage or possibly a regression in python-pluggy, so first retried the tests again to see if they happen to pass before digging further, but this failed. Now retrying with it added to big_packages.


  • Finished retargeting to kinetic all bugs that were listed in the jammy release notes
  • Reports of the ftp pool on daily images being out of date, indicating a failure to sync the ftp mirror locally to cdimage-master. Thought this might be due to the system being so busy again that there was no idle window in which to sync the mirror without impacting in-progress builds; but I could see no evidence of that, the mirror was just 9 days out of date. A manual run of the rsync succeeded without incident.


  • Did a round of processing Debian removals. Of note, Debian has removed ntp source, the binaries now being built as transitional packages from ntpsec; flagged to the attention of the Server Team.
    • LocutusOfBorg asked for removal of android-platform-system-core per Debian bug #1011210. android-platform-development has been removed from Debian for a while, but not removable in Ubuntu because of revdeps, and android-platform-tools has a new version in -proposed which fixes this but can’t migrate because of the above knot. Have forcibly accepted the Debian removal of android-platform-development, which should temporarily increase uninstallibility in kinetic but is expected to settle out in the next couple of proposed-migration rounds.
    • Debian dropped prelink a year ago but it’s still in Ubuntu because the nvidia packages build-depend on the execstack binary package it builds. This was added as a build dependency 13 years ago to fix issues with executable stacks in the closed-source upstream binaries. Things have changed a bit since then, so filed bug #1974091 asking for this build-dep to be dropped.
    • The other revdep of execstack is sl-modem. Unfortunately unlike the nvidia modules, this is dead upstream. So I adjusted the code to handle the executable-stack issue with objcopy instead of execstack to drop the build-dep.
  • misc NEW processing in kinetic.
1 Like


  • modified worker configuration for bos01-(s390x|arm64|ppc64el) to use ftpmaster.internal since an RT was resolved
  • removal of autopkgtest results from swift for multiple End of Life releases (including PPA results which weren’t documented as needing removal)
  • discovered an autopkgtest web frontend was out of date (didn’t have kinetic results for a pacakge) so re-ran download-all-results.service on both units
  • submitted a PR improving download-all-results to use a retry loop when getting results from swift
  • cleaned up long running tests on armhf (they didn’t get auto-cleaned)
  • added python-ase, debci, apport, assimp to never_run for kinetic on armhf
  • added golang-github-valyala-gozstd to big_packages for s390x


  • rebuild of the ubuntu-desktop canary image for @seb128
  • tested a dist-upgrade from Focal to Jammy again for the dbus reboot wait issue
  • investigation into snap channel changing due to a bug report
  • updated end-of-life JIRA template regarding removing autopkgtest results for PPAs too
  • uploaded no change rebuilds of bluez, htslib, ngtcp2, libunwind, libwmf, wvstreams for @dbungert
  • review of a specification for @sil2100
  • replied to Error Tracker data retention email responses
  • re-enabled daily builds of Jammy images
  • uploaded ubiquity fixing a spelling bug
    • rebuilt package for amd64, riscv64 because it FTBFS
  • reported a bug about the lock screen message appearing over ssh
    • reviewed the merge proposal which would fix the above
  • submitted an apport pull request which would improve JournalErrors gathering fixing a bug
  • removed multiple known issues from the Jammy release notes that were fixed


  • attended Ubuntu Developer Membership Board meeting
  • submitted an RT regarding an unused swift tenant (ue_daisy_project)
1 Like
  • subiquity
    • PR: 1297 - show paths to partitions on API Partition objects
    • (no PR yet) - pass along minimum size info
    • Specification work
    • Review: PR: 1296
  • curtin
    • start some integration tests using cryptsetup and proof of concept of handling more cryptsetup cases
  • probert
    • (no PR yet) - report minimum size of partitions for ext / ntfs
    • Review: PR: 117
  • distro:
    • lsvpd: analyze build failure of lsvpd, builds for me, just on log analysis just needed a rebuild with newer dependency, launchpad build pass on rebuild
    • LP: #1946828 - ntfsresize vs ubiquity - on retest with Jammy this issue with a ntfsresize hang appears resolved
    • LP: #1973632 - tuptime - open sync request as patch was accepted in Debian
    • LP: #1959346 - iniparser - recommend dropping an old patch I did that would allow this package to be synced
1 Like
  • python-cheroot package
    • package new Debian version fixing LP #1967139
  • findutils
    • packaged new upsteam version (LP #1973788), sponsoring needed
  • ifupdown
    • remove invalid lines from resolved integration scripts (LP: #1907878)
  • dnstwist
    • fix an autopgtestproblem (LP: #1973220)
      The incorrect parsing of JSON contributed to the flakiness of the test.
  • Reconcile packaging plans for DPDK and SPDK with server team.
1 Like
  • VisionFive

    • Spec under review
    • ogra may have found an issue with the firmware package, waiting for him to provide instructions on how to reproduce the issue before uploading linux-firmware-starfive
  • Nezha

    • Spec under review
    • nezha-boot0: with ram size detection uploaded into kinetic
    • nezha-boot0: SRU done, waiting for someone to pick it up
    • u-boot-nezha: working on UEFI boot, can wait a bit to make it work before uploading and SRUing.
    • flash-kernel updated with licheeRV and Nezha boards
    • Kernel crashes when booted using UEFI, under investigation
  • Ventana:

    • Working on an Ubuntu kernel + ventana patches, fails to boot for now
  • Merge

    • logrotate: waiting for sponsor
    • libsigsegv: waiting for sponsor
    • opensbi: sync sponsored by @slyon
  • Misc

    • dpkg without nocheck for riscv64 built and tested successfully in my PPA to prepare the main component rebuild for riscv64
    • Finally got access to the wiki page and updated the RISC-V page
1 Like


  • Some discussions around POWER9 ppc64el on Canonistack (cc @Frank)



1 Like
  • Nursing amd64 builds that stalled while fetching InRelease (cancel, wait, retry)
  • Kept an eye on the r-bioc-api transition incoming from Debian and retried builds that failed due to out-of-order builds after auto-sync
  • Looked at improving debootstrap to seamlessly handle new ‘devel’ series, mk-sbuild from ubuntu-dev-tools will also need some work
  • After reading @rbasak’s +1 maintenance report I was intrigued by octave being blocked by a petsc FTBFS on riscv64. I found this was due to entangled hypre/scalapack/scotch/petsc/slepc transitions and uploaded no-change rebuilds for them, and they have just migrated :tada:. I retried the riscv64 builds for the octave transition, and now I think octave just needs some autopkgtest retries and removals of biosig and octave-mpi.
  • TIL universe packages, these could all be sync’d: adonthell, atropos, cwiid, ecflow, getfem++, gudhi, jellyfish, libsigrokdecode, link-grammar, lives, ns3, opm-simulators, optlang, pybind11-json, python-biom-format, python-mkdocs, python-pot, r-cran-bbmle, scikit-fmm, zeroc-ice and zope.testing
  • Foundations Merge Party, I got mdadm, python-systemd and lapack. @bdrung stole python-systemd :stuck_out_tongue:, so I took alsa-lib instead, which turned out to be a sync. I looked again at the lapack/octave-control issue, and decided to sync lapack and skip the failing ppc64el test in octave-control rather (still to be uploaded). mdadm is still in progress, but this one is bigger than previous merges since the Debian packaging received a major overhaul in switching to the dh sequencer
  • Looked at sponsoring LP: #1973737 for @xypron, and ended up going with a merge instead of a sync
  • I was assigned libwww-perl last week for proposed migration, but a new version was autosync’d and autopkgtests are still running
1 Like
  • +1 maintenance
    • worked on pysdl2 for s390x mostly. Opened issue 227 upstream and started work on ppa:ogayot/kinetic-proposed. There seems to be some upstream work to do on SDL2 for big-endian support before focusing on pysdl2. At this point, I’d consider disabling the failing tests for s390x.
  • -proposed migrations
    • requests: fixed autopkgtest when HTTP proxy variables are set (LP: #1974182). Forwarded to Debian. Looking for a sponsor :slight_smile: Some patches to send upstream to make tests more robust.
  • subiquity
    • helped validate SRU for python-aiohttp (LP: #1969817).
    • opened PR to use python3-aiohttp again for geoip requests (PR 1298)
    • reviewed PR 1296
    • reviewed spec for partition size minimums
    • reviewed spec for keyboard enhancements
    • drafted spec for NetworkManager connections copy API - in review
    • discussed integration with ubuntu-advantage-client for UbuntuPro
  • misc
    • validation of MOTD/livepatch SRU on hold (LP: #1747499). Need another SRU to unblock.
1 Like


  • LP 1973785 “lock screen message appeared during an SSH upgrade”
    • Fixed kinetic version, and prepped for SRU to jammy
    • @bdmurray uploaded
  • Continuing to investigate/respond to upgrade bug reports. Nothing out of the ordinary so far.


  • Drafting systemd-hwe package spec


  • gjs vs readline (ppc64el)
    • Added to big_packages on ppc64el, and the test passed after that.
  • gnudatalanguage vs readline (amd64) (LP 1973377)
    • The test_tic_toc test is inconsistent because it basically compares (1) the duration between beginning and exit of a loop, and (2) the sum of each iteration’s duration, and fails if the error percentage is greater than a threshold. Debian has a patched committed to increase the threshold, but a new version has not been released. We applied the patch and uploaded 1.0.1-3maysync1 to allow autosync.
    • @slyon sponsored the upload
1 Like
  • Investigating totem failure (still!) on Pi desktop (LP: #1969512)
  • Investigating firefox snap start-up time (and video performance) vs debs on Pi desktop
  • Working on tidying up the raspi-config package (including fixing the incorrect config.txt path, LP: #1972982)
  • Investigated openldap dpkg-reconfigure restart issue (LP: #1973382)
  • Investigated reported incompatibility with Argon One case on Ubuntu
  • Updated flash-kernel merge (LP: #1973801); awaiting testing on a couple of other boards before upload
  • Worked on sbuild merge (LP: #1974177) and posted a fix upstream for dscverify issues found
  • Pi meetings
1 Like



1 Like

Short week due to some time off.


  • Mostly bug triaging and excuses autopkgtest investigations


  • Reviewed PR 279 for slyon


  • Sponsored LP: #1973296 (opencryptoki SRUs)
1 Like
  • Short week, off Monday
  • Released apt 2.5.0
  • Released nullboot 0.4.0
  • DebConf travel planning
1 Like

Short week thanks to family illness

1 Like