Foundation Team Updates - Thursday 02 June 2022

Last week’s update is available at Foundations Team Updates - Thursday 26 May 2022

DPDK 22.03
The Data Plane Development Kit (DPDK) is used to build high performance network applications. In the Ubuntu archives the LTS release of DPDK (version 21.11) is available. For DPDK 22.03 patches adding RISC-V support have been created upstream. To allow testing DPDK 22.03 with these patches is now packaged in ppa:ubuntu-risc-v-team/release.

rdma-core allows remote DMA and is especially used in HPC. Testing rdma-core on RISC-V using a Mellanox ConnectX-3 Infiniband NIC showed no issues.

The Storage Performance Development Kit (SPDK) is used to build high performance storage applications based on rdma-core and DPDK. I have started packaging it.

SBI Debug Console Extension
Review specification draft

1 Like
1 Like
  • Short week, was off Friday and Monday (there was a holiday on Thursday :D)
  • Short next week, will be off next Monday (yet another holiday)
  • More DebConf travel organisation:
    • travel agency managed to find my “flights”. That’s good. Flying FRA-PRN and then PRN-VIE. But also booked “flight” KWQ-FRA, which is really ICE train from Kassel train station disguised as a Lufthansa flight. If train is late, I get usual EU flight passenger rights :smiley:
    • hotel situation is messy. spent too much time finding out stuff. good hotels that are available are on west side of prizren, venue is east side, many hotels are in apparently noisy old town center, don’t seem good option. having travel agency look at booking one of the west hotel for couple nights, then switch to close “good” hotel as it becomes available.
  • grub discussion re out of memory issues
  • discussions about TPM stuff
  • had a look at by @chrisccoulson - that seems incredibly useful to have
  • provided advice to @alexghiti about his libgpg-error gcc-mingw-w64-i686 multi-arch question.
  • provided some absurdly early feedback to @mwhudson after hearing about an interesting spec of his :slight_smile:
1 Like



1 Like


  • Working on systemd v251 merge
    • Brought in Debian 251-2, dropped patches that are applied upstream, and I am reviewing the rest of the patch queue currently.
  • Moved systemd-hwe spec to “Pending Review”
    • Thanks @slyon for review/sign-off.
    • Responded to OEM Enablement team comments, and they also signed-off.
  • Implemented --root option for systemd-hwdb query, merged upstream.


  • Fixed LP 1975747 “snapd-desktop-integration not installed on upgrade to Jammy”, and did SRU verification.
  • LP 1965568 SRU verification
  • LP 1973785 SRU verification


  • libcloud vs paramiko (ppc64el)
    • Still working on this. I have not been able to reproduce this. The tests look flaky because different unit tests fail on different autopkgtest runs. But, they are consistently failing this way only against paramiko it seems.
    • Edit: I have figured out the cause, and will prepare a patch.
1 Like

short week due to vacation.

  • Subiquity:
    • implemented building blocks for Ubuntu Pro redesign
    • worked on specification for Ubuntu Pro
    • discussed NetworkManager API design, with potential shift towards using netplan
    • PR review
  • Misc:
    • python-tornado autopkgtest regression. Fix was provided in upstream curl. Uploaded .debdiff today at LP: #1976619. Needs sponsoring.
    • pysdl2. Patches provided upstream for autopkgtest on s390x. Upstream test-suite green on s390x. Need to backport patches.
1 Like
  • FTBFS reports
  • Proposed migration:
    • curl/pycurl migrated after I triggered tests against the new pycurl in proposed
    • after curl migrated, I ran python-tornado migration-reference tests because it regressed in release (this was investigated by @ogayot and is now fixed in curl upstream)
    • sphinx only waiting on a MIR for libunicode-escape-perl
  • Sponsoring:
  • DebConf22 preparations
  • Looked at improving debootstrap to seamlessly handle new ‘devel’ series
  • Sync’d open-ath9k-htc-firmware (TIL universe package)
1 Like


  • updated my merge proposal for cleaning up timed out jobs
  • added ruby-parallel to big_packages after reading a +1 maintenance report (it passed and migrated)
  • removed assimp/armhf/kinetic and python-ase/armhf/kinetic from never_run as the timed out job cleanup will take care of them

Error Tracker

  • documented how to switch the production Error Tracker from using PS4.5 swift to PS5 swift for IS
  • tested the staging version of the Error Tracker with some new cassandra servers

ISO Tracker

  • Fixed, using an SQL query, the “download links” for Jammy daily builds as they were broken
  • submitted, merged a MP adding a task to the new release process template so the above isn’t missed again


  • reviewed @enr0n’s Jammy merge proposal for ubuntu-release-upgrader
  • uploaded ubuntu-release-upgrader for Kinetic which adds an extra snap to the upgrade process fixing a bug
  • special SRU review of neutron for impish and jammy
  • merged a britney hint for @alexghitti
  • sponsored SRU of ubuntu-release-upgrader to Jammy for @enr0n
  • attended Ubuntu Developer Membership Board meeting
  • reviewed a cdimage MP for @slangasek
  • investigated why old releases are slow to be removed from, added notes about this
  • setup and attended an ubuntu-release team meeting where checklist items were reviewed
  • submitted a hint MP which added a force-badtest for adduser which added a test dep on an i386 package which isn’t installable
  • SRU team shift
1 Like

Short week due to holidays



  • Filled out MIR template for gsasl and libntlm
  • Investigated autopkgtest failures in mysql-8.0. Thanks @vorlon for helping me figure out Multi-Arch
1 Like
  • subiquity
    • PR: 1302 - address feedback and merge PR for getting minimum filesystem info
    • Specification work
    • Review: PR: 1301, PR: 1304
  • distro:
    • dnspython - Examine failures of tests on the Ubuntu ADT network. Open upstream issue. While I have a workaround for tests to enable partial testing with IPv4, there is at least one more issue that isn’t solved yet (test_resolver / test_resolver_override). Investigating.
1 Like

I was on +1 rotation this week, but sadly wasn’t able to get too much done on it as some other time-critical issues came to light.



With my new upload powers, I proceeded to upload my longstanding merge branch, followed by a
quickfix as I got mixed up in my patches, resulting in a FTBFS.

I also prepared a Jammy SRU for the following bugs:


  • Followed up on the LLVM-13 patches for rustc 1.59 in kinetic
  • Patched rustc in kinetic to downgrade the llvm-13 relationship from Recommends to Suggests in order to avoid having to MIR the z3 package (uploaded by slyon, thanks!): LP: #1971128
  • Uploaded backports of 1.58.1 then 1.59 to a security PPA for the Firefox 101 release
    => Still investigating a build failure on s390x

+1 maintenance

  • astroquery: followed up on @alexghiti’s work by submitting his patch to both upstream and Debian.
  • ruby-tty-screen: FTBFS on s390x due to an endianness error. Fixed upstream, I submitted a MR to Salsa to cherry-pick the patch
  • debsig-verify: added a delta to accept zstd-compressed .deb packages.
  • ruby-gitlab-fog-azure-rm: patched out the invocations into explicit ones, submitted both to upstream and Debian.
  • fastp: FTBFS on s390x due to missing libisal-dev, which in turns FTBFS due to endianness issues. Cherry-picked a patch upstream and submitted it to Debian



I spend most of my time on the test suite of Apport to make it run successfully in every environment (schroot, docker, autopkgtest). Now all UI tests (generic, gtk, kde) succeed everywhere. Last step for the test suite is to convert the tests in into integration tests. Then they can be executed in containers. Afterwards I will release a new upstream release.

1 Like

Short week due to Memorial Day holiday.


  • Uploaded biosig to fix a build failure caused by incompatibility with new dcmtk and blocking octave transition


  • Fix by removing the code that prevents us from syncing the local apt mirror while another image build is in progress, because there is always an image build in progress
    • discover that the rsync service has broken and didn’t let cdimage-master access it. Filed RT, now resolved.
  • Release Team meeting discussing various meta topics for the team


  • Spec reviews for netplan and Raspberry Pi
  • Uploaded usb-creator to move it from genisoimage to xorriso, initially planned for the 21.10 cycle but delayed. Now needs an MIR.
1 Like
  • progress on netboot artifact publication
  • spec work and reviews
1 Like