Desktop Team Updates - Monday 6th December 2021

Hi everyone, below you will find the updates from the Desktop team from the last week. If you’re interested in discussing a topic please start a thread in the Desktop area of Discourse .

Last week’s notes are here: Desktop Team Updates - Monday 29th November 2021



  • Added support for sudo and client administration permissions in Active Directory

Desktop Installer


  • Added disk model and vendor names to subiquity’s storage V2 API
  • Added NetworkManagerClient.state for being able to distinguish between site-wide and global connectivity
  • Added missing docs to the logger package
  • Took another stab at the Python conflict with host Python vs. Flutter snap’s bundled Python
    • The idea was to add support for FLUTTER_CMAKE_ENVIRONMENT and FLUTTER_NINJA_ENVIRONMENT environment variables to the Flutter tool to be able to use the bundled Python at build time, yet leave it out of path at run time. While this technically avoids the Python conflict, it broke a whole lot of other things such as Git that is needed for Dart package dependencies from Git


  • Finished coding the CI linting action based on clang-format and clang-tidy with pull request review comments auto generated from the outputs of those two tools. Drifted from the starting purpose, but for the best.
  • Participated in the last Indaba about WSL.
  • Moving myself back to the clean-up of the shutdown/reboot feature.
1 Like


  • Added support for sudo and client administration permissions in Active Directory


  • Participated in the last Indaba about WSL.
1 Like
  • Updated thunderbird beta to 95.0b5
  • let gnome-remote-desktop depends on pipewire-media-session | wireplumber since without one of those the video streaming isn’t starting
  • reported a MIR for pipewire-media-session, Debian decided to stick to it as the default pipewire session manager until pipewire replaces pulseaudio. It probably makes sense for us to stick to it for the LTS since we aren’t replacing pulseaudio and it’s a simpler codebase to maintain and enough for the screen recording and remote desktop usecases.
  • interviews for the open desktop position
  • reported a MIR for xdg-desktop-portal-gnome
  • worked on eds SRU updates for the Gcontact service API deprecation
1 Like

firefox24 firefox

chromium22 chromium

  • updating stable to 96.0.4664.93
  • updating beta to 97.0.4692.36
  • updated dev to 98.0.4736.0
  • continued work on rebasing snap on core20, now successfully building on amd64 and armhf

flutter24 Ubuntu Desktop Installer

package24 other

1 Like
  • CUPS Snap: Waiting for @ijohnson’s pull request on snapd for the cups printing interface to get merged by the snapd team (especially a review by @jamesh is missing). I hope that now, after my successful tests, the final design decisions will get made soon and the PR approved.
  • cups-filters: Started switching the implicitclass backend of cups-browsed from calling CUPS filters as external executables to use filter functions. On the way found some bugs: In the universal() filter function do not call pdftopdf() on input data in application/vnd.cups-pdf, this data is considered as already treated by pdftopdf() (commit), fixed environment variable handling in filterExternalCUPS() (commit), and created a debug helper filter function to check data passing between two filter functions in a chain (filterTee()). Also accepted a Pull Request making sure that when the driverless utility communicates with a device with IPPS URI the communication is encrypted.
  • ghostscript: Uploaded a merge with Debian, prepared by @paride who had problems with symbol lists on non-amd64 architectures, but I ran into the same problems. The small, bug-fixing patches which the merge adds have no influence on the symbols, so something in the build server environment must have changed. Struggled with the dput upload through the cellphone-network-based internet access here, but finally succeeded with the upload process by doing it through the Canonical VPN (set for all internet access through VPN, but this is independent of the symbol table problem). Update: Got solved, really solved, thanks @vorlon!
  • Bugs.
  • Finished libcanberra - thanks @oSoMoN for all of your help!
  • Kept working on cherrytree, trying to build it with all of the gtk4 components and worked with @kenvandine alot on debugging a gtk4 build issue. Here is my cherrytree wip branch. Since adding major pieces to the gnome-sdk and platform snaps is cumbersome, I added parts as needed to cherrytree with the plan of eventually moving them to the sdk snap. Ken found a hack to get past this build error for now.
  • Continuing to debug access issues for the data analytics stuff. The progress of that is being tracked in CR134507. It would be good to sort this out so that @local-optimum and I can start doing things with the data.
  • Gnome snaps stuff:
    • gnome-tetravex: did some cleanups
    • lightsoff: updated to newer base but not sure why the desktop icon seems like it’s missing. Could use another pair of eyes to debug that. Here is my WIP PR that includes those changes.
  • Had another successful Indaba! Thanks to the Enterprise desktop team for doing such a great job showcasing WSL!! Thanks @madhens @jibel @cnihelton and @didrocks - you all rock!