Very slow Wifi (~1mbps) when connecting to router (Tri-Band) (Intel Corp. Wireless 3165 rev79)

I have Ubuntu 22.04.1 LTS on mini pc, never used Linux before, used windows 10 and everything worked fine.
Router model Asus RT-AX92U,
WIFI network that I use set up as Tri-Band Smart Connect (2.4 GHz, 5 GHz-1 and 5 GHz-2) all channel settings set to Auto.

When I connect to my home WIFI I get very slow speed, if I run hot-spot on my phone I get probably the max speed my phone can provide (~40mbps).

When I check router admin panel it shows that my mini pc connected using 5G-1 band.

This is the only device that has this problem. I tried every possible solution that I was able to find but nothing works.
tried to set connection settings such as channel and band, edit iwlconf file,
added iwlwifi-7265d-29.ucode to /lib/firmware, updated OS and apt etc.

spent 2 days trying to “fix” it :man_facepalming:

How fix it?


This site isn’t designed for technical support. The Finding Help topic details where you can get support for Ubuntu. Alternately, if you believe that this is a bug, then please file a bug report.