Ubuntu Server 20.04 fails with subiquity errors

I have an Ubuntu Server 20.04.1 iso image on a usb. When I install this on my pc (intel) I get past the User setup page and then the Installer says it has encountered an error. When looking at the log I see a lot of subiquity errors

This install has been successful in the past and the way this worked, was that I disabled all network interfaces. That trick seems to no longer work. Even when I connect an ethernet to a network that has a DHCP server, an IP is found and set for the interface, but it will not connect to anything outside the company due to a proxy is not set, and I cannot set one for this PC. There is an option to continue the install without updating, and I select that.

Has anyone seen subiquity errors during an install?

I hadto find a Legacy 20.04.1 iso image which has a different Installer interface that worked. It may not have subiquity, but I cannot tell. This one still needed a network and I set one as above and skipped any updates, and this install works!!


This site isn’t designed for technical support. The Finding Help topic details where you can get support for Ubuntu.