Testing unity session in Focal Fossa - 20.04

It’s been a long time since, I moved my systems to Focal, mostly interested in how Unity does with Focal Fossa. Doing really well, without any hiccups. Anyone else?

With full Compiz eye-candy…and, on-line Office suite.
Many thanks to @khurshid-alam!


You have update from another version of Ubuntu like 19.10 or is a fresh install?

Have a read here and here.

Seems ok.
The ubuntu-unity-desktop package has some deps of questionable valve like x-term, gdebi & geary which pull in an additional 70 packages, but whatever…
What is missing is the video and music scope packages, both of which still work ok.
The Photos scope is & has been broken for a long time, if not fixable maybe should be removed from the Dash & Home button…

I used --no-install-recommends to keep most of the unneeded stuff off. @khurshid-alam

Has the fix for showing the username in the upper panel been merged? @khurshid-alam showed a simple fix but I searched and couldn’t find it, if anybody can repeat it here it would be great.

I found it, it is comment #10 in this bug report:

"That is because XDG_SEAT and XDG_SESSION_ID are not set anymore & indicator-session depends on it.

dbus-x11 installs /etc/X11/Xsession.d/95dbus_update-activation-env which unsets those env variables.

Comment out those & reboot. It will work again."

Picture scope always works with shotwell. Can you post some logs?

And about the meta package, I will update it soon.

You’re right, for quite some time I’d forgotten you’d need to import photos to shotwell for the scope to show…

Is there a way to delete/uninstall photos, music, videos scopes from the Unity menu?

1 Like

Unity works much better than any other Linux DE on touch screens – inbuilt actions and those helped by Unity Tweak. While Gnome and Plasma has only one useful touch action, Unity has a multitude of them. Touch screen edges, corners all work, even pulling from top edge would either invoke the global menu or remove it. All touch actions are reversible.

Unity is the only touch friendly Linux DE, other than Unity 8 of UBPorts. The default Ubuntu doesn’t have any touch actions, just checked.


Howdy chanath and all Unity fans, and sorry for this propaganda :slight_smile: LOL

Unity is not just better on touch screens, it is better in every way there is :slight_smile: The simplicity and common sense of Unity, is not present in any other DE. I’m telling you, they (Mark, Canonical) haha don’t have any idea what they achieved.

F* masterpiece!

The only problem now is that ppl using unity are not so loud and extrovert so it can seem that Unity is being forgotten.

the opposite is true!

Unity eXPerience - Unity on steroids - so far the best Unity so far, from Brazil <3



I run an Update from 18.04 to 20.04 to test the new LTS. Now I cant run Unity-Tweak tool because it misses the HUD schema. I cant find the package in any place. Can someone point me the package?

Notwithstanding the value of that tweak tool I guess as it stands now you’d need to install the hud package.
There is no hud package in 20.04, maybe because it doesn’t work anymore?? (don’t know, never used hud…
If that’s the case then the tweak tool should be fixed, maybe file a bug report. (if anyone still maintains it.

In the meantime I guess you could locate & install the 19.10 hud package.

A couple of current oddities here.
With auto login windows in the light-themes show a white line around any window. They go away with a log out/in.
gnome-tweaks opens without showing the sidebar or any window controls, window must be expanded to show.

HUD doesn’t compile on focal ATM, but not sure why it wasn’t copied from eoan archive.

Adaptation of yaru theme to Unity without the gnome app decoration problem.

Download the theme to test the theme. https://github.com/Initu-Castilhos/Yaru-Unity

1 Like

Cannot be downloaded.

1 Like

Please fix pidgin messaging-menu integration from here. https://bugs.launchpad.net/ubuntu/+source/pidgin-libnotify/+bug/1339405

I tested the patch and it worked.