Testing Unity Session in 19.04

As far as using nemo to provide use of the Desktop it wouldn’t need patching if you can get an appropriate file into /etc/xdg/autostart.
In that test ppa I did that via a symlink in the debian file.
The reason for patching it was to allow it to show up in startup applications, also removed the OnlyShowIn= line, whether that mattered didn’t bother to ck.

The other reasons to patch nemo were to give it useful desktop actions compared to default couple (likely missing some translations in the added ones), give it a name different then nautilus and an icon different than nautilus.
The 3rd patch was for one of the supplied extensions which is by default is non-functional in an unity session.

So all in all rather insignificant other than getting nemo-autostart to run on login.
Any user that wants to use nemo as their main or only file manager can ‘improve’ their experience on their own after the fact.

Since Unity Tweak Tool isn’t working, how can I enable virtual desktops?

Appearance > Behaviour > Enable workplaces, you got 4.
CCSM > General options > Desktop size, you can have any amount

:woman_facepalming: I’m blind…

I just installed Ubuntu 19.04 daily iso in a Virtualbox. After installation and upgrading, I installed ubuntu-unity-desktop just from the repos.

I restarted the system, and instead of seeing this issue, the first time that I tried to start Unity from lightdm it returned to the greeter without starting it, but the second time (and further) it started fine. What is does not work is logging out from the session to go back to the greeter, it just freezes with only the desktop background without doing anything.

Apart from this Unity seems to work fine with the version from the official repository.

@walter-garcia

Yes, There seems to be some time out error for unity7.service. It has something to do with gsettings regression. Open ccsm->preference

check profile is set to unity, and change backend to flat-file. Can you reproduce ? You may need to create a new user everytime.

Also install ubuntu-session, gnome-system-log. Create a new user in gnome-shell. Now try to login to unity with that user. When fails go back gnome-shell, open gnome-system-log and search for exec gnome-session --session=unity and post log (pastebin or somewhere) after that till it goes back to session. If you find many search result choose the latest one or clean syslog (/var/log/syslog) and systemctl status rsyslog.service

Also unity.conf and other files are moving out from compiz to unity. I am preparing a new ppa for that. I will post here when it’s ready. That one requires extensive testing.

1 Like

I believe, after you install unity and rebooted into it, you should purge the other DE and all dependencies completely from the system, leaving only Unity. That way, the unity greeter would boot you into the system. Try this on bare metal.

Hi all,

Unity.conf and other conf files are moving out of compiz to unity and a bileto ticket has been created.

The PPA is this : https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3639/

Add the PPA and upgrade both unity and compiz and check if it is working for you. After login open ccsm and check if unity profile is selected. Do the same for unity-lowgfx.

And if possible try installing on a separate partition on a real hardware.

Thanks.

Update: The PPA is not needed anymore, both unity and compiz are now in the repo.

@mc3man @dale-f-beaudoin @walter-garcia @chanath

I don’t have much experience with CCSM, but I assume this is what you’re looking for?

Screenshot from 2019-02-08 02-43-07

What is this Flat-file Configuration Backend? What is the difference between the two backends?
If I choose Flat-file Configuration Backend, Unity works, but all my former settings were gone. Returned to Gsettings Configuration Backend, rebooted and all former settings came back. (These Compiz settings were from Ubuntu 14.04 days, btw, just adding to a new Ubuntu.) And, Unity works quite well.

Btw, the hotcorners setting works too, even with UTT fully purged. Do you know, where the hotcorner setting is stored in the system?

I tried the following things, still in a Virtualbox:

  1. I set profile to unity and changed backend to flat-file in CCSM -> preference.
  2. Log out from the session is still not going back to the greeter, I just get a screen with the background and nothing else.

Then:

  1. Created a new user in gnome-shell
  2. I tried to log in Unity with this new user.

The login first showed a couple of dialogs on Online Accounts and other configurations for the new user, and then Unity did not start and threw me back to the greeter.

I went back to gnome-shell, but gnome-system-logs did not find anything searching for “exec gnome-session”.

This weekend I will try the PPA in real hardware.

Hotcorners are just ccsm->scale plugin. For example if you set in bottom-right- corner to initiate all windows, in dconf it will be
/org/compiz/profiles/unity/plugins/scale/initiate-all-edge 'BottomRight'

Now with the PPA, I can’t reproduce the segfaults and crash any more. So do try it.

Thanks! :slight_smile:
Its been a long time, since I played with ccsm settings. I just import the settings I had few years ago.

Btw, do you know the name the icon on Unity top panel’s rightmost position, after the clock?
EDIT: I found it, it is called system-devices-panel

On fresh install current Ubuntu image, uodated, then ubuntu-unity-desktop installed.
After reboot & login a logout fails every time.
Reboot/shutdown work fine, logouts in an ubuntu session are ok

That’s most likely issue with systemd 240, downgrade to 239 and see if you can reproduce.

How to downgrade to systemd 239?

What happened to the new PPA? Do we still need it?

E: The repository 'http://ppa.launchpad.net/ci-train-ppa-service/3639/ubuntu disco Release' no longer has a Release file.

No. Not anymore. It got published yesterday. :slight_smile:

2 Likes

Go to https://launchpad.net/ubuntu/+source/systemd/239-7ubuntu15

Use

sudo apt-get install <package-name>=<package-version-number> for following 5 packages, for me apt didn’t work bcz I am not on main server,

OR
Download these 5 files for you arch

libnss-systemd,  systemd-sysv,
libpam-systemd,  systemd,
libsystemd0

Copy it to /home/$user/systemd-239 from other partition or you can boot from usb and copy them to installed partition.

Then from grub->advanced->recovery-<drop-to-root-shell

cd /home/$user/systemd-239
dpkg -i --force-downgrade *.deb
1 Like