Monday 10th December

Hi everyone, below you will find the updates from the Desktop team from the last week.

If you’re interested in discussing a topic please start a thread in the Desktop area of the Community Hub (this site).
We also have our weekly meeting on IRC. We meet on Tuesday at 13:30 UTC in #ubuntu-desktop on Freenode. There will be an “Any Other Business” section at the end where you are welcome to raise topics. These topics might be discussed during the meeting, or afterwards depending on the time, depth of conversation, topic and so on.

Last week’s notes are here: Monday 3rd December 2018
Next week’s notes are here: Monday 17th December 2018

1 Like

No change to release bugs.

1 Like


  • Merged upstream changes into snap-store
  • Updated to build with core18
  • Fixed launching of snap:// URLs Bug


  • Testing of bionic SRU
    • Found regression, working on a updating the SRU with a fix

Desktop Portals:

  • Portals PPA to do the prep work and testing of portals backported to supported releases
    • Backported latest xdg-desktop-portal for cosmic in the Portals PPA
    • Backported latest xdg-desktop-portal{,-gtk} for bionic in the Portals PPA
    • Backported latest xdg-desktop-portal{,-gtk} for xenial in the Portals PPA

:speaker: PulseAudio:

:computer_mouse: Gnome Shell performance (stutter | latency | CPU):

:mag_right: Investigated Nvidia+Wayland issues:

  • Waited a few days for the “required” dependencies to get published but they’re still not done. Built them myself and then found they’re not required to get as far as logging in and using a Wayland session with Nvidia. Still, there are actually multiple separate problems that I’ve now tried to outline in the bug.
  • Users of 19.04 can indeed install nvidia-driver-410 and enable Wayland with nvidia-drm.modeset=1 right now. You can log in and use the desktop but:
    • it’s very heavy on the CPU (likely because EGLStreams support is missing, slow buffer copies?); and
    • GLX apps (via Xwayland) are not accelerated at all (they use LLVMpipe software rendering).

:house: Housekeeping:

  • :man_dancing: Finally migrated my development machine to disco.

:bug: Bug management:

1 Like

snapd dbus service activation:

  • PR #6258 is still progressing. There is still some work to be done on the tests and I need to get it reviewed.
  • Under testing, I discovered that directly activated (as opposed to systemd activated) system bus services were failing. As Ubuntu 14.04 doesn’t support systemd activation, it basically meant system bus service activation didn’t work at all there. Further more, changing things to work with 14.04 would make supporting Ubuntu Core systems more difficult. I’m following up with the snapd guys to decide how to proceed.
  • With bus activated services the most appropriate systemd service type is dbus, where the service is considered started when a given bus name is claimed. Snapd can generate unit files of this type, but Snapcraft and review-tools both consider it a syntax error. I started a thread to see what we can do about this. On the bright side, the fact you can’t currently publish a snap using daemon: dbus means we’re free to change the behaviour if appropriate.

No rls bugs.

  • opened a MIR for fonts-yrsa-rasa (new depends of fonts-gujr in disco)
  • updated gupnp/gssdp following MIR review comments
  • updated duplicity in cosmic and looked at an python encoding error
  • SRU verification (gvfs/bionic&cosmic, shotwell/bionic&cosmic, libgnomekbd/bionic&cosmic)
  • helped investigating a poppler regression from the security update
  • updated network-manager to the current 1.12 in disco & merged wowlan changes from alfonso
  • launchpad bugs/e.u.c triagging

This was a short week, I was offline on Thursday and Friday.

firefox24 firefox

chromium22 chromium

  • updated stable to 71.0.3578.80
  • updated chromium-ffmpeg for chromium 71, and updated documentation
  • updated dev to 72.0.3626.7
  • re-published an old core16-based snap in the stable/core16 channel for Fedora 29 users because of a problem there

libreoffice24-margin libreoffice

  • promoted the core18-based snap to stable (and kept the core16-based one in the stable/core16 channel for Fedora 29 users because of a problem there)
  • fixed unit test failures with 1:6.1.3-0ubuntu6 in disco-proposed (bug #1806847)
  • validated 6.0.7 bionic SRU

:bug: rls-bb-tracking bugs

  • bug #1754671 in network-manager: still being tested from test PPA with 1.10.14
  • bug #1765304 in gnome-shell: @Laney uploaded (thanks!), now sitting in the unapproved queue
  • bug #1799230 in libreoffice: in bionic-proposed and verified, expected to migrate to -updates soon
  • bug #1802208 in libreoffice: no progress since last week

:bug: rls-cc-tracking bugs

  • bug #1803142 in libreoffice: still sitting in the unapproved queue


  • Packaged some GTK emoji fixes for Disco & started SRUs for 18.04 and 18.10
  • Released GNOME Tweaks 3.30.2 and prepared the Cosmic SRU
  • Did GNOME 3.31.3 releases for gedit, gnome-menus, Mahjongg, Tali, Tetravex, Tweaks, Quadrapassel
  • Proposed a Night Light color slider for GNOME Settings
  • Cleaned up deprecations in GNOME Settings app’s Mouse & Power panels
  • Added Keyboard Shortcut overlays to Chess, Mahjongg, Mines, Tali, and Tetravex
  • Updated these apps for the new GNOME 3.32 menu recommendations: Chess, D-Feet, gtk-widget-factory, Deja Dup, Dictionary (proposed), Iagno, Klotski, Nibbles, Quadrapassel, Robots, Tali, Tetravex, Yelp (proposed)
  • Switched Tali and Tetravex from autotools to meson
  • Started discussion about how keyboard accessibility for the new GNOME “primary menus” should work
  • Reverted our Tracker packaging to use autotools because of autopkgtest regressions seen with Meson
  • Helped with the ongoing poppler/hunspell/libzip/glew transition
  • Sponsored appstream-glib and snapd-glib disco updates for Robert
  • Escalated gnome-desktop 32-bit thumbnailing regression to Laney

  • Rls bugs:
    • Segmentation fault on gnome-shell debugt exit: mutter is in main, gjs is in cosmic-proposed
    • Ubuntu dock/launcher is shown on the lock screen: it looks like that the problem has not be completely fixed. I took another look last week but without being able to reproduce it’s a bit hard.
    • gnome session: Must ask twice to lock the screen: same as above

My week:

  • cups-browsed: Fixed following bugs:
    • On shutdown queues were removed even if they had jobs
    • In some cases cups-browsed crashed on shutdown
  • cups-filters:
    • Let pdftops filter use Poppler for more Apple LaserWriter models due to PostScript interpreter bug in the printers
    • Released 1.21.5 due to the fixes for Poppler 0.71 compatibility
  • GTK: Prepared SRU for print dialog patch to avoid erroneous print jobs after PPD change.
  • network-manager: First look into project
  • Bugs.

P. S.: Upstream maintainer for avahi still urgently needed.


1 Like