Inkscape snap .config

I have a concern. I use Inkscape a lot. And by purpose, I use the PPA and not the snap. Mainly because I want to add palettes and symbols through.config and usr/share. I was told that this won’t work if we use snap. In GIMP as well, there are a lot of additional perks we add through .config. GIMP and Inkscape are useless without some plugins which are added through .config. I would like to know what the team thinks about it.

~/.config in snaps is simply ~/snap/snapname/current/.config, you should definitely be able to add things to it as you are used to …

as of /usr/share, thats a matter of the snap maintainer to support.

the snap packaging system provides /var/snap/snapname/current or /var/snap/snapname/common for such global bits … but as i said above, the package maintainer needs to make use of these features.


The common folder for Inkscape is empty. No sign of .config. Do we need to create them manually like .themes ?


it definitely exists for me:

$ ls -al ~/snap/inkscape/current/
insgesamt 48
drwxr-xr-x 4 ogra ogra  4096 Apr 14  2019 .
drwxr-xr-x 5 ogra ogra  4096 Aug  2  2019 ..
drwxrwxr-x 7 ogra ogra  4096 Dez 28  2018 .config

we should move this discussion to though, it is really not related to this topic …

1 Like

Ok, thanks. I was looking under common. Please allow just one question.

Do we need to create folders inside .config ? Please see what the deb version has

And the snap version has this

dunno, i dont use additional palettes or extensions with mine … just trying to create one of the dirs might have been faster than taking two screenshots and asking here tough :slight_smile:

Valid point. I tried without success :frowning:

Even tried putting in .local folder ( just in case ).

Your first screenshot is ~/.config/inkscape, while the second is ~/snap/inkscape/current/.config, so I think you at least need to create the inkscape directory there. That should be the same spot as the first screenshot is for the deb.

Tried that as well. Looks like we need to use a numbered folder in


current should be a link to the latest version’s numbered folder, so AFAIK it’s the one you want to be using.

I tried using " current " first. It won’t fetch from it. But if you put inside the numbered folder, it will put a copy inside " current " automatically. I can confirm that it works.

Another issue with the snap version is it breaks the Materia theme which was working in the deb version today morning. Did Inkscape fallback to some old GTK version ?