How to close the Snap Store to allow Snapd to update it

Elsewhere I found this advice, which at least did not give me an error message in the terminal, so may just have worked:

You’ll have to end up killing the snap store as simply closing the window keeps the store running in the background:

killall snap-store

Then tell snapd to update all snaps:

sudo snap refresh


killall snap-store

Tha’s what I had to do couple of days ago when we got the Snap Store update.


Awesome, worked excellent.
Thank You _ very much appreciated.

Choosing “Quiet” isn’t working for me Ubuntu 20.04.5 LTS, so only option for me was:
snap-store --quit
sudo snap refresh


I too ran into the same issue. I was only able to update snap-store (Ubuntu Software) by running:

$ killall snap-store
$ sudo snap refresh snap-store

@SergioCostas I tried the command you suggested, but as of version “41.3-66-gfe1e325”, it doesn’t look like it’s working or available yet.

$ snap-store --quit-on-close-for-update
Unknown option --quit-on-close-for-update

Sorry, my fault: I presumed that that patch was merged, but it wasn’t. So that option isn’t available… yet.


I hope it becomes the default. It wouldn’t do to have to start the snap store from the command line rather than have it start up automatically without it.

This works, Many thanks!!!

Thanks wmrp. It`s works. :+1:

This worked perfectly. Thank you.

Users are still running into this three months later – do we need to visit every user and ask them to run manual commands to update? Or just hope we catch them at the next LTS upgrade cycle?


This one worked for me. Thankyou

It is not a solution for the stable channel, but the new flutter based snap-store does not have this problem

sudo snap refresh snap-store --channel=preview/edge

edit: in order to refresh the snap you still need to close it but you can just close the window however you like


Is there anyone working on driving the snap update topic


Thank you for the information it worked like a charm for me.

Thank you, thank you, thank you!! It worked!!

This is still an issue with the latest release, I came here after trying everything and after a little bit of scrolling i found killall snap-store and then sudo snap refresh worked a treat. I no longer have an update which is refusing to update so thank you all.


This is the one that work For me, I don’t k ow why Canonical don’t fix that issue

1 Like

These two commands will update snap store on Ubuntu 20.04LTS. Hope this helps.
snap-store --quit
snap refresh snap-store


Folks should read the first couple posts in the topic, which should answer your question. If you need further technical support, see our Finding Help topic.