Help with Edubuntu Desktop Installer

Hello again Desktop Team!

Yes, edubuntu-desktop-installer has the same issue ubuntu-desktop-installer had before the mesa fix and, despite the fix, the issue persists. I’ve filed this tracking bug with the terminal output.

As Edubuntu is miles closer to Ubuntu Desktop than Ubuntu Studio (or any other flavor for that matter!), this should be much easier to fix.

Again, here’s a screenshot for reference and/or posterity.


Hey Erich,

So I poked a bit at that and it seems like a snapcraft regression, we are seeing similar issue with the desktop installer if we rebuild it.

Basically LD_LIBRARY_PATH isn’t being set in the snap environment anymore, I’ve reported it as

Workaround if you want to try the daily ISO

edubuntu@edubuntu:~$ snap run --shell edubuntu-desktop-installer
edubuntu@edubuntu:~$ export LD_LIBRARY_PATH=/var/lib/snapd/lib/gl:/var/lib/snapd/lib/gl32:/var/lib/snapd/void:/snap/edubuntu-desktop-installer/11/lib:/snap/edubuntu-desktop-installer/11/usr/lib:/snap/edubuntu-desktop-installer/11/lib/x86_64-linux-gnu:/snap/edubuntu-desktop-installer/11/usr/lib/x86_64-linux-gnu
edubuntu@edubuntu:~$ edubuntu-desktop-installer
1 Like

Sounds good. Right now I’m trying a rebuild using snapcraft 7.x/stable to see if that helps since we’ve determined this is a regression in snapcraft itself.

1 Like

The workaround described is enough for the UI but not for the subiquity subprocess, rebuilding with snapcraft stable/7.x is probably a better option until the problem is resolved

1 Like

Looks like snapcraft 7.x/stable worked for the build solution. Further testing is going on, and I do need to solidify the slideshow (which is currently the Ubuntu Studio slideshow from where I forked it), but progress is progress!

I did an Edubuntu install today. I reported a bug and figured out the workaround. With the workaround, the install completed successfully.

1 Like

What’s interesting about that is that I added lvm2 to the live seed as a dependency, so I’m not entirely sure what’s going wrong there.

1 Like


While the white screen issue is, at least temporarily, fixed by downgrading snapcraft to stable/7.x, @jbicha’s bug up above persists even after adding lvm2 and mdadm to Edubuntu’s live seed, meaning it’s either a bug in subiquity or in edubuntu-desktop-installer.

To attempt to mitigate, I added lvm2 and mdadm to the subiquitydeps stanza in the snapcraft.yml for edubuntu-desktop-installer [1][2] to see if it would at least do something.

We’ll see on the next live .iso build.

[2] No, I did not have to format this like that in Discourse. :stuck_out_tongue:

1 Like

lvm2 is still not listed in the daily manifest file. I don’t know why it didn’t get added, because mdadm is there now.

1 Like

Indeed. It’s almost as if there’s a blacklist or some kind of conflict preventing it from being installed. Either way, the commit in my previous comment seems to have worked because now it no longer crashes with the additions to the subiquitydeps stanza in snapcraft.yml so I think we’re finally over the final hurdle.

The rest is just the slideshow, which I can handle with no issue. :slight_smile:

1 Like

Erich - I don’t see where in the snapcraft.yaml you managed to convince launchpad to build with the 7.x series. How do you achieve that?

It has to be done from Launchpad:


1 Like


We have a working Edubuntu Desktop Installer!

Unfortunately, we have one glaring issue/omission. The ubuntu-flavor-installer framework apparently lacks the --try-or-install flag, so the “Try or Install” functionality of ubuntu-desktop-installer does not function. This is unfortunate because edubuntu-desktop-installer is attempting to pass that flag when first booted and is using the same mechanism (a systemd service file) to remove the dock and desktop icons, albeit with a package as opposed to in casper itself.

However, the mechanism isn’t important as much as the command line being passed is still edubuntu-desktop-installer --try-or-install which, if feature parity were a thing, it should still begin with a “Try or Install” screen after language and keyboard selection. (Bug Report)

Another thing that would be nice is if this graphic could be customized to, for instance, the Edubuntu logo or something since, honestly, it won’t fit with all flavors’ theming:


So it’s getting better! Two issues solved, with one new issue.

First of all, we have some slightly better branding!

And the try/install screen now works! But…

…I’d very much like to replace that logo and, despite dropping the requisite replacement images in the assets directory, I could not override that image. That’s a problem (Bug Report).

1 Like