Gamebuntu

Thanks for joining our Discourse and for your extremely constructive feedback and suggestions! And seriously, we are so proud of Rudra, and everything he has done for the community. Ubuntu is seriously, seriously lucky to have him. :star_struck:

For you and anyone in this thread, Rudra will be presenting on Gamebuntu at our virtual FOSDEM stand this weekend! His Gamebuntu session will be at 12:00:00 PM. If you’d like to chat with him ‘in person’, you all are invited to attend! :belgium:

2 Likes

Thank you @madhens and @gardotd426 :) The screenshots are really useful.

The AppImage for Gamebuntu has been replaced with a package in the MPR. Here’s how to install it using una: https://gitlab.com/rswat09/gamebuntu/-/blob/main/README.md

It will make the update process more streamlined as I package and upload more and more game-related tools to the MPR (which is basically the AUR for Debian and Ubuntu-based systems).

1 Like

Removing the appimage made this incredibly difficult to install. first, couldnt get makedeb to install without going to its github and following its install instructions seperate from your github.
Then, copy and pasting the install instructions kept giving PKGBUILD NOT FOUND errors on the Makedeb line, i had to manually navigate to the folder and makedeb manually.

the install instructions need updating on github (or restore the appimage for simple installation.

Any chance of an All-in-one install.sh or something? check if wget is installed, install if missing, check if makedeb is installed, install if missing, then install?

Next: Gamehub is not creating an entry in Show applications. i can launch via terminal, but nothing from the ubuntu gui. how do i add gamehub to the Ubuntu Show applications menu?

OpenRGB had to be uninstalled, then reinstalled using the instructions on the OpenRGB github. the install done by Gamebuntu would open, then close immediatly, and a crash report would pop. i diddnt save the crash report.

FYI, the installation instructions on GitLab didn’t mention installing makedeb manually. You can just run the installation commands without makedeb being installed. Marius from 9to5Linux didn’t face any issues with the installation instructions.

hmm, that’s strange (a desktop file does get installed to /usr/share/applications/com.github.tkashkin.gamehub.desktop and it appears in GNOME’s application launcher for me)

Installed OpenRGB from Gamebuntu just now and it seems to be working perfectly fine for me. Not sure why you’re facing these issues.

Hey rs2009, appreciate you following up with me.

The first thing I tried to do was simply run the installation commands listed on GitHub in terminal. As I stated previously, they did not work. This is what prompted installing makedeb manually, and the shenanigans there.

I also am not Marius from 9to5linux. I’m just some guy.

The installation was a base fresh Ubuntu install, the same version listed on GitHub. 20.04 IIRC. Cant remember, back on my win10 install RN (alas, Linux and VR seem like oil and water still.)

I did end up finding the .desktop file and moving it into the appropriate place, for me, it seemed to be in the Gamehub folder instead of the /usr/share/applications/ folder.

Me either. OpenRGB was detecting my motherboard (ASUS Aura), GPU (Gigabyte… also known as gigabad), and Keyboard (Corsair) but strangely did NOT detect my (also Corsair) mouse. Also, when it applied RGB Profiles, it deactivated my macros on the keyboard too. Ended up having to boot windows to fix it. So I ended up uninstalling OpenRGB anyway.

I honestly am considering reinstalling Ubuntu and re-starting from scratch because the things I had issues with were so… WEIRD, and I’d like to document them for you, because I absolutely love the idea of your application, and what it’s doing (for everyone who isn’t me apparently lol). My system set up isn’t weird or anything, so I don’t get it.
i5-8600k,
16gb ddr4,
2 NVMe SSDs and 1 4 TB HDD (none of these used for Linux, all with NTFS windows parts, OS drive, Games drive, storage)
2 250 GB SATA SSD’s in motherboard based Raid0 that Linux is getting installed on. EFI part, / part, and swap part all made correctly
3060Ti GPU, Dual monitors (1 1080p and 1 Ultra-wide 2560x1080), Webcam, Keyboard, Mouse…

Like, it’s a fairly standard gaming desktop, not super new, not ancient, and I just hit roadblock after roadblock.

When I tried the AppImage file a few weeks ago (I was using Linux Mint at the time and wasn’t trying to install, just view) the AppImage just launched first try and everything was peachy.

seems there’s a dependency issue in the latest Mint where una-bin is needed but can’t be found in an apt search :confused:

Are you sure you used the correct installation instructions? Gamebuntu’s installation instructions are on GitLab, while Una’s are on GitHub.

You need to follow the installation instructions from https://gitlab.com/rswat09/gamebuntu (the DEB package isn’t supposed to be installed manually).

1 Like

Hi @rs2009, Gamebuntu is great by making gaming easy for beginners! But the new installation method kinda made the app itself hard for beginners :grinning:

Yes, my dude, im sure that i followed the Gitlab instructions. as i said before, it was only after THEY DID NOT WORK that i went elsewhere to solve the problem myself.

you may want to do a fresh install of Ubuntu, and run them yourself to see.

@kazlehoff @ubuntuhandbook1 @premier69

I’ve simplified the installation process of Gamebuntu with una to a single command and updated the readme at https://gitlab.com/rswat09/gamebuntu#installation

1 Like

Where are we with fresh options for wine? The official repositories are missing, so is proton or the versions from tkg or glorious eggroll.
That is one of the more pressing issues as these bi-weekly releases increase the compatibility with games a lot.

1 Like

How are we doing on the various suggestions @rs2009? :slight_smile:

Is this project still going on? Not much news lately?

2 Likes

Yep, just been busy with other projects lately.

2 Likes

Any news about this would instantly raise my interest :star_struck:

Hello! I am excited about trying this on an Intel tablet. One question. You mentioned this would work with KBuntu, will it work on a lighter weight ubuntu distribution like Lubintu or even Puppy Linux (which is based on ubuntu)? That would be very helpful for sure! Thank you for all your hard work!

Pls help me, i cant install the deb so i tried the command from the gitlab and this is the output from the terminal

premier69@premier69-Lappy:~$ bash <(curl -fsL https://github.com/AFK-OS/una/raw/main/install.sh); una install gamebuntu-bin
deb [signed-by=/usr/share/keyrings/makedeb-archive-keyring.gpg arch=all]

(…i had to remove the links since i wasnt allowed to post more than 2 links)

Fetched 7 608 B in 1s (6 303 B/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
makedeb is already the newest version (16.0.0-stable).
The following packages were automatically installed and are no longer required:
glib-networking:i386 gstreamer1.0-plugins-good:i386 gstreamer1.0-x:i386 libaa1:i386 libavc1394-0:i386 libcaca0:i386 libcairo-gobject2:i386 libdv4:i386
libfaudio0:i386 libgdk-pixbuf-2.0-0:i386 libgstreamer-plugins-good1.0-0:i386 libgudev-1.0-0:i386 libiec61883-0:i386 libmp3lame0:i386 libmpg123-0:i386 libopenal1:i386
libproxy1v5:i386 libraw1394-11:i386 libshout3:i386 libslang2:i386 libsndio7.0:i386 libsoup2.4-1:i386 libspeex1:i386 libstb0:i386 libtag1v5:i386
libtag1v5-vanilla:i386 libtwolame0:i386 libvkd3d1:i386 libvpx7:i386 libvulkan1:i386 libwavpack1:i386 libwine libwine:i386 libxcb-randr0:i386 libxdamage1:i386
libxv1:i386 mesa-vulkan-drivers:i386 wine32:i386 wine64
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
/dev/fd/63: line 12: git: command not found
[!] PKGBUILD does not exist.
/dev/fd/63: line 15: una: command not found
/dev/fd/63: line 15: una: command not found
Command ‘una’ not found, did you mean:
command ‘uni’ from deb uniconf-tools (4.6.1-15build1)
command ‘unp’ from deb unp (2.0~pre9)
command ‘tuna’ from deb tuna (0.15-1)
command ‘ua’ from deb ubuntu-advantage-tools (27.13.6~22.04.1)
command ‘unar’ from deb unar (1.10.1-2build11)
Try: sudo apt install
premier69@premier69-Lappy:~$