Egmde - taking a drive on Ubuntu 16.04

egmde - taking a drive on 16.04

Taking a drive on 16.04?!

This is 2021! So why would anyone be using 16.04, as it will soon be “end of life”. Especially with the latest release of software? There is a reason: I’ve been doing a little work in my spare time to help progress Lomiri. And, as most of the UBports development is currently 16.04, using 16.04 makes things a little easier.

Why egmde?

As you may know from other threads, I have been experimenting with using Mir on the desktop and egmde is my “Mir desktop” of choice. So while I was using 16.04 for perhaps the last time I decided to try it.

Installation and setup

It is easy to install egmde on any system that supports snaps and 16.04 falls into that category.

sudo snap install egmde --classic

There is, however, a bit more setup needed than on more recent series. The Wayland support in the version of GTK, Qt and other toolkits from the 16.04 archive is poor, so we’ll have them use X11 via Xwayland.

This needs us to install Xwayland and add some configuration to the egmde setup.

sudo apt install xwayland
echo "app-env-amend=GDK_BACKEND=x11:QT_QPQ_PLATFORM=xcb:SDL_VIDEODRIVER=x11" >> ~/.config/egmde.config

I also always enable workspaces when I use egmde:

echo "no-of-workspaces=4" >> ~/.config/egmde.config

Running egmde

Having set egmde up this way I could log into a VT and run egmde as a “desktop” using the command:

egmde --shell-enable-autostart

Everything works well enough that I can do the work on Mir and QtMir that I am interested in. Obviously, it is a bit weird using a Wayland compositor to run an X11 desktop but it was fun to try and work pretty well!

The problems

I did find however, that I couldn’t log directly into egmde from the lightdm greeter as that doesn’t grok the egmde.desktop file in /usr/share/wayland-sessions/. This could probably be fixed but I didn’t spend enough time looking into it to figure out how to avoid these login errors.