22.04 Nvidia Drivers

Needed to apply in order get access to the crash reports…

I have access already if you can tell me the ID or have a link.

First gnome-shell crash report on 21st June (first install)
Second gnome-shell crash report on 22nd June (second install).

The first crash is Ubuntu 20.04 crashing with the Nvidia driver a year ago.

The second crash is Ubuntu 22.04 crashing with the nouveau driver a week ago.

So unfortunately neither of those relate to this discussion. We’re only interested in the Nvidia driver crashing on 22.04.


Then the crash happened when rebooting the machine and since it did not run up it could not send out a crash report.

I installed the 515 nvidia drivers had to remove xanmod kernel it installed. But refresh rate defaulted to 77hz on a 240hz with no possibility to change was using x11 not wayland but nvidia x settings did not work only showed a few options.

1 Like

@Shin, please report a bug by running:

ubuntu-bug nvidia-driver-515

or if that fails then use this link.

1 Like

The list of issues specific to Nvidia Wayland sessions is still growing.

@tseliot, maybe we should default to Xorg on hybrid systems too?

1 Like

@vanvugt fine by me.

1 Like

I’m having the same issue with 22.04 right after i install the nvidia drivers
the following is the current one:

after the driver installation i got black screen then i made changes in grub to "GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_backlight=vendor acpi_osi=linux nomodeset”
but now my device is not making use of my nvidia gtx 1650 gpu.

Can anyone help with this gpu issue?

I sorted out the issues with nVidia drivers on Ubuntu.
The black screen with blinking cursor occured when not installing nVidia drivers during a new system install but afterwards and not using the tested drivers but downloading them from nVidia, or when the nVidia driver is already installed and some system updates/upgrades are performed.
You will find more details in this launchpad issue.
When ever facing the black screen issue, then boot in recovery mode however is possible and remove/reinstall the tested drivers.
For the time being this is the commands to apply as it was proposed to me, and it worked:

$sudo apt-get --purge remove ‘nvidia
$sudo apt install linux-modules-nvidia-525-generic nvidia-driver-525

Please note that I previously reinstalled the system whenever I was having the black screen/blinking cursor, as I did not know there is always a workaround to start up Ubuntu from there, for example do: [CTRL] + [ALT] + [DEL] to regain access to the boot menu, or instead during boot keep pressing on the key that gives you access to the Ubuntu boot menu (‘Shift’ key with my Gigabyte mainboard) to select the recovery mode, or somewhere during boot when the system hangs I could regain control by clicking randomly on the function keys.
Selecting the Nouveau driver will also allow your system to boot normally without the black screen also subsequently allowing you to reinstall the nVidia tested drivers from a normally booted system.
Last but not least as I am updating my system with pre-releases and presently using 20.10 Kinetic, I had recently the same black screen issue after a system update and I had to downgrade to kernel from I believe a version (using Mainline).

Note that the Nvidia packaging does not play well with phased updates. For kernel 519.0-35, the Nvidia 525-76… driver got removed, but then phasing held back some nvidia 525-85 packages necessary to rebuild the nvidia modules – leaving the currently running kernel without an Nvidia driver. A day later the phasing caught up, all the Nvidia packages downloaded, and the modules rebuilt successfully. The “install” will force the issue if you don’t want to wait for the upgrade to get the packages released.

For support, Ask Ubuntu is a great resource.

@amarchouhan1709, you need to remove nomodeset because more recent NVIDIA drivers like 525 use “modeset”.

1 Like

I tried to search for this bug in launchpad, but I couldn’t find any record of it, and I don’t really know what information to provide as I have resolved it now. But, I want to echo what @ubfan1 has said.

With the phased updates, my computer restarted and I was left without nvidia drivers - I had to re-install them via the CLI. I don’t want this to be the case every time a kernel update happens going forward.
Edit: oh well, I’m an idiot - the launchpad issue was linked in the previous reply to ubfan1 >.< sorry!

1 Like

So my experience has been frustrating. I had an NVIDIA Quadro NVS 290. When I first upgraded to Ubuntu 20, I spent hours trying to figure out how to install the driver. After about 3 days of experimenting and trying I was finally able to build and install the NVIDIA proprietary driver from the root shell. However, I had to continually rebuild and reinstall the driver every time the kernel was updated. I finally got into a pretty good rhythm and I could re-build and re-install the driver before the reboot after a kernel upgrade and that worked well. Eventually, the Ubuntu installer started doing the rebuild automatically as part of the kernel upgrade. It was lovely.

Then I decided to upgrade to 22, and everything went to crud. I spent weeks attempting to reinstall the proprietary driver, tried the “generic” nouveau driver all without any luck. I could only ever run in recovery mode on a single display. I finally got fed up and bought a Radeon HD 5450 legacy graphics card. Plugged in, fired up, worked instantly. I have had my fill of Nvidia on Linux.

I use MSI Katana GF66, Since I have upgraded my system to 64GB RAM and 1.5TB NVME SSD, and installed Ubuntu 22.04, I was facing lag while connected to a 75hz monitor via HDMI also very laggy display,

I have tried all solutions but ended up using this which works as the driver compatibility with GeForce 3060 Mobile.

The only solution i found that I have switched to Integrated Graphics

sudo apt update
sudo apt install nvidia-driver-xxx nvidia-prime (xxx  is the your version )

sudo prime-select intel

prime-select query
It should return intel .

Sounds like LP#1970291 so try logging into Xorg instead.

I had constant crashes and figured out the problem was my Nvidia GPU. Nvidia drivers are are not compatible on Ubuntu. I switched to my Intel GPU and crashes are gone. For Ubuntu just use AMD or Intel. Problem is AMD are all power hogs and will wreck a regular office machine that does not have 500 PSU or greater. I don’t do gaming so I don’t even need a great GPU. Just no more crashing is all I care about now. Lesson learned. Make sure you only buy a computer that can support the non-Nvidia GPU of your choice. That means find out how much power your GPU REALLY will require, not what the manufacturer claims.

What worked for me was to uninstall and purge all nvidia and switch to Intel GPU. CAUTION: This is not easy to do without issue but worst case scenario you can boot into recovery mode and put in the commands to purge all nvidia. There are instructions to be found. I’m no gamer. No more crashes.