Wayland not working with NVIDIA

Hi guys. Nvidia user here. I’d like to enable Wayland (despite the risks, to try it out)

I can’t though, because I don’t know how and there is no guide.

On an ubuntu 19.04 on a system with an Nvidia graphic card, the cog does not show up in the login screen.

what do I do?

Hi @tatsu,

if you click on the settings icon on the login screen you can see an option for Wayland session.

You’ll need to properly enable KMS for nvidia, then probably the session option would show up.
What happens then may depend on hardware, optimus devices will fallback to intel in a wayland session, nvidia only machines you may log in to crappy performance or you may log into llvmpipe crappy performance or you may not log in at all…

that’s what I mean it does not show up at all. i can ad other xorg options there for it to show up but no wayland options : https://askubuntu.com/questions/1175554/ubuntu-19-04-wayland-on-nvidia

i don’t have intel graphics on my cpu, i only have nvidia graphics. this is a full tower case.

What NVIDIA card are using? Check out the thread below.


You need to enable KMS, did you?

thanks for the link.
I am using an Nvidia GTX 760

the command grep modeset /etc/modprobe.d/* /lib/modprobe.d/* did not return anything for me.

Also I don’t know what KMS is or how to enable it.

EDIT: I found this : https://wiki.archlinux.org/index.php/NVIDIA#DRM_kernel_mode_setting

so I tried it by adding : nvidia-drm.modeset=1 to my grub like so :

sudo gedit /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" -> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1"

I then ran

sudo update-initramfs -u


sudo update-grub

then rebooted, this resulted in desktop failing to load and me staying on the background color of the ubuntu boot screen, although I could access TTY and reverse it.

either that’s not what I was to do or my hardware/software combination is entirely incompatible with wayland.

That’s what you have to do for Nvidia - I’ve disabled it for myself at the moment, without accel working in XWayland it’s too annoying. (I use it exclusively on Intel machines though)

If you want to try it you really want to upgrade to 19.10 first, the latest nvidia driver - nvidia-430 driver (not available in 19.04) and latest gnome-shell are really needed for the best experience.

EDIT, Yes I meant to say without using a PPA. If you already on 430 then I would have expected it to work a bit better.


@bryanquigley the new topic seemed to be locked, I could not answer there. thanks for the tip anyhow, I was thinking of trying 19.10 anyhow.

Note, though, that contrary to what you claim, 430 (and even 435! (though 435 has dependency issues)) are available under ubuntu 19.04 with the nvidia PPA. (ppa:graphics-drivers/ppa) and I’m using the 430 on ubuntu 19.04 this very moment.

perhaps you mean to say that 430 is available on 19.10 without a PPA, if yes, I’m curious to know whether anything is different about it or if the PPA simply repackages it?

EDIT: OK so I guess I can’t hope for much better on 19.10 then? I mean it’s not like it’s the lower version gnome-shell which is preventing me from having any desktop at all under wayland is it?