USB Installation of Ubuntu 18.04 No Longer Working

I have 18.04 installed on a USB drive and, now, when I try to boot from it, I get a purple blank screen followed by a black one. Nothing else happens however long I wait. Nothing material has changed on my machine other than having installed the latest kernel updates the last time I ran the OS. My PC is using an AMD RX560 card with proprietary drivers.

I do get the Grub menu from which I can make a number of selections, including Ubuntu (start normally), Advanced options, Ubuntu with Linux (latest 3 kernels and recovery modes), Memory test, and boot into Windows 10; however, nothing works.

I’ve tried recovery modes for the latest two kernels and nothing happens. I read on the web that - when using AMD proprietary drivers - your system can get problematic after an Ubuntu update, but I haven’t seen that before. And, I don’t have the menu option to use generic AMD drivers.

Can anyone help me with this? I’d rather not go through the process of reformatting the USB drive for use, since I have a lot of customizations in it.


check you bios … using uefi or old boot loader

Thanks for the quick reply. I’ve been using this USB stick on this PC for years (it’s an old legacy BIOS system.). That’s not the problem. As I said, it was working just fine until an Ubuntu update and now it’s not working.