Unable to access Ubuntu Mastdon Instance installed on Raspberry Pi 4

Dear Gurus,

Frankly speaking I have seen lots and lots of videos on internet and community blogs for each service (Nginx, fail2ban, iptables , resolver , port forwarding etc, but not having that luck in accessing my website hosted on (DNS bought from service provider ClouDNS pointed “A” record to public IP address of my network) Raspberry Pi (which is on LAN) on WAN.

Will you be able to guide me?
- My setup (all are dummy ip addresses for illustration purpose).

  1. my public IP - 777.333.111.222
  2. my router WAN ip - 123.332.111.222
  3. router gateway -
  4. my raspberry pi Ubuntu 18.4 server ip -
  5. my mac book from where I am using ssh to Raspberry pi -
  6. My have dns (example.com) pointed to my Raspberry Pi web server
  7. “A” record in DNS zone of pointing to 777.333.111.222

Raspberry Pi - Ubuntu setup - NGINX:

server { listen 61001;
listen [::]:61001;
server_name ;
root /home/mastodon/live/public;
location /.well-known/acme-challenge/
{ allow all; } location / { return 301 https://$host$request_uri; } }

server { listen 443 ssl http2;
listen [::]:443 ssl http2;
server_name <websitewith www; }

Raspberry Pi - Ubuntu setup - UFW setup:

**ufw status
Status: active To Action From -

10000 ALLOW Anywhere
Nginx Full ALLOW Anywhere
OpenSSH ALLOW Anywhere
61001 ALLOW Anywhere
10000 (v6) ALLOW Anywhere (v6)
Nginx Full (v6) ALLOW Anywhere (v6)
OpenSSH (v6) ALLOW Anywhere (v6)
61001 (v6) ALLOW Anywhere (v6)

Raspberry Pi - Ubuntu setup - Remote.it setup (This is to ensure that ports are opened and attached to the service

Service Name | Protocol | LAN Address | Port | Application -
http-61001 | TCP | localhost | 61001 | OK: nginx: master
http-80 | HTTP | localhost | 80 | not detected
https-443 | Secure Web | localhost | 443 | OK: nginx: master
web-port-3000 | TCP | localhost | 3000 | OK

BIND9 output for forward and reverse to my domain.

-checkconf -z /etc/bind/named.conf
zone /IN: loaded serial 2
zone 1.168.192.in-addr.arpa/IN: loaded serial 2
zone localhost/IN: loaded serial 2
zone 127.in-addr.arpa/IN: loaded serial 1
zone 0.in-addr.arpa/IN: loaded serial 1
zone 255.in-addr.arpa/IN: loaded serial 1

-checkconf -z /etc/bind/named.conf.local
zone websitenamedotcom/IN: loaded serial 2
zone 1.168.192.in-addr.arpa/IN: loaded serial 2

Check Forward …!
zone forward/IN: loaded serial 2

Check Reverse …!
zone reverse/IN: loaded serial 2

I have done setup in Linux on Raspberry Pi for my Nginx ports web-server port listen on port 80 and port 443. in No Ip its showing ports are actually listening on those ports with Ok status. Status check: I am able to access my raspberry Pi webpage from macbook which is in same LAN. Next objective: To able to access my webpage WAN - Public network/ 3g/4g mobile network

Router setup:

in DNS I am using my no-ip setup in DDNS page and connection is successful In port fowarding page

I have entered following setup :

Service Name | External port. | Local IP | Local port | type
http | 80 | | 80 | TCP/UDP
https | 443 | 192.168.1…222 | 443 |. TCP/UDP
https | 61001 | 192.168.1…222 | 61001 |. TCP/UDP

No success, I am unable to access my Raspberry Pi web-server on WAN /public network/outside of LAN network.

NOIP web configuration client check for port - showing port 80 /443 not open. does that mean its blocked by ISP or any other problem.
Thank you for reading through.

will you be able to guide where I am going wrong/ missing something. Thanks in advance.
Thanks AG

This looks like a technical support request; is it?

This site is for the co-ordination of the Ubuntu project(s), and not support. For Ubuntu Support options, please have a look at https://community.ubuntu.com/t/finding-help/709