Ubuntu Installation Keeps Failing

I am trying to install Ubuntu 20.04 onto my desktop but it keeps failing with error “The attempt to mount a file system with type ext4 in SCSI5 (0, 1, 0), partition #2 (sda) at / failed.”. I created a bootable USB using Rufus 3.11, Rufus 3.13 and balenaEtcher. The drive created with balena wouldn’t even boot. Each time I boot with the USB created using Rufus I initially get a message at the top left hand corner of the screen stating “Initramfs unpacking failed: Decoding failed”. I have spent a lot of hours searching the internet about all these errors and possible reasons for the install to fail and none of the solutions I found were helpful. I purchased a new SATA HDD to rule out any issues with my old HDD perhaps being corrupted. I even tried installing the latest version of Ubuntu available i.e. 20.10 and that gives the same error right before I begin the installation. Not sure what else I can possibly do at this point so I decided I’d make a post here and hope for some advice from the community.

Computer Specifications:
CPU: AMD Phenom II
Motherboard: GigaByte 970A-DS3P
GPU: NVIDIA Geforce GTX 1050Ti
OS: No OS Installed

The image below is the error I keep getting when I try to install. I am unable to post the “Initramfs” error at this time since I am a new member.