Ubuntu Groovy Gorilla: UX/UI issues and other nitpicks

I tried to approach Groovy gorilla as a non tech user and tried noted all the issues I faced. Most of these are UX/UI issues. Happy to hear what you guys think.

Here is the link to the blog post: https://www.bharatkalluri.in/note/ubuntu-groovy-gorilla-nitpicks/

5 Likes

Thanks for sharing your feedback, some comments

The carousel is too small in the first page of software center

there is a bug about it on launchpad

Software center should make up its mind on weather it should show up cli tools.

sounds like worth reporting on https://bugs.launchpad.net/snap-store-desktop/+filebug

Install percent keeps jumping in software center

There are issues with reporting for a long time, reported to gnome-software upstream on e.g https://gitlab.gnome.org/GNOME/gnome-software/-/issues/216

Snap packages seem to open a different Firefox instance with a different profile

Unsure what’s the issue there but seems worth reporting

Search results are not ordered by relevance

the issue seems a gnome-software upstream one (the 3.38 unpatched coming from Debian show similar ordering)

Cursors are sometime different between normal applications and snaps

could be an issue with that snap or with the theme, needs to be investigated

Do not disturb toggle transition issue

right, sounds like an upstream issue

The applications inconsistency is just softwares not actively maintained but without a better alternative. The dock spacing issues seems worth reporting. Also the settings icon screenshot seems missing or invalid?

1 Like

Thanks for the detailed reply, appreciate it.

Great! marked that it affects me.

Reported at snap store desktop launchpad

This actually does not happen with postman, which makes me think this is a snap config issue. Where can I find the snap file for programs hosted on snapcraft (for example, VS Code for which I am facing this issue)?

Hopefully people find time to have a look at this soon. I’ve had a lot of non tech friends find this very un-intuitive.

If I can find the snap config file for these programs, I can compare between for apps which it does not happen and for apps for which it does and send fixes :smiley:

Can you point me to which repo I need to report the bug at? is it dash to dock on launchpad ?

1 Like

@jamesh pointed out that vscode and slack are ‘classic’ confinement snaps so probably something special to those, creating a post on https://forum.snapcraft.io/ about that case would probably be right

I tried to poke on the postman example today but didn’t find their snapcraft.yaml, perhaps @popey could help us there? The issue has been reported. The issue could be similar to the one fixed in other snaps but without the source it’s not easy to say.

Either report it upstream or on launchpad

(the squished setting icon issue is still having an invalid image reference on your blog so unsure what that one is about exactly)

Apparently this was/is an issue with slack. This is already reported (sadly the last reply is on Nov 2019) and also a snapd bug was raised (Last update on Aug 2020).

Done, reported on launchpad (as I was not able to reproduce this on stock gnome)

Sorry about this! Fixed the link. (https://www.bharatkalluri.in/uploads/squished_settings_icon_wifi.png)