Ubuntu Frame OSK Documentation

@uaubuntu you can customize the layout to remove the “preferences” button.

The “wide” layouts are used depending on your screen size, there’s a relatively complex decision process, taking into account the keyboard width, screen scaling etc.

The last “Info: Loaded layout Path:” log tells which layout file was loaded, for example:

Info: Loaded layout Path: "/home/michal/snap/ubuntu-frame-osk/315/.local/share/squeekboard/keyboards/us_wide.yaml"


I’ve followed the installation for the osk and it seems that at startup the osk is opening automatically but without showing any keyboard layout. when you click on the screen that blank zone is disappear and the keyboard is showing correctly when enter an input field.
This is installed with ubuntu frame and wpe-webkit-mir-kiosk on a ubuntu server 22.04.3

Doesn’t anyone have the same behavior?

thanks for the help

@spirics9810 that sounds like an issue reported recently. Can you confirm?

We’ve not reproduced this on our kit, so any hints of how your setup differs from ours would be appreciated.

@alan_g This is exactly the same issue and on my system even the layout=us give this behavior ( what seems not the case for the person reporting the issue )

This is my hardware list

To be completly clear i’ve installed the minimal version of ubuntu server 22.04.03.

I’ve also made the test into a Virtual Machine with the same version of Ubuntu and following the same install procedure. On that one i’m not able to reproduce this issue.
I will try other OS on my real hardware and keep you updated with the results.

Extra info:
I get this in the log when the issue occur
Setting input sources to [(‘xkb’, ‘us’)]

(squeekboard:7352): Gtk-WARNING **: 09:42:57.803: Failed to parse /etc/gtk-3.0/settings.ini: Permission denied
Debug: Tried file “/root/snap/ubuntu-frame-osk/326/.local/share/squeekboard/keyboards/us.yaml”, but it’s missing: No such file or directory (os error 2)
Info: Loaded layout Resource: us
Debug: Tried file “/root/snap/ubuntu-frame-osk/326/.local/share/squeekboard/keyboards/us.yaml”, but it’s missing: No such file or directory (os error 2)
Info: Loaded layout Resource: us
Can’t connect to the bus: Cannot autolaunch D-Bus without X11 $DISPLAY. Visibility switching unavailable.
** (squeekboard:7352): WARNING **: 09:42:57.949: Could not connect to session manager: Cannot autolaunch D-Bus without X11 $DISPLAY

** (squeekboard:7352): WARNING **: 09:42:57.973: Failed to init libfeedback: Cannot autolaunch D-Bus without X11 $DISPLAY

This not only occur at startup of the OS but also if you stop and restart the osk.

Hi @alan_g,

This seems to be solved, since we cannot reproduce this on the same hardware as before.
Now i have another question. When opening the OSK is pushing the web browser content up. is there an option to make it overlay instead of pushing ?


The problem with that would be that the input field may well end up behind the OSK, you wouldn’t see what you’re typing. In the ideal case the OSK would communicate with the application that it’s covering (a part of) the application’s content, and have the app react accordingly, but that would require changes across the stack.

Hi @saviq,

I agree with you but sometimes you prefer to have it overlay or some people prefer like that.
That’s why i was asking