Ubuntu 20.10 gnome shell modem broadband issue

Few days ago I upgraded from Ubuntu 20.04 to Ubuntu 20.10, firstly impression was ‘Wow!’ Ubuntu has gotten pretty fast! Anyway I use too much modem instead of WiFi, but Ubuntu 20.10 doesn’t detect my USB drive as modem. So that made me downgrade again to Ubuntu 20.04 (slow 'n laggy), I don’t know what I could do to solve that issue.

May be this gnome-shell bug:


Well, still not fixed until now… I was trying to use Ubuntu 20.10 on low end PC for programming since it’s faster than Ubuntu 20.04… But with that bug it’s not helping at all.

It was just fixed upstream.

This is an annoying bug, and I filed a Lauchpad one. I also applied the upstream fix and built gnome-shell in this PPA:


That fixed it for me. Please feel free to test and let me know if it fixes it for you.

Sorry, But the fix isn’t working as planned. The USB drive never gets to be on ready mode on my PC and takes too much time to detected it… I reinstalled Ubuntu 20.10 recently in few hours ago… I’m using WIFI now.

Then it’s possible that you were also hit by this bug. It would be great if you could install usb-modeswitch 2.6.1-1ubuntu2 from groovy-proposed and let us know if that helps.

To start, usb-modeswitch 2.6.1-1ubuntu2 is very buggy for me, ever time I tried to configure a new mobile broadband connection, it was automatically ejecting and then preparing USB drive for ready mode (This time was little different because mobile broadband related settings appeared on system menu, but the rest is nearly the same). The process was repetitive, I tried many times and finally with great luck and patience it worked. Second, the mobile broadband on system menu wasn’t creating automatically a setup prompt, so I had to add new connection on network settings.

I noticed that this distro is acting like a daily build, but with those fixes is getting quite stable now…

Sorry about the inconvenience.

I don’t recall that there ever was a setup prompt in the menu, but I’m not sure.

If you still see issues with mobile broadband, please file a new bug:

ubuntu-bug usb-modeswitch

I’m not aware of any more relevant bugs which are about to be fixed…

BTW now that I’ve installed some unstable updates my distro is very slow and CPU usage is nearly always in 100% at any operation. That didn’t happen before, only wanted to upgrade:


Now I’ll erase and reinstall Ubuntu 20.10 again, next time I’ll try to install only that with software updater.

I’m getting:


It has gotten worse… It takes up 15-25 mins to be prepared for connection now:

When I try now before it’s recognized as USB Drive on any device manager tool, even if it’s ready on system menu or settings for mobile broadband connection it’s ejected and prepared for ready mode again and again (takes some time between the switch). That’s not being productive…

@burstxd: Ah, that error message is probably because you installed the package from -proposed. Try this link instead:


Thanks, I sent it right away.