Trying wayland by default again

Ok, firefox starts in wayland even without this parm but problem remains also with firefox nightly.
The problem appears when I start FF, and strangely disappears if I resize FF or start another application.
Reappears each time I close and restart FF.

Another MUCH important problem with Wayland is that all the screenshot and screencast tools are not working but the native PrntScrn and the unconfortable Cntlr+alt+shift+R

In Wayland sessions you can still record the screen with Ctrl+Alt+Shift+R, and screenshot with any of the regular [Shift|Ctrl|Alt]+PrtScn combinations.

Legacy screen recording/grabbing apps for X11 will not immediately work because Wayland does not generally allow apps to spy on each other in that way. +1 for security. But such apps should work in future once they are ported to the common interface (PipeWire) supported by GNOME.


Since it looks like there isn’t a fix for your bug in nightly I’d advise reporting it to the firefox bug tracker.

Is it only bookmarks that don’t drag or are there other things (like tabs) that don’t work?

@3v1n0, @seb128 or @vanvugt - what is the status of this in jammy? I couldn’t find an upstream issue, this trello board is private and I couldn’t find a launchpad issue. Is this being tracked publicly somewhere? Thanks!

1 Like

Most gnome-shell crashes in focal are caused by X11 itself due to bug 1782984. So in focal at least, being able to recover from gnome-shell crashes is mostly only needed in Xorg sessions anyway. Xorg sessions are also exposed to crashes in Xorg itself, which appears to be a bigger problem than gnome-shell if you omit the outlier that is bug 1782984. And there is no automatic recovery from a Xorg crash.

Unless we see an unusually high rate of Wayland-specific crashes after jammy is released then defaulting to Wayland doesn’t worry me. If anyone really has concerns about recovering from gnome-shell crashes then ‘Ubuntu on Xorg’ is still a login option.

I don’t seem to be able to access the above Trello link and don’t recall what it related to.


Hi Daniel,

What’s the state of window sharing in Jammy/Wayland (through Google Meet, Zoom or any)?
Is it ok by default or is it allowed to activate it or is this still not working for a lot of apps?


Screen sharing is something we need to remember to retest… It’s been working and not working at different times for different browsers. The official API for doing that in Wayland sessions involves PipeWire and requires that each browser/app is using the correct PipeWire version.

In case of emergency, break glass and log into ‘Ubuntu on Xorg’ instead.


Some observations as I have been using Wayland on my laptop with 20.04.4LTS for the past couple of days:

  1. Caffeine Indicator, which is in my “Start Up” programs, did not start when I logged in with Wayland. However, once I manually started it, it ran and functioned normally.
  2. Under Xorg, the “Software Updater” app starts in the center of my screen. Under Wayland, it starts in the upper left hand corner.
  3. The pop-up LibreOffice logo also normally starts in the center of the screen, but under Wayland appears in the upper left hand corner.
  4. The bucklespring app behaves oddly. When Firefox is the active application I get the clicking sounds. However, when Thunderbird is the active application, I do not. I also get the clicking when my VirtualBox Windows7 instance is the active application. Very strange. It seems to be dependent on the active application whereas under Xorg it always works.

I do not have Steam installed on my laptop and I don’t play any more CPU/Graphics intensive games on it beyond Aislerot Solitaire so I don’t know if there are any issues in that regard.

1 Like

Screen sharing

Firefox has good support now so that works with for example Google Meet. MS Teams doesn’t support it on the web AFAIK and the “app” isn’t wired up for it yet.
There exists some Electron version with support for Pipewire screen sharing now right? It’s just that no one is shipping that version yet…

@jaime-cruz, the Wayland protocol does not allow apps to specify their exact screen position, whereas X11 does. Still, you can make all new windows centered in the GNOME Tweaks app: Windows > Center New Windows = ON. Or just run:

gsettings set org.gnome.mutter center-new-windows true

For everything else please log bugs in Launchpad.