Trying wayland by default again

For what it is worth, this behaviour difference is probably down to whether you had a native Wayland app or an X11 app focused: if a Wayland app is focused, there are no X11 KeyPress events for Bucklespring to snoop on. On balance, this change is a good thing: while Bucklespring is benign, it is using the same API a keylogger malware would rely on.

With that said, it should still be possible to implement keyboard sound effects on a Wayland desktop: it would just need to be done with the cooperation of the compositor.


Can we talk about the discrimination of NVIDIA users?

I happen to be one of those, but can edit /lib/udev/rules.d/61-gdm.rules and comment this line:

DRIVER=="nvidia", RUN+="/usr/libexec/gdm-disable-wayland"

I haven’t spotted any issues by doing so with the hardware I’m using. In other words it works fine - until the gdm3 package is updated.

So even if Wayland+NVIDIA is a fragile combo sometimes, would it be possible to let users enable Wayland at their discretion in some other way than editing a package owned file outside /etc?


Understand this is NOT a deal-breaker for me. It was just an observation. I can live without bucklespring (and my wife would thank ALL of you) but it would make using the nearly silent laptop keyboard seem “odd” after all these years of using it. I always have my physical Model M keyboard on my desktop system.

Let’s please avoid emotive / loaded terms like discrimination.

Make a symlink /etc/udev/rules.d/61-gdm.rules -> /dev/null and it will persist across upgrades. That’s documented in udev(7).

We’ll enable NVIDIA + Wayland more broadly just as soon as it’s totally safe to do so.


Thanks for the tip! Seems to work as expected.

P.S. Sorry about that choice of word. I should probably have used quotes or a smiley or something.

1 Like

Hey there.

Not sure if this is the best place to report this, but Firefox and Thunderbird (both bundled) and VLC (snap version) are all horribly broken+ in Ubuntu 21.04 with Wayland on Raspberry Pi 4. First noticed the breakage on the weekend after an update.

edit: +horribly broken = window corruption.

Still no screen sharing available, though I do see Pipewire installed. Are we just waiting on integration with the Sharing Settings app?


example of the window corruption. Glitched area is the Firefox window. It still responds to keyboard commands and clicking the mangled controls does still “work”. The rendering is just distorted like this.

1 Like

@gunnarhj, the main reason not to use Wayland on NVIDIA is that it doesn’t support hardware acceleration of X11 apps (most apps and all games). They are rendered in software on the CPU, so that’s a significant step backward. But NVIDIA has a fix on the way. Also, I am advised they’re making the next driver release (470) even more Wayland-friendly. So those are the two main things we’re waiting on right now. You can find the active list of issues here.

We have bug 1887652 open for that.


@robcee, yes we are aware of that issue and are tracking it in bug 1896171. So please subscribe to that instead of discussing it here.


Thanks for the NVIDIA status report!

As regards users’ disabling of the udev rule, the method @laney mentioned is convenient since it survives gdm3 updates.

sudo ln -s /dev/null /etc/udev/rules.d/61-gdm.rules
1 Like

excellent. Thanks, @vanvugt!

Bought a new laptop with Ubuntu pre-installed from Dell and wayland is regularly un-usable;

Was told it is an 8 year old bug.


Cool, you managed to squeeze in the standalone Xwayland!

Getting fractional scaling working without changing the desktop resolution for Xwayland clients would be the next thing I’m looking forward to…

1 Like

Just tried the latest 03-17 iso on Optimus laptop and got dropped to X11 session. Why so if iGPU is Intel?

IIRC, if you have any Nvidia driver installed, then you won’t have any Wayland option available

@openmindead, @fcole90,

Yes that’s due to a simple one line rule in /usr/lib/udev/rules.d/61-gdm.rules. You can comment it out. Please also subscribe to bug 1887652 which is probably a better place for the discussion.

I see a pull request on a fix for mutter. Thanks @vanvugt! :smile:

1 Like

note for anyone else trying to get 3D accelerated apps running on an Rpi in Hirsute, run:

gsettings set org.gnome.mutter experimental-features "['kms-modifiers']"

Not sure if that requires a restart or not.

Thanks, @vanvugt!

1 Like

In Ubuntu 21.04 Wayland session starting Firefox in Wayland with MOZ_ENABLE_WAYLAND=1 firefox I can’t move bookmarks…
but I can move bookmarks after resizing FF or start another app.

1 Like

I believe you are experiencing this dragging issue in firefox which should be fixed in firefox 88 (coming later this month).
Until then you can run firefox beta or firefox nightly if this fix is important enough.

Also, ubuntu 21.04 defaults to starting firefox with that wayland variable so explicitly starting firefox with it now is redundant.

1 Like