Time required for Gparted to restore File System of eSATA connected drive?

After having stated on Twitter to Niel Druckmann that I captured video of an apparent coding error, 3 hours later my ip saw sudden substantial increase in traffic all directed at my Playstation 4 MAC address and the hard drive had been remotely impacted. It had functioned without issue for 10 months until I stated publicly that I had captured a large error in The Last Of Us Part 2’s code. They made it through my T3 modem, my physical firewall, my 3 switches (each with a software firewall different from all others, my bridge, and the last physical firewall. Then entered my PS4 Pro and effected drive data.
I am trying to restore this data but Gparted seems yo be taking an unreasonable length of time to repair the data (filesystem). It has been 9 days in a SATA II system to try and recover a 5TB drive. How long should this take? I only want to recover that 1 video (so YouTube viewers can see the visual effect of problem(s) in Naughty Dog’s code).
How long through eSATA SATA II connection should it take to work through 5TB? When benchmarking the same drive before use in my PS4 Pro by way of my Ubuntu Mate 18.04 system produced 5 297Gb results (averaging the 5 by adding all, then dividing by 5).
How long shoulx this be taking as 9 days already seems far too long to be a reasonable attempt without completion.

Thank you for your help,


I agree 9 days sounds suspiciously long. It would take much less time to copy a drive that size.

Maybe check your kernel log:


and see if there are any SATA/sda/sdb/… errors mentioned. If there are any such connection/communication errors in your kernel log then continuing with Gparted might be pointless.

1 Like

If and when you you do finish the restore operation I suggest opening the ‘Disks’ app and look at the ‘SMART Data & Self-Tests’ for the drive.

1 Like

I am well beyond attempting this action through Gnome Disk Utility. It is unable to access the contents, claiming that the drive is not formatted (hence my attempt with gparted which was unable to mount any of the partitions). That is why I attemptef the recovery (as even testdisk found no mp4 files [ever, it seems the code for mp4 files in testdisk has an error perhaps as it couldn’t even find them on my video back up drive packed to the gills with mp4]). Thank you for suggesting dmesg. No harm in looking.

What I suggested does not involve accessing the drive contents.

1 Like

The application can do nothing with the drive without formatting it. Can display nothing more than display the partitions, model numer and serial number. Gparted was able to do substantially more, excluding completing the recovery thus far (over I think I may have given an incorrect period of time up front, it’s been running for 3 days now). Perhaps the action by what certainly seems to have likely been Sony or Naughty Dog based on the VERY specific target.

In the theater after the asian guy saves Ellie. Her character and the girlfriend are in an office where photos are on the table/desk and one of them lifted from the table with no arm holding it for perhaps 40 seconds or so. Then while it was lowering, Ellie’s arm’s internal surface with nothing inside the arm appeared. Hence my statement to Druckmann of code errors in the game and my mention of the video I had captured and would make public if he failed to reply as he had for weeks in a row. Hours later the drive shut down suddenly and upon reboot it refused to provide any option apart from reinstalling the OS, wiping absolutely everything out with it. That’s why I tried to recover it, so I can post it on YouTube and make it even more public by sending it to Neil Druckmann on Twitter where the entire world can see it. He can’t reasonably refuse to respond then.

Here’s what the application is doing (I set it to Very High priority perhaps 10 minutes into use, hoping it would use multiple threads instead of the only 1 core thread it had been using [but while not multithreading, it did increase disc access a very small amount]). And once again I was wrong about the legth of time it has been running. I changed to this distro (which I thoroughly altered to suite my needs and desires) to try and perform the function as Fedora 32, Ubuntu (Pinguy) 14.04, Ubuntu Mate 16.04 then finally Ubuntu Mate 18.04 (never been able to update any Ubuntu Mate versions on this device as it absolutely always claims that libbluray2 cannot be upgraded due to default-jre-headless not being updateable, searching reveled libasm4-java not being updatable (stopping libasm-4 update. libasm4-java could not be updated due to default-jre-headless not being updateable due to libfontconfig1 not being upgradable. I attempted removal of each component from the initial cause down to the final cause, libfontconfig. But untinstalling libfontconfig cannot reasonably be removed as it takes Marco, many Mate components and substantially more desktop components with it. As a result the is no way to update 14.04 to 16.04 to 18.04 to 20.04 as an immediate result. As well 16.04 cannot be upgraded to 18.04 to 20.04 as a result as well as my 18.04 system unable to be updated to 20.04 due to the exact same reason. I’ve tried through Synaptic (to update the apps causing the problem) terminal to update the apps causing the problem, update manager cannot due to the problem, and the app allowing (install, download remove) deb packages (forgot the name at the moment) installation also fail and is where I was able to see the cause of each (hence the names of each component and dependency I meantioned being presented to me. So I attempted to alter each deb by way of alien, but to no benefit. Can’t move to the latest OS version as a rresult.
Here’s it running and display of how long:

Darn, discourse.ubuntu.com for this topic suddenly isn’t displaying the circle arrow for replies, hence this reply growning longer and longer as it’s the only way I can display any additional data/information/considerations/statements as an immediate result. Plus I can only post 1 of the 2 images due to this website blocking multiple images, so I cannot provide the priority setting marked “Very High” as a result…