The GNOME 3.34 migration (what are your bugs?)

As regards recent changes affecting numlock: No. With that said, numlockx is always available (but that’s old stuff, of course).

1 Like

Can’t seem to rename folder, once create by dragging and dropping application the system assigns folder name. But now I have two Internet folders and no way to rename one of them (or at lease I can’t seem to find a way).

Do you mean this

Yes, I thought that was going to be part of the 3.34. Maybe mistaken, but could’ve sworn I saw a video online demonstrating that.

AFAICS it will, the ticket is open against 19.10. Take into account that it’s a downstream bug.

@mohan-ram, there is a numlock related fix pending upstream:

I guess if that lands it might fix our numlock bugs.


Awesome, thanks for the update.

Mutter 3.34.1 is in the release pocket now.

And the numlock bug seems to be fixed for me.

The strange thing is: Switching to tty3 or tty4 from GDM still disables the numlock. I can’t remember if that was always the case or if it is even expected behavior.

But at least switching to the GNOME Shell (=tty2) works now like before.

I noticed last night after doing system update, and reboot my machine, night light did not work under wayland. It works in, and prior to last night’s update it worked in wayland.

That’s bug #1847551.

Thanks, marked it as effecting me.

The commits (for bug !840) landed upstream in the master branch (there is no 3.34 branch yet). So it will be fixed when Mutter 3.34.2 migrates to Ubuntu. I guess that this will be a SRU and not on the final image. Unless both commits will be cherry picks.

1 Like

Yes it’s supposed to be in 19.10. I should be able to fix it in 48h (finger crossed) :slight_smile:


HUGE memory usage (GBs of memory in a few seconds!) when screen recording. Reported downstream in and upstream in


Not able to shutdown from login screen. I boot up my machine, and when I am at the login screen I choose to power up from the top right. But nothing happens. I have then proceed to log into my account and then initiate shutdown.

That’s bug 1847896 which was also mentioned in the Release Notes.


anyone meet Bug when use WPS office or Librel Office? i have to copy twice for a one String, sometime when i copy and past some string in WPS office it show equal is an image instead of text.

I have the except same thing and have not been able to determine where it comes from. Only happens in WPS office.

I’ve noticed that this bug is visible if you have one full-screen window or 3-5 windows. If you have two windows, or more than 5, “Activities” view functions as it should.

A very annoying bug: notifications are not actionable when focus is on the app that raised them. A big drawback in usability for WhatsApp, Slack, etc. webapps.

Reportes downstream in and upstream in

1 Like