SUSPEND fails on Lenovo e11 (Ubuntu 18.04LTS)

Hi there… I’m an amateur user, yet enthusiast for years with many distros of Ubuntu. I did a fresh install yesterday of the new LTS release, and everything worked fine out of the box except for the SUSPEND feature.

I understand in this version it is set by default to suspend when closing the lid, however, nothing happens when I close it. Moreover, nothing happens either when I select in the Tweak Tool to suspend when closing the lid or when I run $ systemctl suspend.

The outcome is:
Operation inhibited by “UpdateManager” (PID 3019 “update-manager”, user edu), reason is “Updating System”.
Please retry operation after closing inhibitors and logging out other users.
Alternatively, ignore inhibitors and users with ‘systemctl suspend -i’.

Is this a bug for this version or something particular to Lenovo models? I am using a Lenovo e11

I’ve moved this to the category because this site isn’t designed to take tech support questions. Sorry. I’d recommend using one of the official support channels listed on the page