Still cannot run `lxc storage list` after ZFS dependency woes

After snap automatically updated LXD to 5.21, things stopped working because I have ZFS <= 2.1. At that point in time, even lxc list was not functioning. This was in part addressed by an update re-introducing support for ZFS 0.8 onwards:

After this update, lxc list works again, however, lxc storage list still doesn’t work:

# lxc storage list

Error: Required tool 'zpool' is missing

As a side-effect of this, starting containers isn’t possible. Existing containers are continuing to run.

#  snap info lxd | grep installed
installed:          5.21.1-d46c406            (28460) 108MB held
# lxc version
Client version: 5.21.1 LTS
Server version: 5.21.1 LTS

Anyone got an idea how to resolve this? Afterwards, I’ll migrate all containers to a host running ZFS 2.1.

Please try refreshing to 5.21/stable track

sudo snap refresh lxd --channel=5.21/stable

Because that error suggests LXD’s snap still isn’t recognising a compatible ZFS version on your host.

What does uname -a show?

And what is your host OS version?


In addition to what Tom asked, please also report what you get from:

modinfo zfs | grep -w version


Thanks for the reply.

I tried un-holding and refreshing snap:

# snap refresh lxd --channel=5.21/stable

snap "lxd" has no updates available
# uname -a
Linux hostname 5.10.0-21-amd64 #1 SMP Debian 5.10.162-1 (2023-01-21) x86_64 GNU/Linux

It’s Debian 11:

# cat /etc/debian_version 

And zfs 2.0:

# zfs --version


# modinfo zfs | grep -w version
version:        2.0.3-9+deb11u1

zpool works from the command line, but I understand lxd has built-in tooling.

Let me know if you need any more info! :slight_smile:

1 Like should give you ZFS 2.1

1 Like

Ah lxd 5.21 doesnt include zfs 2.0 support.
So can you get zfs 2.1 support?

Ah, ok, so only 0.8 support was re-instated but not 2.0?

Correct, ZFS 0.8, 2.1 and 2.2 are currently support by LXD 5.21.

Ok, assumed it would be >= 0.8 :slight_smile:

I will try ZFS 2.1 tomorrow (I wanted to avoid messing with zfs at first if possible). Thanks for the replies!


Yes that was for Ubuntu Bionic users who were not able to get to ZFS 2.1 even by way of the HWE kernel.

I should have known/guessed to ‘hold’ a specific version of the snap package and avoid it auto-updating. Following the lxd installation instructions that wasn’t too apparent that such automatic breakage would happen. In the future, I will try to stick to apt packages.

So if you follow an LTS track (like 5.0/stable or 5.21/stable) then the min system requirements wont change for duration of series. But if you follow latest/stable its a rolling release where min requirements do change over time.

However in the past LXD snap tracked latest/stable by default if no channel was specified. So this lead to some users tracking latest/stable without knowing the implications.

With the new 5.21 series we’ve updated it to be the default snap track so doing snap install lxd will get you tracking 5.21/stable.

This way it has to be a conscious decision to refresh onto the latest/stable rolling channel.

So hopefully fewer users will be affected by this sort of issue in the future.


Updating to Debian 12 (and hence ZFS 2.1) solved this issue. The upgrade didn’t seem to break anything.

1 Like