Steam call for testing!

My libraries are on different physical drives, so it might be more problematic than having mutliple game folders on the same partition. I will try it when I get back home from work and raise an issue if it doesn’t work. IMO, my use-case is quite common, especially since Steam Deck supports hotswapping game libraries using microSD cards.

Steam uses the removable-media plug, that should always give you access to things underneath /media and /mnt … so a plugged SD card with game data should just work when this plug is connected (use snap connections steam to verify)… for the other disks, either /mnt or a bind mount (note symlinks will not work) into your games folder should give you access…

https://github.com/canonical/steam-snap/blob/main/snap/snapcraft.yaml#L363

1 Like

Please do and let us know how you get on, I agree it’s a very common use-case and this is how my Windows gaming machine is setup. We have tried on separate drives on our side via the Steam settings UI and it seems to play well.

Something to keep in mind is the filesystem a separate game drive is using. A lot of folks coming from Windows have their dedicated game drives formatted as NTFS which can cause some issues with Steam on Linux (Deb and Snap). Steam will recognize the game files and even display the games in the user’s library, but they will often fail to launch. The fix is usually to adjust mount settings in /etc/fstab or format the drive into something a little more Linux friendly.

3 Likes

I’m using ext4 for all my game partitions. I’ve given it a try and it seem that with mount --bind I am able to get snapped steam to read and write into them. I’ll be trying out Steam in a snap from now on, until I hit some unsurmountable issue.

3 Likes

Found an issue just before going to sleep - I can’t use my xbox one controller. I’ll try to check what it says in a terminal. Also, for some reason, Overcooked 2 could not restore my progress. When running the same game from the same directory with .deb steam, it works.

I put in a github issue last week as I experienced the same problem with a wired 360 controller. In my case, it was related to uinput not being listed within the snap.yaml plugs list. Are you connecting the controller with a USB cable or via bluetooth?

1 Like

I’m using Bluetooth for my Xbox One X controller and a dongle for my Steam Controller. I’m going to try both later today.

3 Likes

Any help here?

Steam Big Picture does not show the network status.

While I was able to add the ones inside my $HOME, I can’t seem to add the ones in my other drives. I was able to add the ones inside my $HOME, but not anywhere else.

I have another drive, mounted inside /home/DATA, like my 870 EVO 4TB is on /home/DATA/870E4TB.

Any idea why I can’t add stuff in there now? I can still save stuff there with Firefox.

I tried to manually add by writing to the ~/snap/steam/common/.local/share/Steam/config/libraryfolders.vdf, but no dice.

Hope there’ll be a fix for this. Gonna use the apt version in the meantime…

1 Like

We have some pending fixes to handle more cases for where your library is stored. You can track the status at https://github.com/snapcore/snapd/pull/13053

2 Likes

Would that include directories that’s still in /home but not in $HOME profile?

Yes, I think it would help for that case.

1 Like

On another note, I tested this out on a VM with VFIO setup (RTX 3060 Ti passed through)

Any idea why this is happening on Mantic (Ubuntu Unity).