Steam and can't connect on 21.04 after big update


I noticed that a big group of packages were released from hirsute-proposed recently, including the glibc 2.33 upgrade. At the same time, both Steam (native) and launcher in Wine stopped being able to connect to their backends on my system. My internet works fine otherwise and I could also run both services on Windows, so it seems to be something on my Hirsute install.
I Googled a bit and found a mention of libnss-resolve:i386, but that didn’t help things.
I don’t see anything in the logs so I’m not sure where to start looking or what to file a bug report on…
Anyone else see the same problem?

The proposed pocket isn’t intended for human consumption, so isn’t supported.

1 Like

Yeah, I mean that a lot of packages that were in proposed got moved into the main pocket the other day.

1 Like

Steam still works for me in Hirsute, with the package from Ubuntus repository.
Both opted in and out of the Steam beta.

1 Like

Wow, I solved my issue now, by installing and enabling nscd!

This solved the network related issues with both Steam and Wine for me.
I have no idea why it helped! All “getent hosts” results look the same etc…
If I stop the nscd daemon Steam immediately stops working again, so I have a great environment to test ideas.
I even wrote a program to print all the output from getaddrinfo() but it looks identical afaict.

I got the tip here…

There are a lot of solutions floating around (because this seems to be happening to a number of people on different distros) related to changing your DNS servers or the /etc/resolv.conf configurations, but none of those solutions helped me.