Status of Ubuntu support for Lenovo ThinkPad X13s

@oli, yes the fingerprint reader is broken. If you’d like to help with debugging/testing:

  1. Copy this DTB to /boot/x13s-test.dtb
  2. Boot into grub and modify the entry you want to boot accordingly. The devicetree line should read devicetree /boot/x13s-test.dtb.
  3. Boot the modified entry.

Let me know if that fixes the fingerprint reader.

Regarding 6.10, I haven’t tried any of the newer kernels yet. If you’re adventurous, you could take a mainline kernel for a spin…

1 Like

That worked the fingerprint is working again. What is the recommend location to place the dtb file? Is this the correct location, please advise.

lrwxrwxrwx 1 root root 60 May 22 20:30 /boot/dtb-6.8.0-31-generic -> dtbs/6.8.0-31-generic/qcom/sc8280xp-lenovo-thinkpad-x13s.dtb

Thanks

@okra Thanks for the testing. You can put it here /lib/firmware/6.8.0-31-generic/device-tree/qcom/sc8280xp-lenovo-thinkpad-x13s.dtb but then you need to run update-grub which copies it to /boot. If you put it directly in /boot it will get replaced by the package-provided DTB the next time update-grub runs. Note that reinstalling linux-modules-6.8.0-31-generic will overwrite your local change again.

1 Like

I don’t understand - is it not planned to offer a 24.04 iso anymore like for 23.10? Or is it just a matter of waiting?

I noticed that this kind of x13s link from the official sites and daily too were silently removed, or rather, not added for 24.04 in the first place?

I don’t want to install the old 23.10 again when 24.04 could be out any moment. But it seems impossible to find any info as to what is going on except for this one forum thread here!

@tjenare The X13s ISO for Noble has been removed from the official download page because it’s broken (as stated in the post). I’m working on it but it’s unclear atm if it comes back as an official ISO (with a future point release) or if it stays an unofficial community-supported ISO. See here for an early version.

2 Likes

I was wondering the same thing about the Noble ISOs - thanks for clarifying.

I hope there will be some notification here (or whereever) when there is an ISO that can simply be downloaded somewhere, put on USB stick, and installed, without knowledge for hacking it somehow to add missing files etc.

Sorry for the late reply. Your DTB worked wonderfully.

6.9 didn’t give me any benefits but nothing broke.
6.10-rc1, I get fingerprints without needing your DTB.

Any idea what the status is on the camera?

@oli Thanks for testing the DTB, the fix should be in the next kernel release. Re camera: I had it working on Mantic with a heavily patched kernel and libcamera. Software ISP only though. I need to check what the current state is of the different bits and pieces. Should be doable for Oracular, if time permits.

1 Like

Hi,

I’ve tried to download .iso (2024-05-06 09:25 3.1G) but install fails with message that it can’t find linux-image-generic-hwe-24.04 package.

Strangely when live is booted from USB in Settings I can see Night Light available to set altough it doesn’t do anything. In my previous attempts to set Night Light in GNOME all settings were disabled.

Thanks,

Hm. I’m pretty sure I tested this ISO so not sure what’s going on. The kernel is missing from the ISO pool though, which seems broken… Will take a look.

For what it’s worth, I am positive I have successfully installed 24.04 with the testing ISO above, but I am thinking that it may have only been successful when connected to the network. It was a bit flaky before, but now no matter what I do, I cannot get it installed. I get the same failure looking for the linux-image-generic-hwe-24.04 package.

Also, I have tried installed 23.10 and upgrading to 24.04, but that no longer works either (I have been able to do that once before the 24.04 ISO was available). I am able to get all the way to the point where I need to restart, and upon doing so, even with the 6.5 kernel, it just spits out some text too quickly to read and then goes black.

Tip. If the text goes by to quickly to read. Record a video to catch the text and when you play the video pause on the text.

I’m not sure what changed, but I just tried installing with the 24.04 ISO again (the same one I had already downloaded, though I did have to dd it again), and this time I was able to successfully install the OS and boot into it.

Great, but what changed? Last time I checked inside chroot /target didn’t had nameservers properly set, that’s why online package installation would fail, but I’m not sure how to do it before install starts.

Is night light working for you in display settings?

So at the moment I can’t actually get the Gnome settings to open at all. What I did was almost immediately install tasksel and switch to KDE with SDDM because that’s my preference. That seems to be working perfectly so far in the limited time I’ve been able to spend with it. I tried to launch a Gnome session though, and like I mentioned before, settings wouldn’t even launch.

Here’s an updated installer ISO for Noble: https://people.canonical.com/~juergh/ubuntu-concept/noble/daily-live/current/.

I’ll update the post as soon as I get the permissions back to edit it :frowning:

1 Like

Works perfect for me, thanks juergh! :slight_smile:

@juergh We just got the camera working with libcamera + Firefox - i.e. that should just start working in the near future, notably with libcamera >=0.3 (see also https://mastodon.social/@rmader/112605721850549304).