Snap update - Docker v20.10.24

NB! Older v20.10.17 base:core18 docker snap is now published in core18/stable channel. It will remain unchanged, and unlikely to receive any future maintainance.

Major Changes in latest/stable:

  • snap base upgraded from core18 to core22
  • i386 architecture builds dropped
  • snapd 2.59.1 or higher is required (currently in beta channel)
  • docker versions updated to v20.10.24
  • nftables used by default
  • compose v2 is now the default and only compose implementation
  • deprecated compose v1 removed
  • deprecated machine command plugin removed

Discuss here, or on github

The snap is being progressively released, currently at 10% phasing in the latest/stable channel. switch to tracking core18/latest track if you are experiencing any issues - but please report them, such that we can address them.

1 Like

Thanks for the update, causing my pihole/pihole:latest container stopped working after automatic update to 20.10.24 just 2 days ago. Maybe it is related to the nftables but need to investigate more deeply.

Thanks for any ideas…

Hello, I am sorry to hear that. Some questions:

  1. What OS are you using? 18.04, 20.04, non-ubuntu?
  2. If it is Ubuntu - is it desktop, server, core install?
  3. Have you rebooted since the automatic upgrade (there is currently a bug that containers may not be stopped correctly on upgrade causing issues)
  4. Have you tried adjusting firewall rules afresh?
  5. Have you tried refreshing the docker snap to core18/stable track and does that make pihole work again?
  6. How did you originally open up firewall rules for pihole? was it using ufw, firewalld, iptables?