Snap acting strange in Lubuntu?

This may appear to be a support question, but I’m hoping more that those intimately aware of the snap ecosystem might get some eyes on it and shed some light on what I’m missing.

There was a question on AskUbuntu on the Electron Player snap in Lubuntu. I managed to figure out the answer, but it’s strange that everything Just Works™ in Ubuntu 19.04, but does not in Lubuntu 19.04.

There were two issues:

  1. The snap wouldn’t appear in the menu without upgrading snapd. This was not necessary in Ubuntu, strangely. This is bizarre because Lubuntu/LXQt uses XDG specifications just like Ubuntu. /var/lib/snapd/desktop is indeed in $XDG_DATA_DIRS and the Desktop Entry is in /applications. That said, I’m left scratching my head.
  2. If the snap was already installed before upgrading snapd, it would not run correctly due to an error opening display :0. Removing it and reinstalling it fixed the problem, but maddeningly, the result has the same version and revision information. Perhaps this is a matter of reconfiguring? I’m not sure what the equivalent of dpkg-reconfigure is for snaps, but even still: what’s the relevant configuration problem?

There’s certainly a bug somewhere here, but I’m not sure if it’s with Lubuntu, LXQt, snapd, or what. Help me figure out where to file it :smile:

P.S. Just to eliminate the suggestion, I tried installing on the command line and not using Discover as the OP did and it made no difference.

@wxl, I would just report it in the Snapcraft forum.

1 Like

You are recommended that you use Synaptic Package Manager Instead of Discover and good luck!

Sorry but that’s not helpful. Read the P.S. in the original message.

Have you tried xdg-desktop-menu forceupdate?

You should try asking in Lubuntu forums.

I appreciate your suggestion of the Lubuntu forums. They’re relatively new, so that’s good advice. That said, I’m the head of QA at Lubuntu, so I don’t think it would help for me to try to answer my own question. :rofl: I’m just not an expert with Snaps.

The forceupdate is an interesting thought. It does make a difference with sudo, so perhaps there’s some sort of race condition. Still, not being clear enough on Snaps (if it were a normal package, I’d just blame a postinst), I’m not sure if this is with the inner workings of snapd or with the actual snap package itself.

That and it doesn’t resolve the issue that electronplayer doesn’t run right unless snapd is upgraded, which is not the case in Ubuntu.

Anyways @Khaotic had the right answer to this: the Snapcraft forum is the place to go. I’ll take it up there.