Refreshing the Ubuntu Desktop Installer

I’m a bit scared :fearful:
It reminds me a similar attempt (of which I appreciate the intent :wink:) that is having a bed side effect on Ubuntu 20.10 and at the moment also 21.04:
The installer expects to find an EFI partition on a computer with BIOS

This issue doesn’t affect system-upgrade or installation erasing the entire hard drive (in this case EFI partition is automatically created).
But in any other case installation fails, unless you are aware of this problem… and most people don’t really expect this.
And even expecting this, workarounds can be difficult.

I’m afraid that if all the efforts are going on a new installer, there will not be a fix for the upcoming 21.04. And if things go long, even 21.10 could be affected by this bad bug.

If I’m wrong, I’ll be the happiest person on the planet

The prototype screenshots seem broken. Where or who I should report to?

Indeed the screenshots in the original post are gone. @Wimpress do you know what happened there?

I’ve seen images disappear on the snapcraft forum too. This coincided with a change to the AWS bucket configuration. I think you’ll need to speak to IS @oSoMoN

1 Like

Fixed! Thanks @oSoMoN & @tai271828

1 Like

when will we find it on an Ubuntu ISO?

@corradoventu - If you like, here is an early iso - - but bear in mind this stuff is missing bare-minimum essential features, so don’t expect it usable yet.


Downloaded ISO and started install but the install window ‘Keyboard layout’ is empty (Because I have an Italian keyboard?) and also pressing ‘continue’ has no effect

Note: in the same ISO the other installer (ubiquity) works fine.

21.10 is old installer :frowning:

Yes, because the new installer is still very much in development, it’s not ready for general consumption yet. But if you feel adventurous and want to provide feedback, you can download a canary ISO, where the new installer is the default.


Try install in virtualbox from ISO dated 20211025.
The install completes but fails at end.
Screenshots and log here:

1 Like

@corradoventu - looks like at the time you installed, the Jammy archive was unhappy as some of the packages failed to download.

E: Package 'efibootmgr' has no installation candidate                                                                    
E: Package 'grub-efi-amd64' has no installation candidate                                                                
E: Unable to locate package grub-efi-amd64-signed                                                                        
E: Package 'shim-signed' has no installation candidate                                                                   

We’ve got an impish version of the daily-canary that you might be interested in.

The new install worked fine, thanks. If my tests are useful I will repeat them, let me know.
Screenshots and log here:
so far I have tested in virtual box, do you think it is safe to install in a dedicated partition?

1 Like

@corradoventu - the tests are useful. Your log helped point out jammy vs impish differences. And I appreciate that you tarred up the entire log directory, that made it easy to diagnose.

do you think it is safe to install in a dedicated partition?

Even production installers advise you to back up important data before use, and this one isn’t production yet :wink: . But I think you can do this, but please be careful which partitions you agree to format.

Before I said yes I ran thru an install with real hardware, testing a real dual-boot (linux / linux) case. I ran into the following caveats:

  1. I also ran into the same apt issue you did, but with the impish image. I suspect offline install is a little broken and will look into it.
  2. to work around this, I setup networking. I had to manually ubuntu-drivers install in the install environment, then things were fine.
  3. ubuntu-desktop-installer/subiquity cannot yet cope with repartitioning scenarios like resizing a partition or even creating a new one in free space, so you may have to use a partitioning tool ahead of time to work around this. I used the ‘Disks’ utility, which is available in the installer live environment. I then used the installer Manual partitioning steps to pick up the existing EFI partition, and install to the new partition I created.
1 Like

Try install in preallocated partition on nvme disk
snap:ubuntu-desktop-installer stable/ubuntu-22.04 133
i stopped install because last screen ‘Write changes to disk’ does not specify the partitions to be formatted.

screen Updates and other software
does not propose Updates and other third-party software

screen Installation type
does not propose ‘Install Ubuntu alongside them’

screen Allocate disk space
does not show device for boot
seems not recognising the swap partition existing on a different disk of same PC and automatically assumed as swap from Ubiquity

note: same problems also trying install on SSD disk partition sda2


corrado@corrado-jj-1023:~$ sudo lsblk -o NAME,LABEL,SIZE,FSUSE%,FSTYPE,MOUNTPOINT
[sudo] password for corrado: 
loop0                    99,4M   100% squashfs /snap/core/11993
loop1                    61,8M   100% squashfs /snap/core20/1169
loop2                   150,4M   100% squashfs /snap/firefox/631
loop3                       4K   100% squashfs /snap/bare/5
loop4                    65,2M   100% squashfs /snap/gtk-common-themes/1519
loop5                   242,3M   100% squashfs /snap/gnome-3-38-2004/76
loop6                    54,2M   100% squashfs /snap/snap-store/554
sda                     465,8G                 
├─sda1      p1-focal       32G        ext4     
├─sda2      share1         32G        ext4     
├─sda3      backupp     369,9G    24% ext4     /media/corrado/backupp
├─sda4                      8G        swap     [SWAP]
└─sda5      share2       23,9G        ext4     
sr0                      1024M                 
nvme0n1                 476,9G                 
├─nvme0n1p1 ESP           250M    19% vfat     /boot/efi
├─nvme0n1p2 n2-focal       48G        ext4     
├─nvme0n1p3 n3-jj-1025     48G    42% ext4     /
├─nvme0n1p4 n4-ii-beta     48G        ext4     
├─nvme0n1p5 n5-impish      48G        ext4     
├─nvme0n1p6 DELLSUPPORT   1,8G        ntfs     
└─nvme0n1p7 dati        282,9G        ext4     

I am trying to figure out whether the adoption of subiquity here means that we can also use Cloud Init.

I am trying a Packer build with the boot_command shown below. The logic is to press c to get to the grub> prompt, and then enter the other commands as shown.

As a means to boot, that works, in that the VM boots, and the net.iframes option is applied (interfaces are named eth0…).

What does not seem to work is the ds option. There is no /var/log/installer or /var/lib/cloud, so no log files, which implies no Cloud Init, I think.

The /proc/cmdline is what I expect.

Should this be working?

  boot_command        = [
    "linux /casper/vmlinuz \"ds=nocloud-net;seedfrom=http://{{.HTTPIP}}:{{.HTTPPort}}/\" net.ifnames=0 autoinstall quiet --- ",
    "initrd /casper/initrd<enter><wait>",

This does work with this image:

In the sense that the user-data is being read.

There are problems with my user-data that I shall need to debug. I’d rather debug those problems with a build that has a higher level of quality than a canary build.

I did try this image:

But the user-data was not being read.

So, is there a suitable image that I can test from the “impish” releases that has a higher level of quality than the canary release please?



As an update, with this image:

The same user-data works as expected.

There are 2 discussions about Ubuntu Desktop Installer. Which is the right one? Why two? Wouldn’t it be better to unify them?


A sensible suggestion by @corradoventu, as this thread was originally about the building-blocks and progress of creating the new installer.

Now that this software has been created and is in testing, let’s move discussion to the existing testing and discussion thread: New Desktop Installer Preview Build

If I’m mistaken and somebody really wants this thread left open, PM me and I’m happy to revert.