Problems to add Chinese layout to Ubuntu 18.04

Until yesterday, I used Ubuntu 16.04 LTS. But lastnight I decided to switch to the next version (Ubuntu 18.04 LTS) and thought that I would not run into problems. I did not upgrade 16.04 to 18.04, but made a clean installation of the system, because at first I tried to upgrade, but there were problems with setting up my scanner.
However, the problem arose where I did not think. Usually I use 3 keyboard layout: Russian (as default language), English and Chinese. I added the Chinese keyboard layout in the usual way: first I added Chinese to the system languages, then I added the Chinese keyboard (pinyin) to the keyboard layouts and added the Fcitx input method, then I made the fine settings and everything worked. In 18.04 as in the previous version, I added Chinese to the system languages, added Chinese keyboard layout, selected the input method but layout doesn’t work. First, System needs to restart to apply changes, after restarting system is not able to load desktop - only crimson background and cursor (arrowhead). No hotkeys are available and hard reset can be used to restart. After hard reset I choose Wayland mode to load desktop. After desktop is loaded it turns out that the Fcitx is not working properly: settings are not available, I can not choose Chinese layout, Fcitx freezes and restarts and after it Chinese layout disappears from layout list. I would not like to downgrade to 16.04, since I did the work to install and configure the scanner, and indeed I really liked version 18.04, if not for this problem.
Is it possible to solve it?
I need help.

Ubuntu 18.04 does not support Fcitx properly. Switch to IBus instead, and use for instance the Intelligent Pinyin IM for Chinese.

1 Like

This seems like a typical Support question, so I’ll refer you to the support venues for it.

For Ubuntu’s excellent support venues, see

1 Like