`none` is wrong for Ubuntu Frame cursor configuration

@alan_g be aware cursor=none does NOT work, when cursor=null works as expected :ok_hand:

Looks like a documentation typo/issue. You might want to adjust:

That’s the places I saw it, can’t say where else but you might have some ideas :nerd_face:

@clorichel are you confusing the instructions meant for mir-kiosk with those for Ubuntu Frame?

1 Like

For sure, I just might! And I’m sorry if I’m adding to the confusion :disappointed:

Yet, looking at https://github.com/MirServer/ubuntu-frame/blob/master/REFERENCE.md (which is the reference for Ubuntu Frame) the cursor option is inaccurately described on The config snap configuration option paragraph, and the excerpt this document took from a /var/snap/ubuntu-frame/current/frame.config file is still inaccurate to date if I’m not mistaken:

  • install ubuntu-frame
  • cat /var/snap/ubuntu-frame/current/frame.config
  • :no_entry_sign: it contains # Mouse pointer to use (auto|none|software) which is wrong, none did NOT hide the mouse cursor on my installation
  • :white_check_mark: it should contain # Mouse pointer to use (auto|null|software) which is working, null did hide the mouse cursor on my installation

Did I miss something here?

Thanks @clorichel, fix is up here:


1 Like