No unix socket /var/snap/amc/common/server/unix.socket

I am attempting to build an application using amc application create and get the error:
Error: Post "http://unix/1.0/applications?vm=false": dial unix /var/snap/amc/common/server/unix.socket: connect: no such file or directory

This error is similar what’s referenced in Troubleshoot issues with initial setup
but I don’t even see an ams group after installing the appliance.

What can I try to fix this?

Looking at logs, I see a socket running at /var/snap/anbox-cloud-appliance/common/service/internal.socket should amc be using that one? Is there a way to configure this?


Thanks for reaching out! Could you let me know if you are running the amc application create command as root?
Also, based on your message, I am assuming this happened on an appliance deployment and hence AMS remote access is not used in this case. Please correct me if I am wrong.

On a fresh install of the appliance (anbox-cloud-appliance, no remote access), I ran sudo amc application create and received the same error. I even changed to the actual root user just to check there wasn’t something weird going on and see the same error

I hope this has been answered and resolved with the information at Bug #2045988 “amc commands fail due to missing unix socket with ...” : Bugs : Anbox Cloud.

Thanks it was, sorry for the confusion on my end.