Nested virtualization on macOS

I installed multipass in MacOS, and I launched an ubuntu instance. So I tried to install kvm in it, but looks like virtualization is enabled?

grep -Eoc '(vmx|svm)' /proc/cpuinfo

this command will print 0, which means virtualization is not enabled or supported.

Is there a way I can install kvm in ubuntu instance and launch a VM in it?
I have searched many online tutorials that install kvm and launch a VM in ubuntu requires that vmx is enabled.

@winkeeeey what you’re asking for is nesting, and it’s not supported with the backends we support. The virtual CPU simply does not have the required features.

The only hypervisor that I know of that does support nesting is the commercial VMWare Fusion.

Could someone perhaps add that bit of information to this page then?
https://multipass.run/

“Hyper-V, HyperKit, Virtualbox and KVM are all natively used…”
Then further down the page under ‘Getting started’, the first tip is to launch a new instance with
multipass launch --name ubuntu-lts

but that’s not going to work in most cases, is it?
Or am I misunderstanding the problem here? I have a Windows 10 Pro workstation running on Intel i5 9th gen with virtualization enabled and virtual box as the hypervisor, but when I run

ubuntu@primary:~$ multipass launch --name myVM
launch failed: CPU does not support KVM extensions.

?

EDIT
Seems the instructions are bare bones on that page.
This helped: Installing Multipass for Windows
Turns out I was trying to create an instance within an instance by using the icon in the task tray to open the shell and launching a new instance like that. Please update the documentation?

Hi @Ed_1, the main web page indeed is just a tiny primer to what you can do with Multipass.

The status icon lets you access existing instances, not launch new ones indeed. Sorry if you got another impression. The focus is obviously on command line usage - did you try Windows Terminal yet?