Multipass wants to occupy port 53 with dnsmasq - conflict with running DNS resolver


I’m on Ubuntu 20.04.1 Server.

When installing multipass, it also tries to start dnsmasq on port 53, which conflicts with my existing and running DNS resolver (Unbound).

This means that dnsmasq does not start when installing multipass, but when I reboot my server, dnsmasq starts first, and Unbound can not start.

Is it possible to use multipass without starting dnsmasq on the host machine?


Hi ameinild, it’s actually the other way around, you need unbound to not bind to the Multipass bridge. Multipass needs control of the network it’s creating for its instances.

By default the bridge is mpqemubr0, just have Unbound ignore that one and you’ll be good.

Thanks for the answer - I’ll look into how to disable Unbound for a specific interface then.

Old thread, but I had a similar issue between multipass and dnsmasq after upgrading to Ubuntu 22.04. Solved it thusly:

printf "%s\n%s" "bind-interfaces" "except-interface=mpqemubr0" | sudo tee /etc/dnsmasq.d-available/multipass
sudo ln -s /etc/dnsmasq.d-available/multipass /etc/dnsmasq.d/multipass
sudo systemctl restart dnsmasq