Multipass on Apple Silicon

What utility is there in running Multipass on Apple Silicon, beyond just spinning up instances of Ubuntu in a walled garden?

I address this question to any user in a similar circumstance because I think I may be missing something.

I’m especially interested in hearing from members of the Multipass-on-macOS dev team because I think they really ARE missing something.

When attempting to launch an instance with:

multipass launch --network en0 --network name=bridge0,mode=manual

Multipass returns:

launch failed: The bridging feature is not implemented on this backend

That “backend” on Apple Silicon being the default QEMU driver.

Documentation tells us Multipass’ ability to create a bridged interface is dependent on VirtualBox being installed on the host Mac and the user switching to the VirtualBox driver.

But of course, VirtualBox does not run on ARM processors and reading the tea leaves over at Oracle, likely never will.

This leaves users of Multipass on Apple Silicon in a bit of a Catch-22. We can neither create bridge interfaces with the default QEMU driver nor can we run VirtualBox and invoke its driver.

Since it appears that QEMU is the only driver available for the new Mac ARM processors I’ve had to recommission an Intel Mac new in 2010 and hack it to run Catalina to get Multipass and VirtualBox running in the same space just to get a feel as to how Multipass can save me cycles spinning up instances of Ubuntu.

To be honest, I’m not sure its any easier than cloning VMs in VirtualBox already configured with bridged interfaces.

What have I missed?

% multipass networks

networks failed: The networks feature is not implemented on this backend.

Hmmm… seems quite a few “features” are not implemented on the qemu backend.

Is there a list somewhere? More interesting, is there a ROAD MAP of which features will be implemented and when?

@gurufaru well you completely missed to run Ubuntu natively on Apple Silicon. I also disagree to call Apple a walled garden.

1 Like

The subject is Multipass running on macOS on new Apple processors. I made no mention of running Ubuntu on bare metal Macs.

As for my reference to a “walled garden”, Multipass’ inability to create a bridged interface (again, on Apple Silicon running macOS with the default QEMU driver) means the instances of Ubuntu Multipass creates are “walled off” on their own separate network, and do not appear to my router as every other VM running in say VirtualBox on my Intel machines or UTM running on my Apple Silicon boxes.

@tar Indeed, the fact that UTM implements such a feature with near bare-metal performance using the QEMU driver on Apple Silicon tells me that the Multipass-on-macOS dev team have indeed missed something quite important.

I’m just asking “Is it on someone’s roadmap?”

PS: UTM also brings into question the utility of LINUX on bare-metal Apple Silicon as any performance gains would be marginal and graphics would suffer but I will keep an eye on the Asahi team. I may even try to run it on a VM in UTM. Thank you Alex Cheers.

1 Like

Hi @gurufaru,

We currently are in the process of making a new Multipass release (1.9) that includes bridged networking support on Apple M1’s using Multipass.


Thank you Chris. That feature will be most welcome. Cheers! :wink:

1 Like

Just created an account specifically to say thank you! This is extremely appreciated


To anyone else stumbling here, we have a pre-release package here:

1 Like

THANK YOU ONE AND ALL (yes i’m shouting) for this terrific update!

It’s just what the guru ordered. With it I successfully ssh’d into my Ubuntu instance created in Multipass running on an M1 Mac Mini from a MacBook – after spending a few minutes solving the infamous “Permission denied (publickey)” riddle. (Perhaps more about that in another post)

Then inspired by late night talkshows with Ubuntu playing the guest-host, I ran LXD init and created a container running Ubuntu (running in a Multipass VM running Ubuntu), installed apache and added a proxy listening on port 80.

Then from any browser on any machine on my network I enter the IP address of the Ubuntu instance running in Multipass assigned by my router and bingo, the Apache page running in a container appears.

Thanks again.


A post was split to a new topic: Gfortran error on Multipass

How full features is multipass on Apple M1 architecture? I am looking at getting an M1 Max laptop, fully configured, and an M1 Ultra, fully configure, to run Ubuntu 20.04 servers. I will run a number of products as development machines: .net 7 linux, nginx, Wordpress, OpenSSL,sshfs, Moodle, discourse, superset, CKAN, My SQL, postgress, Tika, Redis, Solr, elasticsearch. I Will this be a productive Development environment? Is it stable?

Hi @bainmckay, I think Multipass should be able to meet your needs there. Did you end up getting those M1s? How’s everything going?

2 issues:
1.) I have an (m1) Apple Studio Ultra, fully configured, and a bunch of intel Macs. I have it (mostly) working. I am having problems getting it to use gateway4 IPs. It keeps going 192.X.X.X.X which. dos not work for may purposes. I got one VM to listing on 10.0.x.x. But can’t get the others.

2.) Critical limitation on Multipass MacOs (Intel and SOS). No way to create a backup or snapshot is a big show stopper. I’ve corrupted many VMs trying. I need route on gateway
(network broken)

Also, I can’t get expand disk to work.

How can I:

  1. Ena

Hi @bainmckay,

Concerning your point 2.), we are actively working on VM snapshots and hope to land that feature soon.

For 1.) I am afraid I don’t quite follow. Perhaps filling in the new issue template will give us a better picture of what you’re trying to achieve.

I am able to make copies by using command line to copy the app Image and out of the content container. I intentionally corrupted image and copied backuped one back in. And it worked. So have the snapshot (albeit a hack) I was looking for.

Really liking Multipass on MacOs (M1 Ultra and Intel). Can’t use Arm image on AMD architecture. Any transforms, other than reinstall w Cloud-init?