'multipass launch appliance:nextcloud' --> Not Found


I was wanting to test out the Ubuntu Appliance for Next Cloud in a Virtual Machine. I am following the instructions listed here: {MAIN_UBUNTU_SITE]/appliance/nextcloud/vm (Note: Discourse won’t let me put 3 URLs in the post because I am a new user, so i had to mangle this link.)

I am on Ubuntu 20.04.

I am getting suck on Step 2. It says to run this command:
multipass launch appliance:nextcloud

After running that command I receive this error:
launch failed: failed to download from ‘http://cdimage.ubuntu.com/ubuntu-core/appliances/ubuntu-core/appliances/nextcloud-core18-amd64.img.xz’: Error transferring http://cdimage.ubuntu.com/ubuntu-core/appliances/ubuntu-core/appliances/nextcloud-core18-amd64.img.xz - server replied: Not Found

If I run ‘multipass find appliance:nextcloud’ the image is listed.
Image Aliases Version Description
appliance:nextcloud 20200812 Ubuntu Nextcloud Appliance

Is anyone else able to replicate this issue or provide a workaround? Thanks!

Hi @seantwie03!

Thanks for your report. Indeed, something went wrong when we updated the images - there’s a double “ubuntu-core/appliances/” in that URL. We’re on it.

In the mean time this should work for you:

multipass launch http://cdimage.ubuntu.com/ubuntu-core/appliances/nextcloud-core18-amd64.img.xz

Fixed. Thanks again @seantwie03 for reporting :slight_smile:

Thanks for the quick response. The URL you posted worked. This is pretty cool tech.